Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Newbie installing the mods, Help badly needed...  (Read 3669 times)

0 Members and 1 Guest are viewing this topic.

jeanlucfornier

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Newbie installing the mods, Help badly needed...
« on: February 26, 2008, 12:41:59 am »

I am a french newbie to forums, php programming etc...
I have installed phpbb3 and Coppermine Photo Gallery 1.4.16, all bridged, everything works fine.
I have been trying to install the mods, but have a problem:
- what is the update.php file you are talking about, it is not in the mods directory...
- I have uploaded the mods directory on my server, next to both phpbb and Coppermine libraries, is this correct?
- when you talk about the bridgemanager, is it the one in Coppermine settings?
Could you please help me.
Another question: what do you think is the best opensource "forum" to bridge with coppermine?

Thanks for your help
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9096
  • aka Frantz
    • Ma galerie
Re: Newbie installing the mods, Help badly needed...
« Reply #1 on: February 26, 2008, 08:35:06 am »

Hi,

do you know the french board ? http://forum.coppermine-gallery.net/index.php/board,38.0.html
Quote
I have uploaded the mods directory on my server, next to both phpbb and Coppermine libraries, is this correct?
you must ulpoad all files in the coppermine directory to replace the "normal coppermine files with the "moded".
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Newbie installing the mods, Help badly needed...
« Reply #2 on: February 26, 2008, 08:36:36 am »

- what is the update.php file you are talking about, it is not in the mods directory...
It comes with coppermine and resides in coppermine's root folder. To run it, point your browser to http://yoursite.tld/your_coppermine_folder/update.php. Alternatively, go to "admin tools", scroll down and click on "update database".

- I have uploaded the mods directory on my server, next to both phpbb and Coppermine libraries, is this correct?[/quoteNo. Read the docs that come with the modpack.
- when you talk about the bridgemanager, is it the one in Coppermine settings?
Unless you have another one...

Another question: what do you think is the best opensource "forum" to bridge with coppermine?
We can't answer such a question, as it depends on your needs (what features you prefer). We use simplemachines, so you might take that as our vote for SMF.

We have a strict "one question per thread" policy that you agreed to respect when signing up. Respect it in the future.
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Newbie installing the mods, Help badly needed...
« Reply #3 on: February 26, 2008, 08:44:00 am »

- there's no official bridge for coppermine. Therefore I haven't adapted one for use with the modpack. Not sure if the user contributed one works flawlessly.
- update.php is a core file (comes with coppermine and you'll find it in the coppermine root dir)
(answered while I was typing)
- you overwrite the existing coppermine files with the ones from the modpack archive (cause they are modded files)
(answered while I was typing)
- the bridgemanger is part of coppermine. You access it diretly typing http://yourdomain.com/path_to_cpg/bridgemgr.php or from within the admin tools

Coppermine supports a lot of forums. They all have advantages and disadvantages.
The modpack atm supports only a few if the bridge files the original coppermine comes with (PhpBB 2.0.18, 19, SMF 1.0x and punbb). Best supported from these are the first two. It's not hard to modify existing bridge files. But it's work and needs testing and an installed forum app. That's something I leave up to users.
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.