Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Internal Server Error on searchnew.php  (Read 9812 times)

0 Members and 1 Guest are viewing this topic.

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Internal Server Error on searchnew.php
« on: February 11, 2008, 10:13:14 am »

Hello everybody.

Unfortunatelly I am having a lot of trouble adding my photos to the website (www.gjonsaraci.com)
When I invoke http://www.gjonsaraci.com/searchnew.php for adding my photos to albums, I obtain this message:
Code: [Select]
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, postmaster@gjonsaraci.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Is there something I can do to sort this out?

Thank you

Andi
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Internal Server Error on searchnew.php
« Reply #1 on: February 11, 2008, 10:22:07 am »

Do http uploads work as expected? Do as suggested in the upload troubleshooting section of the docs.
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #2 on: February 11, 2008, 11:31:53 am »

Ok, thank you. I did what in the docs is suggested.
No errors were detected (I never used the http upload before, because I upload large ammounts of files). Here is the debug log:
Code: [Select]
USER:
------------------
Array
(
    [ID] => 13b15f98246aeb4dc0c6be180243b73f
    [am] => 1
    [lang] => english
    [liv] => Array
        (
            [0] => 829
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => Admin
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg1411_filetypes; (0s)
    [1] => select * from cpg1411_plugins order by priority asc; (0s)
    [2] => delete from `Sql155367_1`.cpg1411_sessions where time<1202722108 and remember=0; (0s)
    [3] => delete from `Sql155367_1`.cpg1411_sessions where time<1201516108; (0s)
    [4] => select user_id from `Sql155367_1`.cpg1411_sessions where session_id=md5("e712d1741dbe11fdda7a634955762de6c1340bb9272e7a6f42c0e1e23a914430"); (0.008s)
    [5] => select user_id as id, user_password as password from `Sql155367_1`.cpg1411_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `Sql155367_1`.cpg1411_users AS u INNER JOIN `Sql155367_1`.cpg1411_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `Sql155367_1`.cpg1411_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg1411_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg1411_usergroups WHERE group_id= 1 (0s)
    [10] => update `Sql155367_1`.cpg1411_sessions set time='1202725708' where session_id=md5('e712d1741dbe11fdda7a634955762de6c1340bb9272e7a6f42c0e1e23a914430'); (0s)
    [11] => SELECT user_favpics FROM cpg1411_favpics WHERE user_id = 1 (0.001s)
    [12] => DELETE FROM cpg1411_banned WHERE expiry < '2008-02-11 10:28:29' (0.002s)
    [13] => SELECT * FROM cpg1411_banned WHERE (ip_addr='88.36.206.14' OR ip_addr='88.36.206.14' OR user_id=1) AND brute_force=0 (0.001s)
    [14] => SELECT aid, title FROM cpg1411_albums WHERE category < 10000 ORDER BY title (0s)
    [15] => SELECT aid, title FROM cpg1411_albums WHERE category='10001' ORDER BY title (0.002s)
    [16] => SELECT COUNT(*) FROM cpg1411_pictures WHERE approved = 'NO' (0s)
    [17] => SELECT unique_ID FROM cpg1411_temp_data (0.003s)
    [18] => INSERT INTO cpg1411_temp_data VALUES ('1b63b6fd', 'YToxOntpOjA7YToyOntzOjExOiJhY3R1YWxfbmFtZSI7czoxMToidGVzdDBfcy5qcGciO3M6MTQ6InRlbXBvcmFyeV9uYW1lIjtzOjIzOiJtSFRUUF90ZW1wXzUwZmY5YjZlLmpwZyI7fX0=', '1202725709') (0.001s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
    [URI_array] => Array
        (
            [0] =>
            [1] =>
            [2] =>
        )

    [control] => phase_1
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.7 - OK
------------------
mySQL version: 5.0.45-community-log
------------------
Coppermine version: 1.4.12(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 5.0.22
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib/mysql -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/php/lib/php/ | .:/php/lib/php/
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 120 | 120
max_input_time | -1 | -1
upload_max_filesize | 50M | 50M
post_max_size | 8M | 8M
==========================
Page generated in 0.168 seconds - 19 queries in 0.018 seconds - Album set : ; Meta set: ;
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #3 on: February 11, 2008, 11:35:39 am »

And this is the log that appears after the file is uploaded and I click "Continue"

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Internal Server Error on searchnew.php
« Reply #4 on: February 11, 2008, 03:30:27 pm »

I did what in the docs is suggested.
Oh, really? I wonder where I missed your reply that corresponds to the instructions in the upload troubleshooting section of the docs:
Quote
When asking for support on the coppermine forum, post a link to your site and a test user account
I also wonder why you posted debug_output although instructions clearly say
Quote
Do not post debug_output unless requested.
In fact you did quite the opposite of what I suggested. Re-read the upload troubleshooting and do exactly as suggested there.
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #5 on: February 11, 2008, 05:45:31 pm »

Ok, thank you for the kind answer, and forgive me to not have understand exactly what the docs asked to do, this due to the fact that English is not my mothertongue. I rereaded the upload troubleshoting again. By the way, you did not missed anything in my reply, it was me that did not post the username and password, and I will briefly explain why.
I created a Test user account, but given that my website has only strictly familiar/personal material, I would prefer not to post this data in public - in fact, If you take a look there you will notice that user registration is closed and that anonymous users can't browse the site.

I would have sent you a personal message with the username and password, but I noticed your signature, so I will wait you to ask me for that (obviously, only if you want to).

Thank you

Andi


P.S. And what does karma mean? I have a "-1" now - does this mean that I will get banned or something?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Internal Server Error on searchnew.php
« Reply #6 on: February 12, 2008, 07:58:20 am »

You can savely post a test user account publicly and disable it once your issues are solved. This should preserve your gallery untouched and your privacy concerns respected.
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #7 on: February 12, 2008, 09:25:20 am »

You can savely post a test user account publicly and disable it once your issues are solved. This should preserve your gallery untouched and your privacy concerns respected.
http://www.gjonsaraci.com/index.php
User name: Test
Password: testuser
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Internal Server Error on searchnew.php
« Reply #8 on: February 12, 2008, 10:05:15 am »

Regular http uploads work as expected (see http://www.gjonsaraci.com/displayimage.php?pos=-4103). So there is only something wrong with batch-add.

Please do the following things:
  • Update - most recent stable release is cpg1.4.16
  • Post a deep link to one of the files you're having issues with when batch-adding - something like http://www.gjonsaraci.com/albums/path_to_file/the_file_that_causes_issues.jpg
  • Try to get access to your server's log (when webhosted, you'll probably have to ask your webhost for it) - an internal server error usually means that there is something fishy on your server setup. In fact, it's an unhandled error message. The server's logs should provide details what actually goes wrong
Please don't disable the test user account yet. We might need it after you posted your above requested data.
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #9 on: February 12, 2008, 11:00:12 am »

Regular http uploads work as expected (see http://www.gjonsaraci.com/displayimage.php?pos=-4103). So there is only something wrong with batch-add.
Yes, in fact error occurs only when I add files via FTP.
Quote
Please do the following things:
Unfortunatelly, I can not di that at the moment. I am not a skilled webmaster, and I have not the time to that now. By the way, all files that I uploaded from a month on have the same exact problem. Here is the last one: http://www.gjonsaraci.com/albums/test/blue_flower_preview_0.jpg
Quote
  • Try to get access to your server's log (when webhosted, you'll probably have to ask your webhost for it) - an internal server error usually means that there is something fishy on your server setup. In fact, it's an unhandled error message. The server's logs should provide details what actually goes wrong
Yes, I will ask them for that but I am almost sure that they will not give me access - they don't do it in any case. As I wrote, things worked very fine from August to December 2007. Is only from January that I have the same problems.
Quote
Please don't disable the test user account yet. We might need it after you posted your above requested data.
Yes of course. And thank you very much for the precious help.

Andi
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Internal Server Error on searchnew.php
« Reply #10 on: February 12, 2008, 12:45:32 pm »

Unfortunatelly, I can not di that at the moment.
Well, it's likely that this will solve your issue. Can't help you much if you don't do as suggested.
I am not a skilled webmaster, and I have not the time to that now.
If you don't have the time to perform the upgrade, then you probably don't care too much about the internal server error you encounter, so what's the actual question? No special skills needed, the upgrading process is easy and being explained in the docs.

By the way, all files that I uploaded from a month on have the same exact problem. Here is the last one: http://www.gjonsaraci.com/albums/test/blue_flower_preview_0.jpg
Uploading that file by http worked fine, so the issue doesn't lie in the file itself, see http://www.gjonsaraci.com/displayimage.php?pos=-4106

As I wrote, things worked very fine from August to December 2007. Is only from January that I have the same problems.
Then something must have changed on your server - if things used to work before and then stopped working, your webhost probably changed something server-sided. Again, my suggestion from above applies: ask them for support. You're welcome to refer to this thread.
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #11 on: February 12, 2008, 02:20:28 pm »

If you don't have the time to perform the upgrade, then you probably don't care too much about the internal server error you encounter, so what's the actual question?
I am sorry but this is not true. I care very much about the error, because I can not batch add files. I think that there is no connection between the two things: the error itself, and me in a lack of time... Maybe it's again a problem that concerns my English....
Quote
Uploading that file by http worked fine, so the issue doesn't lie in the file itself, see http://www.gjonsaraci.com/displayimage.php?pos=-4106
True. I completely agree with you. I was and still am sure that the problem is not connected to the file.
Quote
Then something must have changed on your server - if things used to work before and then stopped working, your webhost probably changed something server-sided. Again, my suggestion from above applies: ask them for support. You're welcome to refer to this thread.
Yes. I think that this is the only possible answer, and yes, I asked for support at aruba.it (the webhost). I am still waiting for an answer.

Do you know what the strange thing is? That the problem occurs only when I click over "Batch add", so when I recall this file http://www.gjonsaraci.com/searchnew.php
But, when I go directly to the tree view of my albums folder, it works very well. The full link is this:
http://www.gjonsaraci.com/minibrowser.php?folder=%2Fweb%2Fhtdocs%2Fwww.gjonsaraci.com%2Fhome%2Falbums%2F&parentform=choosefolder&formelementname=startdir&no_popup=1&limitfolder=/web/htdocs/www.gjonsaraci.com/home/albums/&hidefolders=.,..,CVS,edit,userpics&linktarget=searchnew.php
Logged

Saraci

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Internal Server Error on searchnew.php
« Reply #12 on: February 15, 2008, 09:10:08 am »

Update:

Welcome online again :)
There is little news about my "Error 500" problem.
At my webhost, they told me to add two files that searchnew.php didn't find and I did it. Here is the webserver log:
Quote
web/htdocs4/webx/logs/error_log.webx49:[Thu Feb 14 15:42:56 2008] [error] [client 62.149.129.31] File does not exist: /web/htdocs/www.gjonsaraci.com/home/templates, referer: http://www.gjonsaraci.com/searchnew.php
/web/htdocs4/webx/logs/error_log.webx49:[Thu Feb 14 15:42:57 2008] [error] [client 62.149.129.31] File does not exist: /web/htdocs/www.gjonsaraci.com/home/themes/subMerged/style.css, referer: http://www.gjonsaraci.com/minibrowser.php?startfolder=/web/htdocs/www.gjonsaraci.com/home/albums/&parentform=choosefolder&formelementname=startdir&no_popup=1&limitfolder=/web/htdocs/www.gjonsaraci.com/home/albums/&hidefolders=.%2C..%2CCVS%2Cedit%2Cuserpics&linktarget=searchnew.php&searchnew_php=1&radio=0
By the way, it did not solve the problem.
Secondly, they told me that they updated "ModSecurity" (which I don't know what is) some time ago, and that maybe the problem was connected to that.
They suggested me to modify the time that searchnew.php uses for searching files, because on their webserver, the maximum time allowed for script to execute is 120 seconds.
Is this possible?

Thanks again

Andi
« Last Edit: February 15, 2008, 09:33:06 am by Joachim Müller »
Logged
Pages: [1]   Go Up
 

Page created in 0.028 seconds with 20 queries.