Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Unknown system variable 'SQL_MODE'  (Read 7685 times)

0 Members and 1 Guest are viewing this topic.

kavery327

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Unknown system variable 'SQL_MODE'
« on: February 10, 2008, 07:34:04 pm »

I have installed a backup of Joomla to my localhost which has Coppermine installed in a sub-directory "gallery". There is no bridge installed. Joomla works just fine on the localhost, and all that appears to be missing is the Coppermine database which Joomla Cloner doesn't backup and restore. So, I manually backup the Coppermine database, but get the following message when I try to manually restore it:

SQL query:

-- phpMyAdmin SQL Dump
-- version 2.11.4
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Feb 10, 2008 at 01:10 PM
-- Server version: 4.1.22
-- PHP Version: 5.2.3
SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO"
MySQL said: 

#1193 - Unknown system variable 'SQL_MODE'

Any advice you can provide would helpful.
Logged

Nibbler

  • Guest
Re: Unknown system variable 'SQL_MODE'
« Reply #1 on: February 10, 2008, 08:10:08 pm »

Remove that line. Not related to Coppermine.
Logged

kavery327

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Unknown system variable 'SQL_MODE'
« Reply #2 on: February 10, 2008, 08:33:23 pm »

Thank you for your patience, I realize this is not a Coppermine problem now that I have been playing with it. I did what you suggested prior to your response and now it generates:

MySQL said: 

#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1 AUTO_INCREMENT=11' at line 27

Obviously this is not a Coppermine issue. I am using phpMyAdmin to create the backup script. Is there something better? I am not really up on MySQL and i just want an easy way to backup the database.

Thanks again for your help.
Logged

Nibbler

  • Guest
Re: Unknown system variable 'SQL_MODE'
« Reply #3 on: February 10, 2008, 11:52:54 pm »

When you export from phpmyadmin, select the compatibility option for MySQL 4.0
Logged
Pages: [1]   Go Up
 

Page created in 0.014 seconds with 20 queries.