Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Cannot uploade after upgrade to CPG 1.4.15  (Read 2361 times)

0 Members and 1 Guest are viewing this topic.

Mimer

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 129
    • Fjotte
Cannot uploade after upgrade to CPG 1.4.15
« on: February 02, 2008, 03:41:15 am »

Hi

I've upgradet to CPG 1.4.15 and I get this message when I try to HTTP uploade:
Code: [Select]
The file 'albums/userpics/10002/a7502_big.jpg' can't be inserted in the album

Error executing ImageMagick - Return value: 127

Cmd line :
'/usr/local/bin/convert -quality 80 -antialias -resize x60 -crop 60x60+10+0 -unsharp 0.5x0.707106781187+1.2+0.03 '\''albums/userpics/10002/a7502_big.jpg'\'' '\''albums/userpics/10002/mini_a7502_big.jpg'\'''

The convert program said:
sh: /usr/local/bin/convert -quality 80 -antialias -resize x60 -crop 60x60+10+0 -unsharp 0.5x0.707106781187+1.2+0.03 'albums/userpics/10002/a7502_big.jpg' 'albums/userpics/10002/mini_a7502_big.jpg': No such file or directory

File: /mounted-storage/home10/sub001/sc15863-WIQP/www/gal_fa/db_input.php - Line: 451
I've searched threads, but found no solution.
I've checked path to ImageMagick, permissions to folders and php settings. All should be OK.
I have another CPG 1.4.14 on same host, not upgradet yet, that works fine.

Mimer  8)

Coppermine install: http://fjotte.com/gal_fa/
Forum install:
Coppermine version: cpg1.4.15 + Strams MOD pack for 1.4.15 + Pluginpack
Forum version:
Test user account: test / test
« Last Edit: February 02, 2008, 02:04:56 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Cannot uploade after upgrade to CPG 1.4.15
« Reply #1 on: February 02, 2008, 04:40:03 am »

This is caused by a bug introduced in the 1.4.15 update. Check the announcements thread tomorrow for the resolution.
Logged

Mimer

  • Translator
  • Coppermine frequent poster
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 129
    • Fjotte
Re: Cannot uploade after upgrade to CPG 1.4.15
« Reply #2 on: February 02, 2008, 01:35:35 pm »

Deleted all lines containing the code
Code: [Select]
$cmd = escapeshellarg($cmd);in include/picmgmt.inc.php and include/imageObjectIM.class.php

HTTP uploade and Batch add using ImageMagick works again  :)

I did the same in include/picmgmt.inc.php from Strams MOD pack and uploade works fine.

Mimer  8)

(Sorry for the double post  :-[)
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.