Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: donīt seem to get admin rights after logging in  (Read 4584 times)

0 Members and 1 Guest are viewing this topic.

susimac

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
donīt seem to get admin rights after logging in
« on: January 06, 2008, 04:39:29 pm »

Hi,
just installed version 1.4.14. No problems during install. (in fact, I did a second install from scratch). Then went to "login" and logged on using the admin username and password I specified during install. Was welcomed into the gallery but donīt seem to be seeing the menu intended for people with admin rights. For example I donīt get a link to a Config page as the documentation makes me believe I should under point 2.2.2.

https://80.252.121.106:8443/sitepreview/http/wuppdich.com/gallery/index.php

I noticed a few other "oddities" - maybe they are related and help with trouble-shooting:
1) I get the red error message "Warning your browser does not accept script's cookies" on the login page, both in Firefox and I.E., even though I enabled cookies and even specifically enabled them for my site.
2) Once Iīm logged in I donīt see a "logout" link - in its place is a "login" link
3) if I go to admin.php or versioncheck.php I get the error: You don't have permission to access this page. 
4) I also checked the mySQL database tables for users and usergroups and I can see myself listed as an active user with user_id=1 and user_group=1. I understand that the latter means user_id=1 has admin rights. When I check the sessions table I notice that visits from user_id=0 and user_id=1 have been recorded. Yet the user table doesnīt have an entry for user_id=0.

Iīd be grateful if somebody could help me with this, please. I really like Coppermine - used a previous version on a different site and so hope I can make this latest version work now for my new project. Thanks in advance.

Susi
« Last Edit: January 27, 2008, 04:53:33 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: donīt seem to get admin rights after logging in
« Reply #1 on: January 06, 2008, 05:26:51 pm »

Might be related to this 'sitepreview' thing. Try viewing your site properly.
Logged

susimac

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: donīt seem to get admin rights after logging in
« Reply #2 on: January 06, 2008, 05:45:57 pm »

Nibbler, thanks for the quick reply. Iīm beginning to think along the same lines - maybe the paths are all a bit muddled up while my site is in this temporary location. Tried setting a base URL within the classic template.html file, but that didnīt help either. Will try again once my domain has moved completely.
Logged

sean19799

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: donīt seem to get admin rights after logging in
« Reply #3 on: January 20, 2008, 10:20:40 pm »

Hi,
I too have the same problem.
I have got the latest version of copermine and just installed everything to the server.
When i try and log in as Admin i get a meaage that says "welcom Admin" when i click continue it says i do not have permission to access this page.
I have also checked all of the file permisiions and all seem ok and writable.
Does anyone have any sugestions.

Thanks inadvanced for any coments
Logged

Nibbler

  • Guest
Re: donīt seem to get admin rights after logging in
« Reply #4 on: January 20, 2008, 10:26:07 pm »

Same answer applies to you.
Logged

susimac

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: donīt seem to get admin rights after logging in
« Reply #5 on: January 27, 2008, 04:46:15 pm »

Now that my site is in its permanent location (www.wuppdich.com/gallery)
Iīve repeated the install process and Iīm afraid same problem persists: I donīt get admin rights after logging in with my admin login credentials. Ideas anyone?
Logged

Nibbler

  • Guest
Re: don´t seem to get admin rights after logging in
« Reply #6 on: January 27, 2008, 04:47:53 pm »

You are still using the 'sitepreview' thing. Stop it.
Logged

susimac

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: donīt seem to get admin rights after logging in
« Reply #7 on: January 27, 2008, 04:52:12 pm »

Hi Nibbler, thanks, I just spotted it too, and now it works. Need to investigate why the browser defaults to the sitepreview path. Guess we can close this post now. Thanks everyone for helping out.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.