Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: The previous file could not be placed - you have succesfulyl placed all files?  (Read 6213 times)

0 Members and 1 Guest are viewing this topic.

tsecho

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

 >:(

Very annoying!!! It allowes me to browse for a file, upload it, then when i go to put it into a category and name it etc, it says

THE previous file could not be placed.

You have successfully placed all the files


Now i have tried all suggested but cant fix it...

Please view - user test pw test

http://tsecho.org.uk/gallery
« Last Edit: January 30, 2008, 05:29:07 pm by Joachim Müller »
Logged

Nibbler

  • Guest

Set the number of URI upload boxes to 0 on the groups page.

+ Update your gallery.
Logged

tsecho

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

also had this error now after setting uri to 0

Critical error
The file 'albums/userpics/DSCF0424~6.JPG' can't be inserted in the album

Error executing ImageMagick - Return value: 6


Cmd line :
/usr/bin/convert -quality 80 -antialias -geometry 99x74 'albums/userpics/DSCF0424~6.JPG' 'albums/userpics/thumb_DSCF0424~6.JPG'



The convert program said:
*** glibc detected *** realloc(): invalid size: 0x080690a0 ***



File: /home/tsecho/public_html/gallery/db_input.php - Line: 402 
Logged

tsecho

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

wont let me update it for some reason, do you have a direct link to the page that i can upgrade it.

This was done by an auto install.
Logged

Nibbler

  • Guest

To update you need to download Coppermine from our downloads page and follow the instructions.

http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#14

Had you installed Coppermine properly to begin with you would not have this problem and you would not need to immediately update from the old version the autoinstaller gave you.

Switch the resize method to GD2 in config. If that doesn't help then you need to contact you host about the glibc error.
Logged

tsecho

  • Coppermine newbie
  • Offline Offline
  • Posts: 4

Your attitude stinks!! Had i installed it properly!!

Bad day?!
Logged

Nibbler

  • Guest

Did you follow our install instructions?

No.

So did you install it properly?

No.



What are auto-installers?

There are many webhosting packages that offer pre-made scripts like Coppermine to be installed just with a single click in the webhosting control panel (usually cPanel). We can see that this is an easy and comfortable install method for newbies who have no experience in running and maintaining a website. In an ideal world, this would be the best method - end users wouldn't have to worry about database issues, FTP apps etc.


The sad story

The Coppermine team has made bad experiences with auto-installers in the past. The creators of the auto-installers have to adapt the original packages to make them work with their installers. In the past, the creators of Fantastico did so as well, but they introduced bugs into their re-made flavor of Coppermine, which resulted in strange behaviour. Sadly, the end users who encountered those flaws did not turn to Fantastico for help, but turned up on the Coppermine support board. The developers of those auto-installers are only human, and humans can make mistakes, so there's nothing wrong with the bug in itself. Subsequently, the Coppermine developers made the Fantastico staff aware of the bugs that they had introduced in the first place, asking them to fix them as soon as possible. However, they ignored the bugs for more than 18 months, during which the bug spread through the internet, resulting in even more frustrated end users seeking support from the coppermine staff on an issue that they have not been responsible for and that they could not fix themselves.

Why not use auto-installers

Using auto-installers of course has advantages. However, there are serious disadvantages as well:

  • Bugs can exist in auto-installers that don't reside in the Coppermine package that is provided by the Coppermine team

    As suggested above, the creators of auto-installers have to modify the Coppermine package to make it work with their installers. It is not unlikely that they introduce bugs, as they don't understand the app as well as the original dev team does.

  • Auto-installers usually lag behind in version count

    The Coppermine dev team creates maintenance releases to fix bugs as soon as they are discovered and fixed. The creators of auto-installers update their package less frequently. Webhosts don't apply fixes in auto-installers right when they get released. Subsequently, auto-installers often lag behind in version count, often resulting in vulnerable installs in terms of security.

  • End users don't read the documentation

     It is understandable that you don't read the entire documentation for an app that you can install with the click on a single button. This is OK - everybody likes "easy". However, if you're not forced to read the documentation, you might miss important notes.

Logged

fotke

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
  • I am doing my best, but always open for suggestion
    • Amateur photos for Your desktop

Helo, today, after fresh install of Coppermine 1.4.12 in cPanel&Fantastico I came across same problem. I solved it very easy just by changing in Admin/Files and thumbnails advanced settings/Method for resizing images from "Image Magick" to "GD version 2.x".

Hope this will work for you too,
Regards,
Zoran
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

The fact that Fantastico installs select the wrong image library (one that doesn't exist in the first place) is only one of the many flaws and negative aspects of auto-installers (see Nibbler's reply above). I understand that you're trying to help others with similar issues, but please don't try to encourage others to use Fantastico: the fact that you installed cpg1.4.12 (which has known security flaws) instead of cpg1.4.14 shows that you'd better do as we suggest and stop using those crappy auto-installers. It's mandatory to upgrade. Do so using the upgrade method we describe in our docs. Don't wait for Netenberg to upgrade Fantastico and your webhost rolling out those changes. Auto-installers suck. Your report is well-meant, but inappropriate.
Logged

fotke

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Male
  • Posts: 39
  • I am doing my best, but always open for suggestion
    • Amateur photos for Your desktop

Dear Joachim Müller,

Thank You and Your team for great piece of software. I performed an upgrade according to the documentation to the 1.4.14 version and everything went fine. You can see it at: http://www.superfotke.com/galerija

I will try to make no more errors like previous post :).

Best regards and good work,
Zoran
Logged
Pages: [1]   Go Up
 

Page created in 0.032 seconds with 19 queries.