Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Coppermine Version 1.4 not compatible with PHP5  (Read 5189 times)

0 Members and 1 Guest are viewing this topic.

timepilot

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Coppermine Version 1.4 not compatible with PHP5
« on: January 21, 2008, 01:10:55 am »

I recently had my website moved to another server at my hosting company due to access problems, meaning most of the time my site wasn't there. :o  Now they are telling me that I need to upgrade to a newer version of Coppermine. But keep in mind they already had my gallery running on this new server that has PHP5. I've provided a link for someone to look at and see if you come to form the same opinion as I do. I think they are wrong!

Link
Logged

Nibbler

  • Guest
Re: Coppermine Version 1.4 not compatible with PHP5
« Reply #1 on: January 21, 2008, 01:20:26 am »

Your include_path is wrong. Where it says . (dot) it should say .: (dot colon).

I am constantly amazed by the incompetence of various webhosts' support people.
Logged

timepilot

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Coppermine Version 1.4 not compatible with PHP5
« Reply #2 on: January 22, 2008, 07:51:33 am »

I'm told by my hosting company that I must upgrade Coppermine to the latest version so it will work with PHP5. How can this be true if it already worked on the new server, then why would I need to upgrade the gallery? Keep in mind now my gallery is restored but all of the time tech support at the hosting company is telling me I must upgrade the gallery. They even said they had to reconfigure the server just to get my gallery to work. ::)  I believe they are full of bologna! :) What do you think?   BTW Thanks for your help Nibbler!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Coppermine Version 1.4 not compatible with PHP5
« Reply #3 on: January 22, 2008, 08:57:40 am »

Your webhost is right to advice to update to the most recent stable release - if you're running anything else but cpg1.4.14, it's mandatory to upgrade for security reasons. However, your webhost is wrong to say that older versions of coppermine don't work with PHP5 - all releases of cpg1.4.x worked fine with PHP5. As Nibbler suggested: they seem to be rather incompetent - you might want to look for another webhost (you're welcome to tell them about this and maybe make them aware of this thread). If you want details, post a link to your gallery (instead of just posting a link to a screenshot).
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.