Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Fatal Error  (Read 5271 times)

0 Members and 1 Guest are viewing this topic.

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Fatal Error
« on: January 11, 2008, 08:21:01 am »

I've had this error almost 2 years ago but that's a different story. I got the same message after I uploaded 1,000+ pics. I just installed the newest version last week and never had a problem till now!!

Fatal error: main() [function.require]: Failed opening required 'bridge/coppermine.inc.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/awill/public_html/gallery/include/init.inc.php on line 239

so any help would be great!
« Last Edit: January 21, 2008, 08:36:33 am by Frantz »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #1 on: January 11, 2008, 08:22:22 am »

Post a link to your gallery for a start.
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #2 on: January 11, 2008, 08:24:19 am »

sorry that would help wouldnt it?

http://amazingwill.net/gallery/index.php
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #3 on: January 11, 2008, 08:49:52 am »

The file the error messages "complains" about (http://amazingwill.net/gallery/bridge/coppermine.inc.php) is inaccessible - I get a 403 error. Review permissions and make sure that there is no improperly-configured hotlink script (.htaccess file) that keeps coppermine from accessing that file. If you're not sure what to do, ask your webhost for support (you're welcome to show them this thread).
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #4 on: January 11, 2008, 09:21:15 am »

the permissions in my ftp or the database?
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #5 on: January 12, 2008, 06:08:06 am »

well i reuploaded everything and it still doesn't work. the file is in my ftp = both showing off on my ftp and the cpanel. its so weird. i guess i'll start all over again, ugh.
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #6 on: January 12, 2008, 06:09:09 am »

*both showing on both of my ftp and cpanel.....
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #7 on: January 12, 2008, 11:15:06 am »

Do as I suggested then:
If you're not sure what to do, ask your webhost for support
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #8 on: January 13, 2008, 07:27:24 am »

everything is in the folder, including the .htaccess. i asked my webhost but she asked if i mentioned about the file being there. i reuploaded quite a few times.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #9 on: January 13, 2008, 01:01:35 pm »

What's the content of the .htaccess file then?
The answer of your webhost is invalid - I'm aware that the file is there. If it wasn't there, you'd be getting a "404 not found" error. But you do get a "403 forbidden" error. Quite frankly: if you have shown this thread to your webhost and your webhost was not able to make heads or tails of my reply, you should really look for another webhost who knows his way around.
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #10 on: January 13, 2008, 03:43:51 pm »

oh i didn't know what shows for 403 and 404. interesting.  yea i dont think she knows much? here's the content, is it supposed to say allow instead of ignore? I was going to try that but i didnt.

# -FrontPage-

IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthName amazingwill.net
AuthUserFile /home/awill/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/awill/public_html/_vti_pvt/service.grp
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #11 on: January 14, 2008, 07:16:04 am »

That should not interfere. Maybe an .htaccess file in a folder above yours interferes. Again: ask your webhost for support.
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #12 on: January 21, 2008, 05:37:47 am »

go ahead and make this solved. i was told to reinstall and its working fine now. thanks.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #13 on: January 21, 2008, 08:48:30 am »

Thanks for returning and posting your solution. However, that piece of advice from your webhost (un-installing and re-installing) was very incompetent from your webhost - they chose the easy way out and did not bother to look into this for you. Re-installing is a matter of brute-forcing the error message to go away. Your webhost should instead have look into your webspace, searching for .htaccess files that are being taken into account for your webspace.
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #14 on: January 21, 2008, 04:55:05 pm »

well this is what my host's server manager said:

This appears to be an incorrect setting or corrupt file in their gallery. I checked all the server settings and it is showing a mismatch, and not any actual server error

Do you have a working backup we can restore?
 
That basically means you'd have to reinstall :(
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Fatal Error
« Reply #15 on: January 21, 2008, 06:07:38 pm »

They told you bull*. But after all, this incident should hopefully teach you the importance of frequent backups.
Logged

gretchi

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 20
Re: Fatal Error
« Reply #16 on: January 22, 2008, 01:25:35 am »

well i didn't know. i'm not a tech person. i didn't have to redo any of the settings, it was still there. so all i have to do is upload the pics.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.