Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Upload issue  (Read 4281 times)

0 Members and 1 Guest are viewing this topic.

Yamaboy

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Upload issue
« on: January 02, 2008, 08:52:53 pm »

I had problems uploading with an older version 1.4.10 so I upgraded to the latest version. The problem still seems to occur. I think the host changed something but I've corrected all the permissions. One error I get is when logging in (I just noticed) and the other is when I try to upload. I've set up a test account:

http://www.yamaboy.com/gallery
ID: testuser
Password: testu

This is what I see after following the [config/group change] suggestions for the uploading problem.

Thanks for the help.


>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

No file was uploaded !

If you have really selected a file to upload, check that the server allows file uploads...

File: /usr/local/psa/home/vhosts/yamaboy.com/httpdocs/gallery/db_input.php - Line: 311

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

USER:
------------------
Array
(
    [ID] => 9876fd05e961478f177eef437ae7a9e0
    [am] => 1
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 35
    [user_name] => testuser
    [groups] => Array
        (
           
  • => 2

        )

    [disk_max] => 10000
    [disk_min] => 10000
    [can_rate_pictures] => 1
    [can_send_ecards] => 0
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 0
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Registered
    [upload_form_config] => 0
    [group_quota] => 10000
    [can_see_all_albums] => 0
    [group_id] => 2
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg132_filetypes; (0.001s)
  • [1] => select * from cpg132_plugins order by priority asc; (0s)
        [2] => delete from `photos`.cpg132_sessions where time<1199299794 and remember=0; (0s)
        [3] => delete from `photos`.cpg132_sessions where time<1198093794; (0s)
        [4] => select user_id from `photos`.cpg132_sessions where session_id=md5("42c8841c81e0293adc498933a048bb23759a8d8b1e2380a5565968d8d088943e"); (0s)
        [5] => select user_id as id, user_password as password from `photos`.cpg132_users where user_id=35 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `photos`.cpg132_users AS u INNER JOIN `photos`.cpg132_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='35' (0.001s)
        [7] => SELECT user_group_list FROM `photos`.cpg132_users AS u WHERE user_id='35' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg132_usergroups WHERE group_id in (2) (0.001s)
        [9] => SELECT group_name FROM  cpg132_usergroups WHERE group_id= 2 (0s)
        [10] => update `photos`.cpg132_sessions set time='1199303394' where session_id=md5('42c8841c81e0293adc498933a048bb23759a8d8b1e2380a5565968d8d088943e'); (0s)
        [11] => SELECT user_favpics FROM cpg132_favpics WHERE user_id = 35 (0s)
        [12] => DELETE FROM cpg132_banned WHERE expiry < '2008-01-02 13:49:54' (0s)
        [13] => SELECT * FROM cpg132_banned WHERE (ip_addr='74.247.34.39' OR ip_addr='74.247.34.39' OR user_id=35) AND brute_force=0 (0s)
        [14] => SELECT aid FROM cpg132_albums WHERE visibility != '0' AND visibility !='10035' AND visibility NOT IN (2) (0s)
        [15] => SELECT category FROM cpg132_albums WHERE aid='3' and (uploads = 'YES' OR category = '10035') (0.001s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[album] => 3
    [MAX_FILE_SIZE] => 1024000
    [title] => test
    [caption] => ewt
    [keywords] =>
    [event] => picture
)

==========================
Page generated in 0.22 seconds - 16 queries in 0.004 seconds - Album set : AND aid NOT IN (22,19,21,30,35) ; Meta set: ;
Logged

SaWey

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1119
    • SaWey.be
Re: Upload issue
« Reply #1 on: January 02, 2008, 09:06:44 pm »

please go to this page: http://www.yamaboy.com/gallery/phpinfo.php
and see if uploads are enabled
Logged

Yamaboy

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload issue
« Reply #2 on: January 02, 2008, 09:21:18 pm »

Just checked, file_uploads are set to on. HTTP uploads work, anything from your local PC produces the error.
Logged

Yamaboy

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload issue
« Reply #3 on: January 02, 2008, 10:55:02 pm »

It looks as though the host changed some directory permissions (which they've randomly done from time to time) but even after changing permissions of edit/albums/users back to 777, the error still shows up. I'm stumped.
Logged

SaWey

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1119
    • SaWey.be
Re: Upload issue
« Reply #4 on: January 02, 2008, 11:08:22 pm »

Sorry, but I can't see what's going on, I hope someone else can help you
Logged

Yamaboy

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload issue
« Reply #5 on: January 03, 2008, 12:14:08 am »

Thanks for looking.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Upload issue
« Reply #6 on: January 03, 2008, 08:25:26 am »

From the docs:
Quote
Do not post debug_output unless requested.
, so don't!

Here's what others did with similar issues:
For nearly all of those issues you'll need to ask your webhost for support.
Logged

Yamaboy

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload issue
« Reply #7 on: January 03, 2008, 04:56:36 pm »

From the docs:, so don't!

Here's what others did with similar issues:



One tiny mistake. Tsk tsk. Despite my forum searching I think this link is exactly the problem I seem to be having.

Thanks.
Logged
Pages: [1]   Go Up
 

Page created in 0.036 seconds with 20 queries.