Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: problem of install directory for my galery  (Read 2741 times)

0 Members and 1 Guest are viewing this topic.

labro

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
problem of install directory for my galery
« on: December 27, 2007, 08:33:13 am »

Hallo,
I have just downloaded cpg14, unzipped and uploaded the cpg14 folder on my http://www.mlabro.ovh.org in the "www" folder and renamed cpg14 to "coppermine".
Everything seems to work but now, with respect to my previous galeries I did with porta and simple viewer, instead of finding my galery in http://www.mlabro.ovh.org, I find it in http://www.mlabro.ovh.org/coppermine.

How can I change this ? Move album directory in "www" parent folder, change coppermine setting,... ?

Thanks for help
Best regards

Marc
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: problem of install directory for my galery
« Reply #1 on: December 27, 2007, 09:23:37 am »

Quote
instead of finding my galery in http://www.mlabro.ovh.org, I find it in http://www.mlabro.ovh.org/coppermine.

How can I change this ? Move album directory in "www" parent folder, change coppermine setting,... ?
instead having the coppermine file in a folder (coppermine in your case), place all coppermine files directly in your server root folder(www in your case). Be sure to respect coppermine folder structure (don't change the subfolder names)
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

labro

  • Coppermine newbie
  • Offline Offline
  • Posts: 19
it works fine but a little messy in www root
« Reply #2 on: December 27, 2007, 09:13:36 pm »

I have moved all files to parent directory "www" and it works fine. Thanks a lot.
It is just a pity www has become so "messy" with coppermine directories (docs, images,include, lang,...) but also all the coppermine files (admin.php,getlang.php,...).
Is it the only way to do ?
Leaving coppermine dir unchanged and only moving album dir to www dir with its index.php file was not enough ?

Best regards
Marc
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9094
  • aka Frantz
    • Ma galerie
Re: problem of install directory for my galery
« Reply #3 on: December 27, 2007, 10:30:44 pm »

Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: problem of install directory for my galery
« Reply #4 on: December 28, 2007, 10:03:52 am »

Every non-trivial application consists of files in the root folder and some sub-folders. There is no way to circumvent this, and it won't hurt for the users of your site.
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 20 queries.