Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: The size of the file you have uploaded is too large!  (Read 5560 times)

0 Members and 1 Guest are viewing this topic.

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
The size of the file you have uploaded is too large!
« on: December 25, 2007, 03:14:11 pm »

Hi!

I've just installed a clean Coppermine version: 1.4.14(stable) on my server. However I have a problem when I try to upload images.
I get folowing error:

Quote
The size of the file you have uploaded is too large (maximum allowed is 0 KB) !

File: /customers/behrentzs.com/behrentzs.com/httpd.www/gallery/db_input.php - Line: 364


And this is the debug-info:

Quote
USER:
------------------
Array
(
    [ID] => 0eeca9b4123cf4cfd1a3c82a17e2d728
    [am] => 1
    [lang] => danish
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => Behrentzs
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0s)
  • [1] => select * from cpg14x_plugins order by priority asc; (0s)
        [2] => delete from `behrentzs_com`.cpg14x_sessions where time<1198587887 and remember=0; (0.001s)
        [3] => delete from `behrentzs_com`.cpg14x_sessions where time<1197381887; (0s)
        [4] => select user_id from `behrentzs_com`.cpg14x_sessions where session_id=md5("ae081eff33481477999870a852d6a681fe433eb908a60d19d038503352b1b59b"); (0s)
        [5] => select user_id as id, user_password as password from `behrentzs_com`.cpg14x_users where user_id=1 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `behrentzs_com`.cpg14x_users AS u INNER JOIN `behrentzs_com`.cpg14x_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
        [7] => SELECT user_group_list FROM `behrentzs_com`.cpg14x_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (1) (0s)
        [9] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 1 (0s)
        [10] => update `behrentzs_com`.cpg14x_sessions set time='1198591487' where session_id=md5('ae081eff33481477999870a852d6a681fe433eb908a60d19d038503352b1b59b'); (0s)
        [11] => SELECT user_favpics FROM cpg14x_favpics WHERE user_id = 1 (0s)
        [12] => DELETE FROM cpg14x_banned WHERE expiry < '2007-12-25 15:04:47' (0.001s)
        [13] => SELECT * FROM cpg14x_banned WHERE (ip_addr='62.66.179.41' OR ip_addr='62.66.179.41' OR user_id=1) AND brute_force=0 (0s)
        [14] => SELECT category FROM cpg14x_albums WHERE aid='1' (0.001s)
        [15] => SELECT COUNT(*) FROM cpg14x_pictures WHERE approved = 'NO' (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[album] => 1
    [MAX_FILE_SIZE] => 0
    [title] => Test
    [caption] => Test
    [keywords] => test
    [event] => picture
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.5 - OK
------------------
mySQL version: 5.0.32-Debian_7etch3-log
------------------
Coppermine version: 1.4.14(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.34 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.11
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/run/mysqld/mysqld.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.2
Linked Version 1.2.2
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | On | On
safe_mode_exec_dir | /surely/you/must/be/joking | /surely/you/must/be/joking
safe_mode_gid | Off | Off
safe_mode_include_dir | /usr/lib/php5 | /usr/lib/php5
safe_mode_exec_dir | /surely/you/must/be/joking | /surely/you/must/be/joking
sql.safe_mode | Off | Off
disable_functions | disk_total_space, diskfreespace | disk_total_space, diskfreespace
file_uploads | On | On
include_path | .: | .:
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/b1sendmail -t -i | /usr/sbin/b1sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 12M | 12M
post_max_size | 12M | 12M
==========================
Page generated in 0.083 seconds - 16 queries in 0.003 seconds - Album set : ; Meta set: ;

I searched this board for info, but I did not find a solution in any of the topics.
I have asked my webhost about the max file size, and it's unlimited.
So, that's whyI ended up here: http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble

The pics I've tried to upload have following information:

Pic1:
Size: 275 KB
Dimensions: 1632 x 1224px
Format: .jpeg
---
Pic2:
Size: 2,80 MB
Dimensions: 3888 x 2592px
Format: .jpeg

I just can't seem to figure out what's wrong. I changed the size values in the settings + in the groups, but with no luck.

Any help is very appriciated!
« Last Edit: December 30, 2007, 08:09:24 pm by Nibbler »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: The size of the file you have uploaded is too large!
« Reply #1 on: December 25, 2007, 03:18:26 pm »

Re-read http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#upload_trouble and the section after it and do exactly as suggested there.
Logged

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: The size of the file you have uploaded is too large!
« Reply #2 on: December 25, 2007, 03:53:19 pm »

Ah, I guess I should learn to read before I write..Sorry.

Now I've done as described. You can login with the details below:

User: testuser
Pass: test

Logged

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: The size of the file you have uploaded is too large!
« Reply #3 on: December 25, 2007, 03:54:06 pm »

Forgot the link:
http://behrentzs.com/gallery/

(Isn't it possible to edit your posts?)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: The size of the file you have uploaded is too large!
« Reply #4 on: December 25, 2007, 04:22:51 pm »

(Isn't it possible to edit your posts?)
No, this feature has been disabled deliberately due to previous abuse by others.
Logged

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: The size of the file you have uploaded is too large!
« Reply #5 on: December 30, 2007, 04:04:02 pm »

Please, anyone?
Logged

Nibbler

  • Guest
Re: The size of the file you have uploaded is too large!
« Reply #6 on: December 30, 2007, 04:29:04 pm »

Set a higher size limit.
Logged

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: The size of the file you have uploaded is too large!
« Reply #7 on: December 30, 2007, 05:10:35 pm »

Set a higher size limit.

Well, I've both tried to set it to 0 (unlimited, right?) and as many 9-numbers as I could... but I still culdn't?
Logged

Nibbler

  • Guest
Re: The size of the file you have uploaded is too large!
« Reply #8 on: December 30, 2007, 06:25:00 pm »

Pick something sensible. Neither 0 (which does not mean unlimited) or 9999999999999... are sensible values.
Logged

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: The size of the file you have uploaded is too large!
« Reply #9 on: December 30, 2007, 07:24:13 pm »

I tried to set the limit to 102400KB (100MB), but when I try to upload a certain pic I get this error:

Quote
Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 15552 bytes) AND THEN THE LINE AND FILE IT OCCOURED IN HERE.


What to do?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: The size of the file you have uploaded is too large!
« Reply #11 on: December 30, 2007, 07:50:03 pm »

Logged

CaptainB

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 23
Re: The size of the file you have uploaded is too large!
« Reply #12 on: December 30, 2007, 07:54:39 pm »

Easy now, I asked because I didn't knew it - but thanks Nibbler, that worked.
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 19 queries.