Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Looking to Hire someone to fix one issue...  (Read 8116 times)

0 Members and 1 Guest are viewing this topic.

ttanaka

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Looking to Hire someone to fix one issue...
« on: December 18, 2007, 06:20:56 am »

I already have Coppermine 1.4.4 installed and CPMFetch installed and working inside our phpBB2 forum - we have a random thumbnail show up in the left nav of the forum.

Now, I'm looking to put a random image on our index.html.  I was hoping I could simply use the same/similar commands as in our phpBB2 integration but those don't work.  There is something going on w/ the path, or with PHP, or something.

So, I have a get-image.php file (which I will later include in the index.html page).

The code of this file is simply:

<?php
  include "/photos/cpmfetch/cpmfetch.php";
   $objCpm = new cpm("/photos");
   $options = array("subtitle" => "File name : {{pFilename}}", "imagesize" => "int", "imagelink" => "int" );
   $objCpm->cpm_viewLastAddedMedia(1, 4, $options);
   $objCpm->cpm_viewRandomMediaFrom("album=1,3",1, 1, $options);
   $objCpm->cpm_close();
 ?>

I get this error:

Warning: main(/photos/cpmfetch/cpmfetch.php) [function.main]: failed to open stream: No such file or directory in /home/eproxim/public_html/get-image.php on line 2


I've also tried using a period in front of the path, and that gives me another, different error.

ERROR: Path to Coppermine incorrect. (/home/eproxim/public_html./photos//include/config.inc.php)
Fatal error: Call to a member function on a non-object in /home/eproxim/public_html/photos/cpmfetch/cpmfetch.php on line 532

So, I don't know what's going on, and I don't have time to troubleshoot this.  Please shoot me an email if someone can fix and please provide a quote/estimate, thanks!  ttanaka at gmail dot com.

Regards,

Tyson
« Last Edit: December 18, 2007, 09:56:16 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Looking to Hire someone to fix one issue...
« Reply #1 on: December 18, 2007, 08:19:57 am »

I already have Coppermine 1.4.4 installed
Then I wouldn't worry much about cpmFetch in the first place. Instead, I suggest upgrading asap - your gallery is vulnerable. Most recent stable release currently is cpg1.4.14.

Any particular reason for asking such a trivial question on the paid support section? Why haven't you posted on the free support board?
Logged

ttanaka

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Looking to Hire someone to fix one issue...
« Reply #2 on: December 18, 2007, 09:19:09 am »

Yay, got help and got it fixed!  Umm... posted here because was tired of researching and troubleshooting.  Was looking for a quick fix, posting here seemed to work, so thanks!  You can close this issue...
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 20 queries.