Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 1.4.14 + latest modpack + smf 1.1.4 critical  (Read 4994 times)

0 Members and 1 Guest are viewing this topic.

Veseliq

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
1.4.14 + latest modpack + smf 1.1.4 critical
« on: December 16, 2007, 12:38:27 pm »

Well, I've updated my gallery and installed the lattest modpack and now there is an error when I click on a thumbnail in the gallery - here is the debug info:

Code: [Select]
While executing query "SELECT c.msg_id, c.msg_author, c.msg_body, UNIX_TIMESTAMP(msg_date) AS msg_date, c.author_id, c.author_md5_id, c.msg_raw_ip, c.msg_hdr_ip, c.pid, u.avatar AS avatar_url FROM cpg149_comments AS c LEFT JOIN `modreact_modreactor`.smf_members AS u ON c.author_id=u.ID_MEMBER WHERE pid='59' ORDER BY c.msg_id ASC" on Resource id #23

mySQL error: No database selected

Well, as I was searching the boards here, I found many threads but all of them with older version of the gallery and bridge. I read that this issue should have been fixed but... now I've got it.

I've searched for a udb.base.inc file in the bridge folder - there is only udb_base.inc now and the function get_comments is just declared in the bottom of the file, but not called, so I couldn't do the "quick fix" I found in other threads...

http://www.modreactor.com/gallery/index.php

this is my gallery (now I will enable the debug info for everyone) and this is one of the topics I found about the issue:

http://forum.coppermine-gallery.net/index.php?topic=40221.msg190614#msg190614

Thank you!
« Last Edit: December 19, 2007, 02:49:23 pm by Stramm »
Logged

Veseliq

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: 1.4.14 + latest modpack + smf 1.1.4 critical
« Reply #1 on: December 16, 2007, 12:45:09 pm »

I couldn't edit my post and just wanted to say that the gallery contains comments and titles in cyrillic (1251) so many characters are now displayed wrong.
Logged

Veseliq

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: 1.4.14 + latest modpack + smf 1.1.4 critical
« Reply #2 on: December 16, 2007, 07:45:30 pm »

WOW!
I found few things while trying to resolve the problem. The method get_comments() in version 1.4.14 is called on line 2465 in file themes.inc.php and there actually WAS a commented line with the "right" query - with the solution from the topic I pointed in my previous post. But as I switched the method get_comments() with the other line with the right query, well nothing changed, just now the debug info doesn't say mysql error: no database selected but exactly:
Code: [Select]
While executing query "SELECT msg_id, msg_author, msg_body, UNIX_TIMESTAMP(msg_date) AS msg_date, author_id, author_md5_id, msg_raw_ip, msg_hdr_ip, pid, avatar_url FROM cpg149_comments WHERE pid='644' ORDER BY msg_id ASC" on 0

mySQL error:

No mysql error pointed but anyway thats probably because in the get_comments method if anything fails there is a call to function cpg_db_error() witch shows the exact error...
Hope this helps as I'm totally confused :(
Logged

Veseliq

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: 1.4.14 + latest modpack + smf 1.1.4 critical
« Reply #3 on: December 17, 2007, 08:37:00 am »

FIXED!

It was all my mistake - the line I uncommented wasn't the same as the one posted as solution in the other topic. Now it's all fine :)
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: 1.4.14 + latest modpack + smf 1.1.4 critical
« Reply #4 on: December 17, 2007, 10:25:36 am »

Have you properly upgraded?? Uploaded all files etc. ? Should work without the need to modify anything.

Veseliq

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: 1.4.14 + latest modpack + smf 1.1.4 critical
« Reply #5 on: December 19, 2007, 01:03:09 pm »

Sure I did so, I uploaded all files, ran update.php, rebridged the forum, etc... Dunno, now it is OK...
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 20 queries.