Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: imagemagic return value 11  (Read 3776 times)

0 Members and 1 Guest are viewing this topic.

edombrower

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
imagemagic return value 11
« on: December 08, 2007, 06:03:14 pm »

can't find a good resolution to this error:

The file 'albums/userpics/Dodo_tree_01~0.jpg' can't be inserted in the album

Error executing ImageMagick - Return value: 11

Cmd line :
/usr/bin/convert -quality 80 -antialias -geometry 87x100 'albums/userpics/Dodo_tree_01~0.jpg' 'albums/userpics/thumb_Dodo_tree_01~0.jpg'


The convert program said:


File: /home/edddom/public_html/gdcmedia/creative/db_input.php - Line: 402


[I have followed all the recommended steps]
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: imagemagic return value 11
« Reply #1 on: December 08, 2007, 06:38:02 pm »

http://forum.coppermine-gallery.net/index.php?topic=28652.0
Does this happen with known-good images as well?

[I have followed all the recommended steps]
No, you have not. Do exactly as suggested in the upload troubleshooting section of the docs.
Logged

edombrower

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: imagemagic return value 11
« Reply #2 on: December 10, 2007, 08:12:39 pm »

clearly you can tell I haven't, but I can't see a step that I haven't done.

(btw, if I resave the image in ImageConverter, it uploads... is there something about newer filetypes with Imagemagik?)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: imagemagic return value 11
« Reply #3 on: December 10, 2007, 08:17:43 pm »

clearly you can tell I haven't, but I can't see a step that I haven't done.
Let me quote from the docs, highlighting the stuff that you apparently failed to read:
Quote
Asking for support on upload issues

When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested. If you want fast results, you should disable admin approval for the group the test user is in, so supporters can tell instantly what is wrong without needing to double-check.

When people have issues with uploading and decide to post their question on the Coppermine support board, they usually are told to read this upload troubleshooting section. Many of them fail to do so properly, which results in frustration both for users as well as supporters. To make this absolutely clear: the above mentioned steps are absolutely mandatory, no matter what skill level you have, no matter what upload method you have troubles with. Failing to do exactly as suggested will result in your request for help being ignored. Yes, this applies to you. We mean it!

And is there any specific reason for not answering the other question:
Does this happen with known-good images as well?
I have asked this for a particular reasons. Just ignoring everything I say will make it more likely that you're going to get ignored as well. After all, I'm not asking for free support from you, but vice versa, so I can expect that you do your homeworks.
Logged

edombrower

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: imagemagic return value 11
« Reply #4 on: December 10, 2007, 10:25:41 pm »

Just finished trying to upload an image that previously did upload... it did work...

here's the URL: http://gdcmedia.dombrower.com/creative/login.php
id: test user
pw: tester

The images that are not uploading are JPGs from a new Mac using photoshop.. JPG format... if I import them to imageConverter on the mac and simply save it, then upload it, it works.

LMK if I've got all the steps right now.

Thanks for your patience.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: imagemagic return value 11
« Reply #5 on: December 11, 2007, 07:05:43 am »

Make sure the jpeg images are in RGB - only RGB images can be processed. CMYK, Pantone or whatever you might have used will not work.
Logged
Pages: [1]   Go Up
 

Page created in 0.048 seconds with 20 queries.