Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: no subdirectories in albums  (Read 2496 times)

0 Members and 1 Guest are viewing this topic.

jochenandries

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
no subdirectories in albums
« on: December 11, 2007, 08:28:08 am »

Hello all,

I have about 7 websites where coppermine is doing it's job.
Now I wanted to create a webgallery online for the company I work for. (www.plopsa.be)

It's running on an internal machine with WAMP 5.  It's the first time I did this, I have several Joomla sites running on it, but it's the first coppermine-install.

I wanted to upload about 200 pictures from a party we had last friday.
In albums I made a directory where I placed all the pictures
In coppermine I made an album like I used too.
I want to add pictures, but coppermine tells me there are no folders in albums...
Ooooh yeah, there are 3 folders (with pictures) there !!

Yesterday I searched the whole day here on the forum, but I couldn't find the solution :-(

What I think it's strange is that he' looking in : /C:\WAMP\www\Gallery\albums/
It's not working on the "webserver" nor on an other machine...

Here's the debug-info:
USER:
------------------
Array
(
    [ID] => 49d055fc8d143fe55e8d480c87b036ee
    [am] => 1
    [lang] => dutch
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => administrator
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg14x_filetypes; (0s)
  • [1] => select * from cpg14x_plugins order by priority asc; (0s)
        [2] => delete from `Gallery`.cpg14x_sessions where time<1197354075 and remember=0; (0s)
        [3] => delete from `Gallery`.cpg14x_sessions where time<1196148075; (0s)
        [4] => select user_id from `Gallery`.cpg14x_sessions where session_id=md5("f945134120dc950ddd4fb308dae7bcd873ed11fc98fa3fe156ad608f2abeac2f"); (0s)
        [5] => select user_id as id, user_password as password from `Gallery`.cpg14x_users where user_id=1 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `Gallery`.cpg14x_users AS u INNER JOIN `Gallery`.cpg14x_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
        [7] => SELECT user_group_list FROM `Gallery`.cpg14x_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg14x_usergroups WHERE group_id in (1) (0s)
        [9] => SELECT group_name FROM  cpg14x_usergroups WHERE group_id= 1 (0s)
        [10] => update `Gallery`.cpg14x_sessions set time='1197357675' where session_id=md5('f945134120dc950ddd4fb308dae7bcd873ed11fc98fa3fe156ad608f2abeac2f'); (0s)
        [11] => SELECT user_favpics FROM cpg14x_favpics WHERE user_id = 1 (0s)
        [12] => DELETE FROM cpg14x_banned WHERE expiry < '2007-12-11 07:21:15' (0s)
        [13] => SELECT * FROM cpg14x_banned WHERE (ip_addr='192.168.37.13' OR ip_addr='192.168.37.13' OR user_id=1) AND brute_force=0 (0s)
        [14] => SELECT aid, title FROM cpg14x_albums WHERE 1 (0s)
        [15] => SELECT COUNT(*) FROM cpg14x_pictures WHERE approved = 'NO' (0s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
    )

    ==========================
    VERSION INFO :
    ------------------
    PHP version: 5.2.5 - OK
    ------------------
    mySQL version: 5.0.45-community-nt
    ------------------
    Coppermine version: 1.4.14(stable)
    ==========================
    Module: GD
    ------------------
    GD Version: bundled (2.0.34 compatible)
    FreeType Support: 1
    FreeType Linkage: with freetype
    T1Lib Support: 1
    GIF Read Support: 1
    GIF Create Support: 1
    JPG Support: 1
    PNG Support: 1
    WBMP Support: 1
    XPM Support:
    XBM Support: 1
    JIS-mapped Japanese Font Support:

    ==========================
    Module: mysql
    ------------------
    MySQL Supportenabled
    Active Persistent Links 0
    Active Links 1
    Client API version 5.0.45
    ==========================
    Module: zlib
    ------------------
    ZLib Support enabled
    Stream Wrapper support compress.zlib://
    Stream Filter support zlib.inflate, zlib.deflate
    Compiled Version 1.2.3
    Linked Version 1.2.3
    ==========================
    Server restrictions (safe mode)?
    ------------------
    Directive | Local Value | Master Value
    safe_mode | Off | Off
    safe_mode_exec_dir | no value | no value
    safe_mode_gid | Off | Off
    safe_mode_include_dir | no value | no value
    safe_mode_exec_dir | no value | no value
    sql.safe_mode | Off | Off
    disable_functions | no value | no value
    file_uploads | On | On
    include_path | .;C:\php5\pear | .;C:\php5\pear
    open_basedir | no value | no value
    ==========================
    email
    ------------------
    Directive | Local Value | Master Value
    sendmail_from | no value | no value
    sendmail_path | no value | no value
    SMTP | localhost | localhost
    smtp_port | 25 | 25
    ==========================
    Size and Time
    ------------------
    Directive | Local Value | Master Value
    max_execution_time | 30 | 30
    max_input_time | 60 | 60
    upload_max_filesize | 2M | 2M
    post_max_size | 8M | 8M
    ==========================
    Page generated in 0.232 seconds - 16 queries in 0 seconds - Album set : ; Meta set: ;


    Greetings,
    Jochen Andries

    PS : Please don't shoot me if it's a stupid thing...
« Last Edit: December 12, 2007, 07:37:00 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: no subdirectories in albums
« Reply #1 on: December 11, 2007, 08:31:32 am »

What I think it's strange is that he' looking in : /C:\WAMP\www\Gallery\albums/
It's a known issue (as suggested in the docs) that the browsable batch-add interface doesn't work on Windows-driven servers. Turn it off to the "classic" batch-add interface.

Here's the debug-info:
Nobody asked for it. It only clutters a thread. Only post it if a supporter explicitely asked for it.
Logged

jochenandries

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: no subdirectories in albums
« Reply #2 on: December 11, 2007, 08:47:59 am »

THX,

I'll have a try !

Jochen
Logged

jochenandries

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: no subdirectories in albums
« Reply #3 on: December 11, 2007, 08:57:44 am »

Nope  :(

Still doesn't find any folders
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: no subdirectories in albums
« Reply #4 on: December 11, 2007, 09:35:55 am »

Does regular HTTP upload work as expected? If no: do exactly as suggested in the upload troubleshooting section of the docs. If yes: post a deep link to one of the files you're having issues with when trying to batch-add them.
Logged

jochenandries

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: no subdirectories in albums
« Reply #5 on: December 11, 2007, 10:23:54 am »

I managed to do it with JUpload  :D

THX for the support !!
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 21 queries.