Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Not creating thumbnails  (Read 12393 times)

0 Members and 1 Guest are viewing this topic.

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Not creating thumbnails
« on: December 04, 2007, 06:26:46 am »

Perhaps this is something that went wrong when I reinstalled Coppermine. But now when I upload new photos into my albums/uploads folder and then try to batch add them, it can't create thumbnails. Did I perhaps miss a file in uploading Coppermine to my site or what?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Not creating thumbnails
« Reply #1 on: December 04, 2007, 08:33:02 am »

Do exactly as suggested in the upload troubleshooting section of the docs.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #2 on: December 04, 2007, 05:36:10 pm »

Okay this is the debug message I get, which means nothing to me:
Code: [Select]
USER:
------------------
Array
(
    [ID] => 6e2d5af6658c28988b4dab161cb7f741
    [am] => 1
    [lang] => english
)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => Ashley
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg1410_filetypes; (0s)
    [1] => select * from cpg1410_plugins order by priority asc; (0s)
    [2] => delete from `bradpai_gallery`.cpg1410_sessions where time<1196782431 and remember=0; (0s)
    [3] => delete from `bradpai_gallery`.cpg1410_sessions where time<1195576431; (0s)
    [4] => select user_id from `bradpai_gallery`.cpg1410_sessions where session_id=md5("7a265acabc633fe6aa202d10639dfffadb900a06871a4fd5f8f5bc7822797b9e"); (0s)
    [5] => select user_id as id, user_password as password from `bradpai_gallery`.cpg1410_users where user_id=1 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `bradpai_gallery`.cpg1410_users AS u INNER JOIN `bradpai_gallery`.cpg1410_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
    [7] => SELECT user_group_list FROM `bradpai_gallery`.cpg1410_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg1410_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg1410_usergroups WHERE group_id= 1 (0s)
    [10] => update `bradpai_gallery`.cpg1410_sessions set time='1196786031' where session_id=md5('7a265acabc633fe6aa202d10639dfffadb900a06871a4fd5f8f5bc7822797b9e'); (0s)
    [11] => SELECT user_favpics FROM cpg1410_favpics WHERE user_id = 1 (0s)
    [12] => DELETE FROM cpg1410_banned WHERE expiry < '2007-12-04 16:33:51' (0s)
    [13] => SELECT * FROM cpg1410_banned WHERE (ip_addr='71.59.254.210' OR ip_addr='71.59.254.210' OR user_id=1) AND brute_force=0 (0s)
    [14] => SELECT aid, title FROM cpg1410_albums WHERE 1 (0s)
    [15] => SELECT COUNT(*) FROM cpg1410_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
    [insert] => 1
)

==========================
POST :
------------------
Array
(
    [d0000] => 54
    [pics] => Array
        (
            [0] => i0000
            [1] => i0001
            [2] => i0002
            [3] => i0003
            [4] => i0004
            [5] => i0005
            [6] => i0006
            [7] => i0007
            [8] => i0008
            [9] => i0009
            [10] => i0010
            [11] => i0011
        )

    [album_lb_id_i0000] => d0000
    [picfile_i0000] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwMS5qcGc=
    [album_lb_id_i0001] => d0000
    [picfile_i0001] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwMi5qcGc=
    [album_lb_id_i0002] => d0000
    [picfile_i0002] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwMy5qcGc=
    [album_lb_id_i0003] => d0000
    [picfile_i0003] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwNC5qcGc=
    [album_lb_id_i0004] => d0000
    [picfile_i0004] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwNS5qcGc=
    [album_lb_id_i0005] => d0000
    [picfile_i0005] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwNi5qcGc=
    [album_lb_id_i0006] => d0000
    [picfile_i0006] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwNy5qcGc=
    [album_lb_id_i0007] => d0000
    [picfile_i0007] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwOC5qcGc=
    [album_lb_id_i0008] => d0000
    [picfile_i0008] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAwOS5qcGc=
    [album_lb_id_i0009] => d0000
    [picfile_i0009] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAxMC5qcGc=
    [album_lb_id_i0010] => d0000
    [picfile_i0010] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAxMS5qcGc=
    [album_lb_id_i0011] => d0000
    [picfile_i0011] => dXBsb2Fkcy9vbmVsaW5ldGlja3MxLzAxMi5qcGc=
    [insert] => Insert selected files
)

==========================
VERSION INFO :
------------------
PHP version: 5.2.0 - OK
------------------
mySQL version: 4.1.22-standard
------------------
Coppermine version: 1.4.10(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XPM Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.22
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Stream Wrapper support compress.zlib://
Stream Filter support zlib.inflate, zlib.deflate
Compiled Version 1.2.1.2
Linked Version 1.2.1.2
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/lib/php:/usr/local/lib/php | .:/usr/lib/php:/usr/local/lib/php
open_basedir | /home/bradpai:/usr/lib/php:/usr/local/lib/php:/tmp | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 2M | 2M
post_max_size | 8M | 8M
==========================
Page generated in 0.093 seconds - 16 queries in 0 seconds - Album set : ; Meta set: ;

Also, where it says RESULT, instead of coming out with the OK or PB or whatever symbol, it says "click for details or to reload" and when I click it says "Unable to create thumbnail or reduced size image."
« Last Edit: January 01, 2008, 09:33:43 am by Hein Traag »
Logged

Nibbler

  • Guest
Re: Not creating thumbnails
« Reply #3 on: December 04, 2007, 07:02:49 pm »

Do exactly as suggested in the upload troubleshooting section of the docs.

You have done the opposite of what was asked for, so how are we supposed to help you?
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #4 on: December 04, 2007, 08:56:57 pm »

I did? I posted the messages that I got, isn't that I was supposed to do?
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #5 on: December 04, 2007, 09:01:55 pm »

Never mind I see how I didn't follow directions precisely. So sorry.  ::) I'm trying to do this right, I swear!

I'm not getting any error messages!!! Here's my gallery:
http://brad-paisley.net/gallery
And I made a test user account (username: test password: test) if someone wants to try and upload something and see what happens
Logged

Nibbler

  • Guest
Re: Not creating thumbnails
« Reply #6 on: December 04, 2007, 10:31:37 pm »

Works fine for me.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #7 on: December 04, 2007, 11:28:20 pm »

So then what could possibly be going wrong? It is definitely not working for me.
Logged

Nibbler

  • Guest
Re: Not creating thumbnails
« Reply #8 on: December 04, 2007, 11:47:56 pm »

Have you tried with small files you know to be valid? Post an example.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #9 on: December 05, 2007, 03:21:34 pm »

Um I tried uploading some files that I had previously uploaded before I had to re-install the gallery, but they still didn't work.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Not creating thumbnails
« Reply #10 on: December 06, 2007, 07:40:24 am »

Do as Nibbler suggested:
Post an example.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #11 on: December 06, 2007, 08:00:16 am »

I'm not sure what exactly you want...I'm sorry for sounding stupid I'm just trying to figure out what you want.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Not creating thumbnails
« Reply #12 on: December 06, 2007, 08:06:15 am »

Attach one of the files that you're trying to upload (one that you're having issues with) to your posting here (using "additional options" when composing your message).
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #13 on: December 06, 2007, 04:30:48 pm »

Gracias thanks. Here ya go.
Logged

Nibbler

  • Guest
Re: Not creating thumbnails
« Reply #14 on: December 06, 2007, 05:35:09 pm »

Works fine.

http://brad-paisley.net/gallery/displayimage.php?pos=-668

Can't really help you with problems that happen only to you.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #15 on: December 07, 2007, 06:35:08 pm »

Could it be something to do with my FTP or something?
Logged

Nibbler

  • Guest
Re: Not creating thumbnails
« Reply #16 on: December 07, 2007, 07:10:50 pm »

If you can't upload via the web interface then FTP does not come into it atall.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #17 on: December 09, 2007, 06:35:48 pm »

So do you think maybe I should entirely delete coppermine and reinstall it?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Not creating thumbnails
« Reply #18 on: December 10, 2007, 07:44:41 am »

No. Coppermine is not a desktop application that you un-install and re-install to make issues go away.
Logged

ash_sk8s

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 30
Re: Not creating thumbnails
« Reply #19 on: December 10, 2007, 08:03:28 pm »

Well then I've got no freaking idea what to do. ANY suggestions at all?
Logged
Pages: [1] 2   Go Up
 

Page created in 0.039 seconds with 20 queries.