Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: upload / db problem  (Read 3765 times)

0 Members and 1 Guest are viewing this topic.

dogo

  • Translator
  • Coppermine newbie
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 7
  • Marian Trendafilov
upload / db problem
« on: December 03, 2007, 10:03:22 pm »

here is my gallery http://fsghs.1111mb.com/
user: test
pass: test

i am sure the problem is in the db but i dont know where to look.
i can give you sql dump if you want
« Last Edit: December 05, 2007, 08:10:22 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: upload / db problem
« Reply #1 on: December 04, 2007, 07:42:46 am »

The error message I got was
Quote
Impossible to move orchid_purpurea_40k.jpg to albums/userpics/10153/ !

File: /www/1111mb.com/f/s/g/fsghs/htdocs/db_input.php - Line: 355
That doesn't mean that there is something wrong with your database. Do as suggested in http://coppermine-gallery.net/demo/cpg14x/docs/index.htm#ErrorImpossibleToMove
Logged

dogo

  • Translator
  • Coppermine newbie
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 7
  • Marian Trendafilov
Re: upload / db problem
« Reply #2 on: December 04, 2007, 08:42:12 am »

I triple check the permissions , all in albums is 777 .
And I know there is a problem with the database because I did set this same gallery to use database of working gallery on the same account, and it uploaded and stored the pictures in the http://fsghs.1111mb.com/albums just fine.

The problem is not in the cpg filese because i made fresh upgread yesterday, and the permissions are ok , so it must be the db. something went wrong there I dont know what :(
Logged

dogo

  • Translator
  • Coppermine newbie
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 7
  • Marian Trendafilov
Re: upload / db problem
« Reply #3 on: December 04, 2007, 05:43:01 pm »

WOW this cpg is awesome I just had to  use a fresh database and inserted the the important tables like albums and users, and it is ok now.

Thank you for making such a good app , where newb people like me can easy fix the problems :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: upload / db problem
« Reply #4 on: December 05, 2007, 08:11:06 am »

Thanks for returning and resolving your thread. How did the tables get deleted in the first place though? Did you delete them by accident?
Logged

dogo

  • Translator
  • Coppermine newbie
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 7
  • Marian Trendafilov
Re: upload / db problem
« Reply #5 on: December 07, 2007, 03:55:10 pm »

Thanks for returning and resolving your thread. How did the tables get deleted in the first place though? Did you delete them by accident?
there wasnt deleted tables , i think the config table was wrong.
Actually now the 1111mb is down from days, i have to move my gallery , but i didnt get backup from the fixed db , have yo deal with it again. I dont know what I am realy doing, just playing with the tables on method try, mistake , try ...

I almost fix it. I can upload , i have to create each new folder in /userpics manualy cuz the script make folders w/ wrong permissions and then it can't put the files there ...
Logged

Nibbler

  • Guest
Re: upload / db problem
« Reply #6 on: December 07, 2007, 04:02:27 pm »

Read the manual - silly safe mode.
Logged

dogo

  • Translator
  • Coppermine newbie
  • **
  • Offline Offline
  • Gender: Male
  • Posts: 7
  • Marian Trendafilov
Re: upload / db problem
« Reply #7 on: December 07, 2007, 04:59:09 pm »

Thank you, Nibbler.

lol , this single line in the config.inc.php make me such an idiot
thinking the db is the problem , and when I "Fixed" it I used copy of the config.inc.php file of the fresh working cpg that seemed to had this line in , and now I used again the wrong config.inc.php that makes problems :D

But you guys from the Dev Team have to put info for the Safe mode issues into 2.1.1 Setting permissions and 4.11.4 Upload troubleshooting because the people who have problems with the upload look there and the most of us who use free hosting don't know they have to edit the config.inc.php when they move to host that uses safe mode.


pp: where is the edit button ?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: upload / db problem
« Reply #8 on: December 07, 2007, 07:03:58 pm »

pp: where is the edit button ?
Disabled because of abuse in the past.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.