Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Please, help me! Fatal error...  (Read 5728 times)

0 Members and 1 Guest are viewing this topic.

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« on: March 24, 2004, 03:21:51 pm »

Hi!
I have installed Version 1.2.1 . If everything well ran, until I have anew played in ordner "themes"> "default" dateien theme.php and template.html. Since then I have this mistake.

Quote
Fatal error: Call to undefined function: theme_display_album_list_cat() in /homepages/18/d74591556/htdocs/coppermain-gallery/index.php on line 493


Please, help me! Have despaired totally... Thanks in advance!
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Please, help me! Fatal error...
« Reply #1 on: March 24, 2004, 03:33:57 pm »

If you mean you did some editing in the default theme, and it no longer works, you can do a couple of things.
Try going into another theme.  If you cannot get to config, type this at the end of your url '?theme=water_drop'.  This should put you in the water drop theme.

You could also upload a new copy of the files you messed with.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #2 on: March 24, 2004, 03:47:04 pm »

Thanks for quick antwort  :)  
Have tried with config.php'?theme=water_drop', has not functioned... If error message comes:

Quote
Fatal error : You do not have rights for viewing this page.


... excuse for mine English, can better German or Russian ...
Logged

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #3 on: March 24, 2004, 03:51:19 pm »

What can I still do to save mine album?...  :(
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Please, help me! Fatal error...
« Reply #4 on: March 24, 2004, 04:20:47 pm »

try with index.php
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #5 on: March 24, 2004, 04:48:58 pm »

With index.php something like that comes:

Quote
Multiple Choices
The document name you requested (/coppermain-gallery/index.php') could not be found on this server. However, we found documents with names similar to the one you requested.
Available documents:

/coppermain-gallery/index.php?theme=water_drop' (extra character)
/coppermain-gallery/INDEX.PHP?theme=water_drop' (extra character)


And if I on one or other link clik this comes here:

Quote

error 404: file not found! Unfortunately, the given document could not be found on this server.


But files are on server - 100%... :(
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Please, help me! Fatal error...
« Reply #6 on: March 24, 2004, 05:50:56 pm »

have you left the apostrophy (') in, that should not be there.

And a link would help us look for the problem.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #7 on: March 24, 2004, 06:19:04 pm »

Yaa... It has really functioned!  :D  
I have given first wrong. Sorry...  :oops:  
Now I come on mine album in index seite in "water drop" design. I must still say, mine album is in phpbb2 forum integrated. Is a matter logging in about phpbb2 forum. However, after tip this comand I am not logged in, but come in index.php as well as she was. I do not come in admin site.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Please, help me! Fatal error...
« Reply #8 on: March 24, 2004, 06:41:57 pm »

Alena, please do as Casper suggested and post a link and a test user account.
Do not answer in German only please - unless you post both in German and English.

[translation]
Alena, ein Link zu Deiner Seite und den Benutzernamen und das Passwort eines "normalen" Benutzers, bitte.
Keine Antwort auf Deutsch, es sei den, Du schreibst zweisprachig auf Englisch und Deutsch!
[/translation]

GauGau
Logged

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #9 on: March 24, 2004, 07:53:29 pm »

http://.........
The language is Russian...  :roll:

name: test
passwort: test
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Please, help me! Fatal error...
« Reply #10 on: March 24, 2004, 09:47:11 pm »

OK, so your problem is that when clicking on "login" in coppermine you're being sent to phpBB. You enter your username and password there and you're being redirected back to coppermine. So far, so good - but in coppermine, you're not logged in.
As the same thing happens when I try to login to your gallery, it's clear that it isn't a client issue (your computer is not to blame, as it happens to me as well), so you probably haven't configured coppermine of the cpg-phpbb bridge file properly.
Here's what you do: siwtch off integration temporarily and log into coppermine as admin (standalone) with the password you created on install. Then go to your config and check your cookie name and cookie path (make a hardcopy of the screen). Next, switch integration back on and edit your bridge file: check if you have the correct paths and a cookie name in phpbb that is not the same as in coppermine. Double-check all your settings in the bridge file.
If you have configured it properly, they should be working fine.

GauGau
Logged

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #11 on: March 24, 2004, 10:41:55 pm »

Thanks! I werd try. I still report about mine success or Failure... here. Please, write still this sentence in German, I would like certainly his I it has properly understood. Thanks for your trouble!

...siwtch off integration temporarily and log into coppermine as admin (standalone) with the password you created on install...
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Please, help me! Fatal error...
« Reply #12 on: March 25, 2004, 08:38:36 am »

Quote from: "alena"
...siwtch off integration temporarily and log into coppermine as admin (standalone) with the password you created on install...

[Translation]
Schalte die Integration mit dem Forum zeitweise (testhalber) ab und logge Dich als Admin mit dem Passwort ein, das Du bei der Installation von Coppermine eingegeben hast.
[/Translation]

GauGau
Logged

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #13 on: March 25, 2004, 10:07:17 am »

Hi again!
Yesterday I have still changed dei variable in forum konfiguration:

name cooke: from phpBB2mysql in phpbb2mysql
 
And now I can log in again in album!  :)  Come in admin site, only if I design restore (default) might it does not go. But forum intergration I have not switched off. Should I maybe do it?...
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Please, help me! Fatal error...
« Reply #14 on: March 25, 2004, 10:47:27 am »

It seems to be working well now.

Leave it and enjoy.  :wink:
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #15 on: March 25, 2004, 01:19:31 pm »

Hi casper, thanks for hilfe, it really goes!  :D  :D  :D  But I would like to have my "default layout" again. In admin site I cannot change it. I can already select, but it jumps over and over again in "water_drop". What can I undertake?...
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Please, help me! Fatal error...
« Reply #16 on: March 25, 2004, 09:00:35 pm »

just do what you did before, but this time do 'index.php?theme=default'.
This will return you to the default theme, and should be permenant.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #17 on: March 25, 2004, 10:30:40 pm »

Hi again,
I cannot switch on yet "default design"...  :(
What can it lie with? Please, helps me...
Logged

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
Please, help me! Fatal error...
« Reply #18 on: March 25, 2004, 10:41:12 pm »

It works ok for me in default theme.  This may be a cookie thing.  Try logging out, deleting your coppermine cookies in your browser, and loging in again.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

alena

  • Coppermine novice
  • *
  • Offline Offline
  • Gender: Female
  • Posts: 20
Please, help me! Fatal error...
« Reply #19 on: March 25, 2004, 10:42:33 pm »

THANKS! Now EVERYTHING goes again!  :D  :D  :D  It is easy supper these Support here gives  :!:  :idea:  :!:


Sorry for the news.
Quote
Hi again,
I cannot switch on yet "default design"...  
What can it lie with? Please, helps me...

Have not seen the answer. The Brauser does not update...  :oops:

...Because it runs now everything supper, I have still pair questions... I thinks, do not work I. I would like to place link "login-logout" below in index site and headlines "admin login".  How?
Logged
Pages: [1] 2   Go Up
 

Page created in 0.027 seconds with 19 queries.