Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: 1 2 [3]   Go Down

Author Topic: Download video hack for v. 1.4.2  (Read 40506 times)

0 Members and 1 Guest are viewing this topic.

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Download video hack for v. 1.4.2
« Reply #40 on: October 14, 2006, 11:58:26 pm »

hi guys ive sorted it in fashion by copying the whole of the sample theme.php to my template theme.php - but it does spoil the look of the mavigation a bit - but at least it works
You shouldn't have copied all of sample theme.php... just the function(s) you want to modify.
Logged

Paver

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 1609
  • Paul V.
Re: Download video hack for v. 1.4.2
« Reply #41 on: October 15, 2006, 03:19:24 am »

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Download video hack for v. 1.4.2
« Reply #42 on: October 15, 2006, 02:00:39 pm »

copying the whole of the sample theme.php to my template theme.php
You mustn't do that. Only copy the section you want to see changed, not the entire content of themes/sample/theme.php
Logged

Glorn

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Download video hack for v. 1.4.2
« Reply #43 on: February 26, 2007, 06:28:01 am »

With this hack in place, IE works just fine for downloading.

However, Firefox reads all files as filetype "application/octet-stream" and then saves them as such.

I know that this is from the download.php code, but does anyone know why Firefox is doing this and IE is not?

And if so, can I correct it so that Firefox recoginzes the appropriate filetype?






Thank you,

Glorn H.
Logged

gldickens3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 39
Re: Download video hack for v. 1.4.2
« Reply #44 on: November 21, 2007, 06:23:54 am »

Hello,

I have a very strange problem for which I would like some guidance.

I successfully implemented this Download Video Hack modification and it works great;  That is, it works great for clients running Windows with Windows Media Player.  However, videos cease functioning once this hack is implemented on clients running Linux with the MPlayer Plug-In For Firefox.  I have tested this extensively with CentOS 5 running MPlayer version 1.0rc2 along with Mplayer Plug-In version 3.45.  I compiled both Mplayer and the Mplayer Plug-In from source and they both otherwise work great.

I have two websites running very similar copies of Coppermine.  I discovered that when I implemented the Download Video Hack on both websites that the MPlayer Plug-In quit working for both websites and that the Mplayer Plug-In began working again when I reverted back to the code without the Download Video Hack.  So, to demonstrate, I have set one website up with the Download Video Hack and set the other website up without the Download Video Hack.  Here are a couple of samples of each:

Two Videos Without Download Video Hack can be viewed at:

http://www.dickens.com/gallery/thumbnails.php?album=24

Two Videos With Download Video Hack:

http://georgiajets.org/gallery/thumbnails.php?album=24
http://georgiajets.org/gallery/thumbnails.php?album=31

The dickens.com site has not implemented the Download Video Hack whereas the georgiajets.org site has.  So, playing any of the videos on either of the sites will demonstrate what I am describing.  Please keep in mind that the client must be running MPlayer with the MPlayer Plug-In for Firefox in order to replicate this problem.

This problem may very well be caused by an issue with the MPlayer Plug-In instead of Coppermine but I wanted to see if anybody had observed this phenomona and whether there is a known work around.  I say this primarily since the Download Video Hack appears to work fine under Windows with Windows Media Player.  I am hopeful that someone has already found a solution.  I have played around with the code some but I cannot make it work.  All the while, I will readily admit that this hack shouldn't affect any media player.

I hope that this is the proper thread under which to post this issue.

Many thanks in advance for your reply.

Gordon Dickens
Logged

gldickens3

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 39
Re: Download video hack for v. 1.4.2
« Reply #45 on: November 21, 2007, 09:33:21 pm »

OK.  I solved my own problem.  My theme is a custom theme and uses the variable "clsid" instead of "classid" in the code that is modified for this hack.  As soon as I changed the variable "classid" in the modified code back to "clsid" then the MPlayer Plug-in started working with this hack.  I don't really understand why it was working in Windows Media Player and not with MPlayer Plug-In but I now have it working properly in both places.

FYI,

Gordon
Logged
Pages: 1 2 [3]   Go Up
 

Page created in 0.025 seconds with 20 queries.