Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: English_gb not detected  (Read 6097 times)

0 Members and 1 Guest are viewing this topic.

jesusarmy

  • Contributor
  • Coppermine novice
  • ***
  • Offline Offline
  • Posts: 34
English_gb not detected
« on: November 14, 2007, 06:25:56 pm »

I have set my browsers to English (united Kingdom) [en-gb], both MSIE and Firefox, but CPG still autodetects the language as plain "English" and so gives the US variant spellings (Favorite instead of Favourite, for example).

If I set the preferred language to French, both MSIE and Firefox display the menus in French, as desired.

I have forced a redetect of the language by going to http://www.jesus.org.uk/gallery?lang=xxx after changing the preferred browser language.

As it works with one language and not another, I find it hard to see what in my set up could be wrong.

Am I right in suspecting that the auto-detect code does not differentiate between US and GB variants of English?

http://www.jesus.org.uk/gallery


« Last Edit: November 15, 2007, 09:33:51 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: English_gb not detected
« Reply #1 on: November 14, 2007, 07:26:39 pm »

This is correct.
Logged

Nibbler

  • Guest
Re: English_gb not detected
« Reply #2 on: November 15, 2007, 09:33:40 pm »

Fixed in cvs.
Logged
Pages: [1]   Go Up
 

Page created in 0.016 seconds with 19 queries.