Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Batch Add - 404 Cant Read That File  (Read 3099 times)

0 Members and 1 Guest are viewing this topic.

adam1982

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Batch Add - 404 Cant Read That File
« on: November 12, 2007, 01:45:20 am »

Hi All,

Firstly just wanted to say thank you for an excellent application, I've been running it for about 1.5 years now and its never missed a beat!

Secondly I want to apologies in advance if Iím posting this in the wrong area or if this has already been covered (I did a few search's but couldnít find what i was looking for)

Recently I have moved my image gallery from an older server to a new server. The upgrade went mostly to plan, however I have run into one problem using the Batch Add images. I've copied over the old album folders (The folders I had created on my old server under albums) When I do a batch add on some of the directories they work fine, and on some of them it comes up with "404 can't read that file"

After comparing directories that did work to ones that didnít work, it seems to come down to the image name. If the image name has either a space or a "-" in it, then I get the 404 error. If the image name doesnít have any of those characters in it, then it works fine.

I searched around the forum a bit trying to find this problem, and the closest I came up with, was a post saying to disable the "Search-engine-friendly URLs" plugin. I've checked and the plugin is not installed, and I have even disabled all plugins.

Could anyone shed any light on what I have missed/done wrong? I donít want to go through and rename all my pictures to remove space's and "-"'s and this used to work on my older version of Coppermine

Again, apologies if I have posted this in the wrong section, or if it has already been covered

Thanks in advance
Adam
« Last Edit: November 12, 2007, 07:47:10 am by Sami »
Logged

adam1982

  • Coppermine newbie
  • Offline Offline
  • Posts: 2
Re: Batch Add - 404 Cant Read That File
« Reply #1 on: November 12, 2007, 07:36:18 am »

Well after many search's and hair pulling I solved it.

I turned on the debug mode through the control panel and then went to re upload the photos. It turns out it was something stupid that I forgot to do, I didnt give the IUSR account write access to the albums directory so it couldnt rename the files with spaces etc

All solved now

Thanks
Adam
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Batch Add - 404 Cant Read That File
« Reply #2 on: November 12, 2007, 07:49:01 am »

Good to hear you solve it :)
just a note:
Try to avoid space on your filename which cause issue on UNIX base box , BTW you're save on your wondows box
Logged
‍I don't answer to PM with support question
Please post your issue to related board
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.