Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Serbian latin characters  (Read 6950 times)

0 Members and 1 Guest are viewing this topic.

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Serbian latin characters
« on: November 02, 2007, 02:13:53 am »


  Hi there!

  I have a problem with characters in coppermine - if I set the charset to utf-8, some Serbian latin characters wont display properly. I am talking about the characters in category titles, album titles or image description.

  I have tried other charsets offered in the config panel, but none of them does the job. The most I can get it to do is show two Serbian latin characters - š and ž.

  Any ideas? Thanx :)

  LP

   
Logged

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Serbian latin characters
« Reply #1 on: November 02, 2007, 02:24:33 am »


   Maybe I should add that I'm using MySQL, and here are the charset parameters:
 
   MySQL charset: UTF-8 Unicode (utf-8)
   MySQL connection collation: utf8_unicode_ci

   
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Serbian latin characters
« Reply #2 on: November 02, 2007, 07:13:06 am »

Did you use another charset before you switched to utf-8? If yes, you'll have to convert the textual content of your database to utf-8
Post a link to your gallery for a start.
Logged

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Serbian latin characters
« Reply #3 on: November 12, 2007, 01:58:21 pm »

Quote
Did you use another charset before you switched to utf-8?

   No, I have just installed coppermine for the first time ever.

Quote
you'll have to convert the textual content of your database to utf-8

   There is no previous textual content. Whatever I type in coppermine automatically gets displayed as question marks or something similar.



Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Serbian latin characters
« Reply #4 on: November 12, 2007, 03:17:57 pm »

Post a link to your gallery for a start.
Logged

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Serbian latin characters
« Reply #5 on: November 12, 2007, 10:02:31 pm »


   Here it is: http://www.serbiatravelers.org/foto/

   Please check out the first category... the question marks in the category descriptions are also supposed to be letters (I typed them as letters, but after saving they somehow turned into question marks). The charset is set to unicode - utf8.

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Serbian latin characters
« Reply #6 on: November 13, 2007, 06:42:51 am »

Please post here the string that is suppossed to show - I'm trying to replicate on my testbed wether this is a bug.
Logged

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Serbian latin characters
« Reply #7 on: November 13, 2007, 11:31:23 am »


   Ok, here is what I actually typed: a b c d   ....   š č ć ž đ 
   and here is what it shows after having been saved: a b c d .... š ? ? ž ?

Logged

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Serbian latin characters
« Reply #8 on: November 13, 2007, 03:43:13 pm »


   I've done some research and guess what I've found out :)

   When I check my SQL table, I see that table "categories" (as well as all the other table) has the following charset:

   Collation     latin1_swedish_ci

   While in "config" panel of my coppermine gallery, it says "utf-8".

   How can I get all my gallery tables to be utf-8 instead of latin1_swedish?
Logged

bokonon

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: Serbian latin characters
« Reply #9 on: November 13, 2007, 07:32:34 pm »


   I have managed to fix the problem by editing the SQL file and reinstalling the database. I added "COLLATE 'utf8_general_ci'" at the end of every "CREATE TABLE" statemend.

   It all worked fine untill I enabled the bridge with the simple machines forum - when the charset got messed up again (although the database still said utf8_general_ci). However, when I disabled the bridging, the problem disappeared.

   Any idea why this happens? It would be great if I could use the bridge and have my characters displayed properly at the same time :)
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 19 queries.