Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: plugin manager installed plugin folders not deletable  (Read 4040 times)

0 Members and 1 Guest are viewing this topic.

erostew

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
plugin manager installed plugin folders not deletable
« on: October 28, 2007, 02:31:12 am »

Hopefully this is posted in the correct board.

Just noticed that any plugin that is uploaded as a zip has it's folder owned by apache. So when you uninstall and then click to delete the plugin from the server nothing happens. The only way I could delete the folder was to ssh into my server and chown it to the domain's user. This seems to be because the folder is created with permissions 755. Other folders created by CPG are owned by apache but chmod 777 and can be deleted as normal.

Not a huge problem but it could be an issue for folks with limited webspace and no access to take ownership of the folder.

Did a search and couldn't find mention of this anywhere so I thought to post it here.
« Last Edit: October 29, 2007, 08:10:40 am by GauGau »
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9096
  • aka Frantz
    • Ma galerie
Re: plugin manager installed plugin folders not deletable
« Reply #1 on: October 28, 2007, 09:12:07 am »

Hi,

Quote
So when you uninstall and then click to delete the plugin from the server nothing happens.
I can't replicate this issue (local server and web server). work's as expected  :-\
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

erostew

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
Re: plugin manager installed plugin folders not deletable
« Reply #2 on: October 28, 2007, 09:26:43 am »

Hi,
I can't replicate this issue (local server and web server). work's as expected  :-\

Strange. I could understand different server configurations having something besides apache for owner, but not sure why I would get files chmodded 755 only for plugins folders created by the plugin manager when unzipping. Must be a config issue on my server I guess.

Regards
Logged

François Keller

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 9096
  • aka Frantz
    • Ma galerie
Re: plugin manager installed plugin folders not deletable
« Reply #3 on: October 28, 2007, 09:32:39 am »

Quote
Must be a config issue on my server I guess.
Yes it's possible.
Logged
Avez vous lu la DOC ? la FAQ ? et cherché sur le forum avant de poster ?
Did you read the DOC ? the FAQ ? and search the board before posting ?
Mon Blog

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: plugin manager installed plugin folders not deletable
« Reply #4 on: October 28, 2007, 10:56:26 am »

This entire issue is not related to coppermine, but to the way you set up your webserver. Contact your webhost if you need to see this changed.
Logged

erostew

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
Re: plugin manager installed plugin folders not deletable
« Reply #5 on: October 28, 2007, 05:33:34 pm »

This entire issue is not related to coppermine, but to the way you set up your webserver. Contact your webhost if you need to see this changed.

Not worth my time to try and fix the issue if it is just on my server. Can easily be worked around by using ftp to upload plugins. Ownership of the created folders by apache is expected and desired. Only 755 being used instead of 777 is a small problem.

Only reported it because I thought it was a general issue. Thanks for your time.
Logged
Pages: [1]   Go Up
 

Page created in 0.02 seconds with 20 queries.