Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: 500 Internal Server Error  (Read 3057 times)

0 Members and 1 Guest are viewing this topic.

chels

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
500 Internal Server Error
« on: October 13, 2007, 01:45:30 am »

Hi there :) Alright this is kind of messy...

My Coppermine gallery is http://bad-behavior.com/gallery. My site had been up and running normally for several months, when all of the sudden, out of nowhere, I get a 500 Internal Server Error when I try to access my it. It not only happened to my Coppermine gallery but also my Wordpress blog located at http://bad-behavior.com/blog.

I tried overwriting all php files in my /gallery directory with fresh ones, but no luck. I also tried deleting my .htaccess file, still nothing.

I contacted my host about it last week. He said that the problem was my php code, which obviously isn't the case because I reuploaded everything brand new.

Does anybody know what could be causing that error? Is it a database issue? I guess I can try a fresh install of Coppermine and then import my old database. But if anybody knows an easier fix or even how it may have happened I would be much appreciative. Thanks!
« Last Edit: October 16, 2007, 08:06:50 am by GauGau »
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: 500 Internal Server Error
« Reply #1 on: October 13, 2007, 09:45:07 am »

I get this when i go to your site.
Code: [Select]
Parse error: syntax error, unexpected '=' in /home/chelsey/public_html/gallery/plugins/highslide/codebase.php on line 234
Reupload a fresh codebase file for highslide because the current is not working.
Logged

chels

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: 500 Internal Server Error
« Reply #2 on: October 14, 2007, 09:01:28 pm »

Thanks for the reply. I've reuploaded the entire highslide directory. But since I get a 500 error, is there a way I can install/uninstall it from the backend since I can't access my plugins manager?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: 500 Internal Server Error
« Reply #3 on: October 15, 2007, 08:12:03 am »

To manually disable the use of plugins, access your database using phpMyAdmin, browse coppermine's config table, find "enable_plugins" and set the value to "0".
Logged

chels

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: 500 Internal Server Error
« Reply #4 on: October 15, 2007, 09:00:02 pm »

Thanks for those instructions.

I tried reuploading the highslide files, disabling highslide and all plugins through phpmyadmin and I still get a 500 internal server error. So strange. Any other ideas?
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: 500 Internal Server Error
« Reply #5 on: October 15, 2007, 09:59:30 pm »

Check your Server's Error Log
Logged
‍I don't answer to PM with support question
Please post your issue to related board

chels

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: 500 Internal Server Error
« Reply #6 on: October 15, 2007, 10:45:12 pm »

Thanks, I ended up reuploading my entire includes folder from a backup and got the gallery to work again. Wierd!
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 20 queries.