Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Internal Server Error - Is it because of how many pics I have in an album?  (Read 6603 times)

0 Members and 1 Guest are viewing this topic.

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33

I've had my gallery for over a year now, but last night I got this error when I tried clicking on a thumbnail in one of the albums:

Quote
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@harryandginny.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

It only happens with the one album though. All the others work fine. This album has 20232 files in it. Is that why I have the problem? Because of the amount of images?

http://www.harryandginny.org/framebyframe/index.php?cat=19

Any help would be appreciated!
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #1 on: September 20, 2007, 11:38:28 am »

Is it happening continuously or it was only one time error ?
Cause I can't see the error , It could be a mysql or web server internal issue on specific time that you was browsing
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #2 on: September 20, 2007, 11:42:12 am »

No, it's still happening.

It's images from this album it's happening with:

http://www.harryandginny.org/framebyframe/thumbnails.php?album=109
Logged

Nibbler

  • Guest
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #3 on: September 20, 2007, 11:44:23 am »

For large albums, split the files up into different directories on the server.
Logged

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #4 on: September 20, 2007, 11:46:11 am »

Do you mean the folders to batch upload from? I already have them split. At the moment there's 14 folders for that one album.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #5 on: September 20, 2007, 12:03:23 pm »

- First of all Upgrade to most recent version (it's 1.4.13) you're using 1.4.10
- I click on some of those thumbs and didn't see internal error !
- Reducing the "Number of rows on thumbnail page" to 5 may help you (in case of timeout issue )
config=>Thumbnail view=>Number of rows on thumbnail page
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #6 on: September 20, 2007, 12:08:17 pm »

No, it's still the same problem.

I'm going to try reducing the amount of images in that album and see if that helps.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #7 on: September 20, 2007, 12:12:11 pm »

Is this Uploading issue ? or you're trying to click on one of thumbnails within album ?
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #8 on: September 20, 2007, 12:19:13 pm »

I'm trying to click on one of the thumbnails within the album. They uploaded okay, I just can't view the full sized image afterwards.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #9 on: September 20, 2007, 12:35:39 pm »

Then it's not related to the number of images that you have on album or folder
it should be something else
- check your server log
- do you have any mod or plugin installed?
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #10 on: September 20, 2007, 12:41:47 pm »

How do I check my server log?

The only Mod I've been using is cpmFetch.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #11 on: September 20, 2007, 12:49:09 pm »

You should have access to it under hosting control panel
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #12 on: September 20, 2007, 02:29:59 pm »

Which log would it be? Error or Access log?
Logged

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #13 on: September 20, 2007, 02:36:05 pm »

Okay here's the error log.

Quote
[Thu Sep 20 05:10:43 2007] [error] [client 69.158.12.113] File does not exist: /home/***/harryandginny.org/test/test/images/0000-00.gif
[Thu Sep 20 05:10:43 2007] [error] [client 69.158.12.113] File does not exist: /home/***/harryandginny.org/missing.html
[Thu Sep 20 05:10:47 2007] [error] [client 69.158.12.113] File does not exist: /home/***/harryandginny.org/favicon.ico
[Thu Sep 20 05:10:47 2007] [error] [client 69.158.12.113] File does not exist: /home/***/harryandginny.org/missing.html
[Thu Sep 20 05:23:37 2007] [error] [client 88.131.153.91] File does not exist: /home/***/harryandginny.org/robots.txt
[Thu Sep 20 05:23:37 2007] [error] [client 88.131.153.91] File does not exist: /home/***/harryandginny.org/missing.html
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #14 on: September 20, 2007, 03:02:33 pm »

Try to open one of those images and then check it , provided entries didn't belong to your issue
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #15 on: September 20, 2007, 04:34:47 pm »

Um, sorry but I don't understand what you mean?
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #16 on: September 20, 2007, 08:48:41 pm »

your posted error log doesn't show any related entry about your issue , so
- Go to that album and retry to open fullsize image (that will create a internal error)
- Now go to your error log and see if there is a log entry or not
Logged
‍I don't answer to PM with support question
Please post your issue to related board

iamfez

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 33
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #17 on: September 20, 2007, 09:15:03 pm »

This is what's now on the error log:

Quote
[Thu Sep 20 12:10:45 2007] [error] [client 80.195.129.211] File does not exist: /home/dtl/harryandginny.org/test/test/images/0000-00.gif
[Thu Sep 20 12:10:45 2007] [error] [client 80.195.129.211] File does not exist: /home/dtl/harryandginny.org/missing.html
FATAL:  emalloc():  Unable to allocate 6 bytes
[Thu Sep 20 12:11:41 2007] [error] [client 80.195.129.211] Premature end of script headers: /dh/cgi-system/php.cgi
[Thu Sep 20 12:11:41 2007] [error] [client 80.195.129.211] File does not exist: /home/dtl/harryandginny.org/internal_error.html
Logged

Nibbler

  • Guest
Re: Internal Server Error - Is it because of how many pics I have in an album?
« Reply #18 on: September 20, 2007, 09:33:57 pm »

This is caused by a combination of a large number of pics in the album, your server configuration and inefficient code in Coppermine. Try to split the album into smaller parts.

[Note: To reproduce the issue, view a fullsize image in the album mentioned or use the pos addressing system to access  an intermediate image, for example: http://www.harryandginny.org/framebyframe/displayimage.php?pos=-175511]
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 20 queries.