Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Problemi dati EXIF  (Read 4081 times)

0 Members and 1 Guest are viewing this topic.

piolohm

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Problemi dati EXIF
« on: September 03, 2007, 08:40:12 pm »

Salve, vorrei porvi questo problema.
Dopo aver caricato diverse foto mi sono accorto che in alcune i dati exif visualizzati risultano errati. Mi sono reso conto che i problemi sono soltanto nelle foto che ho modificato e salvato con Capture NX. In particolare i dati corrotti sono il tempo d'esposizione e la modalià cattura scena.
Preciso che controllando le proprietà del file caricato in galleria i dati risultano corretti, quindi il problema risiede nel modulo che li va a leggere (magari per qualcosa introdotto dal Capture).

Ho provato a cercare sui topic presenti ma non ho trovato nulla.
Qualcuno ha idea?

Grazie in anticipo,
Pierpaolo

Ah, questo è un esempio di foto corrota (Tempo d'esposizione visualizzato: 625/100000 sec; effettivo 1/160)
http://www.cromatismi.net/galleria/displayimage.php?album=random&cat=4&pos=-485
« Last Edit: September 05, 2007, 08:42:53 pm by Lontano »
Logged

Davide Renda

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: Problemi dati EXIF
« Reply #1 on: September 04, 2007, 09:55:09 pm »

In effetti la cosa è alquanto bizzarra. Provo a supporre che, probabilmente, il formato in cui Capture NX (programma che personalmente non conosco) non è "letto" come dovrebbe da Coppermine che, invece, vede i dati precedenti la manipolazione.
Hai fatto bene a postare anche nella parte anglofona del forum, magari qualcuno che conosce Capture NX potrà aiutarti.

Davide Renda

  • Moderator
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 1427
  • aka "Lontano"
    • www.daviderenda.eu
Re: Problemi dati EXIF
« Reply #2 on: September 05, 2007, 08:42:31 pm »

Come ti ha risposto GauGau nel topic in inglese, la libreria EXIF utilizzata da Coppermine è vecchia non più sviluppata, per cui potrebbero esserci problemi con campi EXIF specifici e coi dati in essi contenuti. Ci possono anche essere incongruenze a seconda degli apparecchi digitali utilizzati.

piolohm

  • Coppermine newbie
  • Offline Offline
  • Posts: 4
Re: Problemi dati EXIF
« Reply #3 on: September 06, 2007, 06:11:35 pm »

Bhè, l'unca soluzione sarebe quella di aggironarmi le funzioni php riguardanti la lettura degli exif!?! :'( :'(
Se ci riusciro vi farò sapere  ;)
Logged
Pages: [1]   Go Up
 

Page created in 0.019 seconds with 18 queries.