Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: XP Publishing was working for years. Now it stopped working. HELP!  (Read 5012 times)

0 Members and 1 Guest are viewing this topic.

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7

Hi everyone. I have been using coppermine for years. It was working fine. We use the XP publishing wizard exclusively for publishing photos and has been working fine.

Suddenly today it stopped working with the following error (see attachment), I have not done any change to the config (other than enabling debug for Admin)


here is the debug log



USER:
------------------
Array
(
    [ID] => 34880acbfc779fb354c8c0497d022e31
    [am] => 1
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => rajivmehra
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM cpg133_filetypes; (0s)
  • [1] => select * from cpg133_plugins order by priority asc; (0s)
        [2] => delete from `rajivm_coppermine`.cpg133_sessions where time<1188298479 and remember=0; (0s)
        [3] => delete from `rajivm_coppermine`.cpg133_sessions where time<1187092479; (0s)
        [4] => select user_id from `rajivm_coppermine`.cpg133_sessions where session_id=md5("12208466400080753e851c524fbead73c5bdcf184ff9d6ce1f8d105a240ba5c0"); (0s)
        [5] => select user_id as id, user_password as password from `rajivm_coppermine`.cpg133_users where user_id=1 (0s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `rajivm_coppermine`.cpg133_users AS u INNER JOIN `rajivm_coppermine`.cpg133_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0s)
        [7] => SELECT user_group_list FROM `rajivm_coppermine`.cpg133_users AS u WHERE user_id='1' and user_group_list <> ''; (0s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg133_usergroups WHERE group_id in (1) (0s)
        [9] => SELECT group_name FROM  cpg133_usergroups WHERE group_id= 1 (0s)
        [10] => update `rajivm_coppermine`.cpg133_sessions set time='1188302079' where session_id=md5('12208466400080753e851c524fbead73c5bdcf184ff9d6ce1f8d105a240ba5c0'); (0s)
        [11] => SELECT user_favpics FROM cpg133_favpics WHERE user_id = 1 (0s)
        [12] => DELETE FROM cpg133_banned WHERE expiry < '2007-08-28 11:54:39' (0s)
        [13] => SELECT * FROM cpg133_banned WHERE (ip_addr='67.151.171.130' OR ip_addr='67.151.171.130' OR user_id=1) AND brute_force=0 (0s)
        [14] => SELECT category, title, aid, keyword, description, alb_password_hint FROM cpg133_albums WHERE aid='47' (0s)
        [15] => SELECT COUNT(*) FROM cpg133_pictures WHERE approved = 'NO' (0s)
        [16] => SELECT title,keyword from cpg133_albums WHERE aid='47' (0s)
        [17] => SELECT COUNT(*) from cpg133_pictures WHERE ((aid='47'  ) )   (0s)
        [18] => SELECT pid, filepath, filename, url_prefix, filesize, pwidth, pheight, ctime, aid, keywords, title, caption,hits,owner_id,owner_name from cpg133_pictures WHERE ((aid='47'  ) )   ORDER BY filename ASC  LIMIT 18 ,9 (0.001s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
       
[album] => 47
    [page] => 3
)

==========================
POST :
------------------
Array
(
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.7 - OK
------------------
mySQL version: 4.1.22-standard
------------------
Coppermine version: 1.4.5(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.22
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.2.3
Linked Version 1.2.3
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/usr/lib/php | .:/usr/lib/php
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 10M | 10M
post_max_size | 8M | 8M
==========================
Page generated in 0.043 seconds - 19 queries in 0.001 seconds - Album set : ; Meta set: ;


Can someone please help me fix it?
Logged

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #1 on: September 01, 2007, 07:07:41 pm »

Please help me!

Anyone?
Logged

Nibbler

  • Guest
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #2 on: September 01, 2007, 08:41:39 pm »

Link and test account might be helpful.
Logged

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #3 on: September 01, 2007, 09:16:37 pm »

I just upgraded to the v1.4.12, hoping that it will go away, but the problem is still there.

Logged

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #4 on: September 01, 2007, 09:19:01 pm »

Ok thanks for trying to help.
here is the link:

http://www.neilmehra.com/cpg/index.php

username : test
password : testing


HTTP upload works fine

Thanks
Logged

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #5 on: September 02, 2007, 05:03:20 pm »

Someone please help me!

Am I doing something wrong, why am I not getting any answers?
I went through the documentation and looked at the troubleshooting uploads section. I followed all the steps but the log does not show any errors.
Logged

Nibbler

  • Guest
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #6 on: September 02, 2007, 05:07:43 pm »

You need to wait for someone who still uses windows to help you.
Logged

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #7 on: September 02, 2007, 05:17:33 pm »

Do you mean no one uses the XP publishing wizard anymore?

Then how do people upload lots of pics? Is there any other quick and simple option??

Or are you saying that my server is Windows,,,,,,because it is not.

thanks


You need to wait for someone who still uses windows to help you.
Logged

Nibbler

  • Guest
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #8 on: September 02, 2007, 05:26:55 pm »

Use FTP + batch add.
Logged

rm

  • Coppermine newbie
  • Offline Offline
  • Posts: 7
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #9 on: September 03, 2007, 05:11:04 pm »

I know that option is there but it has very low WAF!

The xp wizard is a very easy thing to use for non-computer savy people.

Use FTP + batch add.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #10 on: September 04, 2007, 10:15:50 am »

Do you mean no one uses the XP publishing wizard anymore?
There are still a lot of people who use Windows XP. However, most devs and supporters don't have Windows XP, but real operating systems.
Logged

mattreidy

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: XP Publishing was working for years. Now it stopped working. HELP!
« Reply #11 on: September 11, 2007, 03:36:32 pm »

I've got the same problem with my instance of 1.4.12; All users are unable to create new ablums via the XP Publishing wizard but are able to create them directly in Coppermine. Help?

I can't think of anything that has changed on my server (Windows 2003). I don't see it being a file-level permission issue on the server since albums are just a MySQL database object/relationship.

I've found the wizard to be the best tool for the basic user to upload pictures. To keep things on the server organized, I've written an application that creates user and date based subdirectories under userpics, moves uploaded files from userpics to the appropriate directory and upadtes the Coppermine database with the new location.

Thanks,

-Matt
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.