Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Problem installing captcha  (Read 3545 times)

0 Members and 1 Guest are viewing this topic.

bvu007

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Problem installing captcha
« on: August 09, 2007, 04:50:08 pm »

Hi,
I've followed the instructions on how to install captcha plugin.

However I get an error when I run my gallery:

Parse error: parse error, unexpected T_DOUBLE_ARROW in /homepages/39/d170410665/htdocs/Photographie/themes/classic/theme.php on line 25

theme.php code is as follows:

<?php
/*************************
  Coppermine Photo Gallery
  ************************
  Copyright (c) 2003-2006 Coppermine Dev Team
  v1.1 originally written by Gregory DEMAR

  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License as published by
  the Free Software Foundation; either version 2 of the License, or
  (at your option) any later version.
  ********************************************
  Coppermine version: 1.4.10
  $Source$
  $Revision: 3275 $
  $Author: gaugau $
  $Date: 2006-09-03 12:10:47 +0200 (So, 03 Sep 2006) $
**********************************************/

// ------------------------------------------------------------------------- //
// This theme has all CORE items removed                                     //
// ------------------------------------------------------------------------- //
define('THEME_IS_XHTML10_TRANSITIONAL',1);

'{CONFIRM}' => $lang_display_comments['confirm'],
'{COMMENT}' => $lang_display_comments['comment'],
<tr>
  <td class="tableb_compact" colspan="2">
    {CONFIRM}
  </td>
  <td class="tableb_compact" colspan="2">
    <input type="text" name="confirmCode" size="5" class="textinput"> <img src="captcha.php" align="middle">
  </td>
</tr>
<!-- END input_box_no_smilies -->
                                </td>
                                <td class="tableb_compact">
                                <input type="hidden" name="event" value="comment" />
                                <input type="hidden" name="pid" value="{PIC_ID}" />
                                <input type="submit" class="comment_button" name="submit" value="{OK}" />
                                </td></tr>

?>

Anyone knows how to troubleshoot?

Thanks
Bodo
« Last Edit: August 09, 2007, 05:32:12 pm by Nibbler »
Logged

Nibbler

  • Guest
Re: Problem installing captcha
« Reply #1 on: August 09, 2007, 05:07:49 pm »

Are you actually using the plugin or are you modifying code (ie. a  mod)? Either way follow the instructions more carefully, I'm sure they don't tell you to do that.
Logged

bvu007

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Problem installing captcha
« Reply #2 on: August 09, 2007, 05:10:04 pm »

Hi,
sorry, got it solved now.

Now that I read the instructions for captcha 1.8 it runs fine now!

Thanks Bodo
Logged
Pages: [1]   Go Up
 

Page created in 0.031 seconds with 19 queries.