Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: "Succesful upload" followed by glitch  (Read 3890 times)

0 Members and 1 Guest are viewing this topic.

Hobo89

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
"Succesful upload" followed by glitch
« on: August 07, 2007, 06:52:06 pm »

Hello,

I installed cpg 1.4.12 (stable) and it works fine, except for one little problem.

I configured ImageMagic to automatically resize all pics for all users: max authorized file size is 2Mb and max res. 4000.

When i upload a 1,10 Mb / 2304x3072 image i get the following:
(http://groupehumaniterre.com/1.jpg)
upload succesful

so far so good, then

(http://groupehumaniterre.com/2.jpg)
a black bar... and no image

and then the following message when clicking next: "The previous file could not be placed.

You have successfully placed all the files."

Kind of contradictory... any enlightenment would be greatly appreciated

thanks
Logged

Hobo89

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: "Succesful upload" followed by glitch
« Reply #2 on: August 07, 2007, 07:35:45 pm »

ill take that it that u wanted the debug raport:

Quote
SER:
------------------
Array
(
    [ID] => 77f09dfcff7fe5199a9b04cbf0af18c6
    [am] => 1
    [lang] => english
    [liv] => Array
        (
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 1
    [user_name] => Steff
    [groups] => Array
        (
           
  • => 1

        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 3
    [ufc_min] => 3
    [custom_user_upload] => 0
    [num_file_upload] => 5
    [num_URI_upload] => 3
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 3
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
   
  • => SELECT extension, mime, content, player FROM photos_filetypes; (0.001s)
  • [1] => select * from photos_plugins order by priority asc; (0.002s)
        [2] => delete from `humaniterre_photos`.photos_sessions where time<1186504472 and remember=0; (0.024s)
        [3] => delete from `humaniterre_photos`.photos_sessions where time<1185298472; (0.003s)
        [4] => select user_id from `humaniterre_photos`.photos_sessions where session_id=md5("83a5719586cc494302f2a6d809a4749b9193f4015a7ac79c27ce002c07f286be"); (0.001s)
        [5] => select user_id as id, user_password as password from `humaniterre_photos`.photos_users where user_id=1 (0.015s)
        [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `humaniterre_photos`.photos_users AS u INNER JOIN `humaniterre_photos`.photos_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='1' (0.001s)
        [7] => SELECT user_group_list FROM `humaniterre_photos`.photos_users AS u WHERE user_id='1' and user_group_list <> ''; (0.002s)
        [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM photos_usergroups WHERE group_id in (1) (0.001s)
        [9] => SELECT group_name FROM  photos_usergroups WHERE group_id= 1 (0.008s)
        [10] => update `humaniterre_photos`.photos_sessions set time='1186508072' where session_id=md5('83a5719586cc494302f2a6d809a4749b9193f4015a7ac79c27ce002c07f286be'); (0.009s)
        [11] => SELECT user_favpics FROM photos_favpics WHERE user_id = 1 (0.001s)
        [12] => DELETE FROM photos_banned WHERE expiry < '2007-08-07 17:34:32' (0.02s)
        [13] => SELECT * FROM photos_banned WHERE (ip_addr='82.67.0.124' OR ip_addr='82.67.0.124' OR user_id=1) AND brute_force=0 (0.033s)
        [14] => SELECT aid, title FROM photos_albums WHERE category < 10000 ORDER BY title (0.001s)
        [15] => SELECT aid, title FROM photos_albums WHERE category='10001' ORDER BY title (0.001s)
        [16] => SELECT COUNT(*) FROM photos_pictures WHERE approved = 'NO' (0.001s)
        [17] => SELECT unique_ID FROM photos_temp_data (0.033s)
        [18] => INSERT INTO photos_temp_data VALUES ('d0804c44', 'YToxOntpOjA7YToyOntzOjExOiJhY3R1YWxfbmFtZSI7czoxMjoiRFNDTjI1NDkuSlBHIjtzOjE0OiJ0ZW1wb3JhcnlfbmFtZSI7czoyMzoibUhUVFBfdGVtcF8wN2UwM2E3Yy5KUEciO319', '1186508073') (0.063s)
    )

    ==========================
    GET :
    ------------------
    Array
    (
    )

    ==========================
    POST :
    ------------------
    Array
    (
       
[URI_array] => Array
        (
           
  • =>
  • [1] =>
                [2] =>
            )

       
[control] => phase_1
)

==========================
VERSION INFO :
------------------
PHP version: 4.3.6 - OK
------------------
mySQL version: 4.1.11
------------------
Coppermine version: 1.4.12(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.22 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support: 1
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support: 1

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.0.18
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /tmp/mysql.sock
MYSQL_INCLUDE -I/usr/local/include/mysql
MYSQL_LIBS -L/usr/local/lib/mysql -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.1.4
Linked Version 1.1.4
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | no value | no value
file_uploads | On | On
include_path | .:/php/includes:/usr/local/share/pear:/usr/local/lib/php/pear | .:/php/includes:/usr/local/share/pear:/usr/local/lib/php/pear
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | me@localhost.com | me@localhost.com
sendmail_path | /usr/sbin/sendmail -t -i  | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 8M | 8M
post_max_size | 8M | 8M
==========================
Page generated in 2.025 seconds - 19 queries in 0.22 seconds - Album set : ; Meta set: ;
Logged

Hobo89

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: "Succesful upload" followed by glitch
« Reply #3 on: August 07, 2007, 07:41:21 pm »

because i know i can batch add files, tho the problem is that single uploaded pictures through http just gives the above glitch
Logged

Nibbler

  • Guest
Re: "Succesful upload" followed by glitch
« Reply #4 on: August 07, 2007, 08:12:15 pm »

4.11.4 Upload troubleshooting

If you are experiencing issues with coppermine's upload process, temporarily change your coppermine settings as suggested below to get more detailed error messages:

    * Go to your coppermine page and log in as admin
    * Go to the config screen
    * Scroll to the bottom of the page
    * Expand the "Maintenance settings" section by clicking on it
    * Enable debug mode for everyone
    * Leave display of notices switched off
    * Save the new settings by clicking on "Save new configuration"
    * Go to the "groups" panel
    * Set the upload form configuration for all groups to "Single file uploads only" (set File upload boxes to "1", URI upload boxes to "0" and No. of boxes to "fixed")
    * Save your new settings

Then try to upload (using http uploads, even if you experienced troubles using another upload method) - you should get a more detailed error message that tells you what exactly goes wrong with your uploads. If the error message doesn't mean anything to you, search the support board for the error message you get.
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested.

When people have issues with uploading and decide to post their question on the Coppermine support board, they usually are told to read this upload troubleshooting section. Many of them fail to do so properly, which results in frustration both for users as well as supporters. To make this absolutely clear: the above mentioned steps are absolutely mandatory, no matter what skill level you have, no matter what upload method you have troubles with. Failing to do exactly as suggested will result in your request for help being ignored. Yes, this applies to you. We mean it!
Logged

Hobo89

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: "Succesful upload" followed by glitch
« Reply #5 on: August 07, 2007, 11:38:31 pm »

Thanks for your concern, i understand... so i followed the steps and created the following user:

username: Test
Pass: papa

CPG address: http://www.groupehumaniterre.com/photos/index.php

debug mode is activated with only one upload box and 0 URIs.

Thanks again

Logged

Hobo89

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: "Succesful upload" followed by glitch
« Reply #6 on: August 08, 2007, 12:15:46 am »

i get this as a specific error message:

The file 'albums/userpics/10001/1~0.jpg' can't be inserted in the album

Error executing ImageMagick - Return value: 1

Cmd line :
/usr/local/bin/convert or /usr/local/bin/convert -quality 80 -antialias -geometry 100x43 'albums/userpics/10001/1~0.jpg' 'albums/userpics/10001/thumb_1~0.jpg'


The convert program said:


File: /usr/local/psa/home/vhosts/groupehumaniterre.com/httpdocs/photos/db_input.php - Line: 402
Logged

Nibbler

  • Guest
Re: "Succesful upload" followed by glitch
« Reply #7 on: August 08, 2007, 02:08:10 am »

Why did you set the path to imagemagick to "/usr/local/bin/convert or /usr/local/bin/convert"? That makes no sense. Enter the correct path to imagemagick's convert executable or switch to GD2 instead.
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.