Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: The selected album/file does not exist.  (Read 5488 times)

0 Members and 1 Guest are viewing this topic.

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
The selected album/file does not exist.
« on: August 17, 2007, 12:21:47 pm »

After I upload a picture and enter picture details and click continue I get this message:

"The selected album/file does not exist !
File: /----/----/gallery/include/functions.inc.php - Line: 1360"


The image is inserted into the user gallery anyway but don't know why the message is still there?

I've gone through the trouble shooting sticky and made all changes to work with safe mode as outlined:

Searched and found a user with similar problems... a fix was listed but didn't work for me:
http://coppermine.svn.sourceforge.net/viewvc/coppermine/trunk/cpg1.4.x/db_input.php?r1=3338&r2=3364

-----------------------
Album link: http://gallery.swisshut.com
login: debugtest
pass: debugpass

I have set config settings as per Troubleshooting documentation.
Logged

Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website - Spintires.nl
Re: The selected album/file does not exist.
« Reply #1 on: August 17, 2007, 01:39:15 pm »

Similar problem reported here : http://forum.coppermine-gallery.net/index.php?topic=40574.0

See if that solution also works for you and let us know if it did  :)
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: The selected album/file does not exist.
« Reply #2 on: August 17, 2007, 07:33:41 pm »

You're running cpg1.4.10 - it's mandatory to upgrade asap to the most recent stable release (currently cpg1.4.12) for security reasons. Might fix your troubles as well, as it should contain the fixed code.

Joachim

P.S. Your site is dead-slow for me - the redirection to your actual gallery (http://c26.servage.net/~sc33143-AFJT/gallery/) is taking ages. Are you per chance self-hosted? We don't recommend this at all.
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #3 on: August 18, 2007, 02:50:26 am »

Thanks for the replies guys.

Hein: Thats the same solution I tried before but the code change didn't work for me.

GauGau: I've manually updated the critical security issue but yeah I should update the whole thing. I haven't done it yet because haven't checked if its compatible with the Stramm mod pack.

I've got hosting with ww.servage.net. I've made some changes to my .htaccess to allow for the slower speeds like: php_value memory_limit 40M, php_value max_execution_time 60, php_value max_input_time 120.

The strange thing is... as admin I don't get that error. Only as registered users?
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #4 on: August 18, 2007, 03:08:14 am »

I have setup a second gallery using 1.4.12 at (same login as above):
http://c26.servage.net/~sc33143-AFJT/gallery2/

When I try to upload as registered user I get this error which I also had gotten before on the previous version at times:

The file 'albums/userpics/IMG_4129.jpg' can't be inserted in the album
The image you have uploaded is corrupted or can't be handled by the GD library


If I log in as admin I can upload no problem, without any errors.
Logged

Nibbler

  • Guest
Re: The selected album/file does not exist.
« Reply #5 on: August 18, 2007, 03:13:15 am »

My test upload worked, so maybe your file actually is corrupted or can't be handled by the GD library. Post more details.
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #6 on: August 18, 2007, 03:20:02 am »

Sorry just realised I forgot to increase file upload size for the groups in the new install of cpg1.4.12. Seems to work perfectly with the new version.

I'll try a upgrade on the 1.4.10 and see how it affects my mods  :P If it doesn't work I'll do a new version of 1.4.12. 

Thanks guys.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: The selected album/file does not exist.
« Reply #7 on: August 18, 2007, 10:22:09 am »

After having upgraded cpg to version 1.4.12 you'll have to apply Stramm's modpack for cpg1.4.12, which is available for download as well.
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #8 on: August 25, 2007, 07:46:13 am »

Hi Guys,

I've upgraded both cpg and the stramm modpack to 1.4.12. I thought I had it figured but now it doesn't work for either admin/user.

As user:
After uploading image, entering pic details and clicking continue it loads a blank page (upload.php)

As admin:
After uploading, entering details and continuing I get this error:
"Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 10240 bytes) in /..../swisshut.com/gallery/include/picmgmt.inc.php on line 434"

These are the settings in my htaccess:
php_value upload_max_filesize 100M
php_value post_max_size 100M
php_value memory_limit 40M
php_value max_execution_time 60
php_value max_input_time 120

In my web host ACP I have tried switching these settings to off:

PHP Safe Mode
PHP Safe Mode GID
PHP Register Globals

Album link: http://gallery.swisshut.com
login: debugtest
pass: debugpass
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #10 on: August 25, 2007, 08:15:07 am »

I've read that before GauGau,

I've calculated the size of my image and its way under what I've allowed for in my htaccess file.
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #11 on: August 25, 2007, 11:42:06 am »

I got a email to approve a picture from you GauGau, strange because the test user is set to not need permission. Were you able to upload and place the image into a album? It's not usualy the uploading that causes the problem but the placing of the picture into a album afterwards.  :-\

thanks for checking it out for me.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: The selected album/file does not exist.
« Reply #12 on: August 25, 2007, 02:00:44 pm »

Disabling admin approval would have been helpfull... ::)
Logged

OzButcher

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 44
Re: The selected album/file does not exist.
« Reply #13 on: August 25, 2007, 03:31:30 pm »

It is... I don't understand why its asking for permission? Hmmm something big must have gone wrong. Maybe I should install again from fresh? ???

[Edit GauGau] Replaced hotlinked image with attachment [/Edit]
« Last Edit: August 26, 2007, 10:12:59 am by GauGau »
Logged
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.