Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Problems uploading files. It did work before.  (Read 3614 times)

0 Members and 1 Guest are viewing this topic.

kevertje

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Problems uploading files. It did work before.
« on: June 27, 2007, 06:22:34 pm »

http://www.kevertje.net/pictures/index.php

Created new album on my website and that works.
I tried to add files and selected the folder where I uploaded all the JPG files.
When I clicked on the specific folder I can see all the JPG files. Looks perfect. When moving on I normally see little thumbnails of each picture. (list of new files)
No thumbs overthere. Selecting the album I want and pressing the button to insert the pictures in that album gives the message that Coppermine was not able to show the resized picture or not able to resize the picture.

Even uploading one by one (when using the upload file button on top) didn't work.

I'm using Coppermine for ages (last upload 2nd of june and as far as I can see nothing changed since than).

Interesting enough: when selecting a folder which already exists for ages it does recognize the pictures and shows me the thumbs ! I checked the 755/777 stuff and all is the same (old folder is the same as the new)

Any tips tricks ?
« Last Edit: June 29, 2007, 07:16:08 am by Sami »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Logged

kevertje

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Problems uploading files. It did work before.
« Reply #2 on: June 28, 2007, 04:39:46 pm »

Hereby some debugging. I tried creating an account but can't find out how to create a user which stricht "per album" access only... I'm scared that I give full access to everyone ;)


Code: [Select]
USER:
------------------
Array
(
    [ID] => d7f90686b78fe9d90fb46b06e32a96f3
    [am] => 1
    [lang] => dutch
    [liv] => Array
        (
            [0] => 23
            [1] => 1317
            [2] => 1318
            [3] => 1319
        )

)

==========================
USER DATA:
------------------
Array
(
    [user_id] => 2
    [user_name] => admin
    [groups] => Array
        (
            [0] => 1
        )

    [disk_max] => 0
    [disk_min] => 0
    [can_rate_pictures] => 1
    [can_send_ecards] => 1
    [ufc_max] => 0
    [ufc_min] => 0
    [custom_user_upload] => 0
    [num_file_upload] => 1
    [num_URI_upload] => 0
    [can_post_comments] => 1
    [can_upload_pictures] => 1
    [can_create_albums] => 1
    [has_admin_access] => 1
    [pub_upl_need_approval] => 0
    [priv_upl_need_approval] => 0
    [group_name] => Administrators
    [upload_form_config] => 0
    [group_quota] => 0
    [can_see_all_albums] => 1
    [group_id] => 1
)

==========================
Queries:
------------------
Array
(
    [0] => SELECT extension, mime, content, player FROM cpg_filetypes; (0s)
    [1] => select * from cpg_plugins order by priority asc; (0s)
    [2] => delete from `kevertje_copp1`.cpg_sessions where time<1183037440 and remember=0; (0s)
    [3] => delete from `kevertje_copp1`.cpg_sessions where time<1181831440; (0s)
    [4] => select user_id from `kevertje_copp1`.cpg_sessions where session_id=md5("1a13237b681ac0e0252c4a4d59b026b9db70db5d85bb4c8a79b1ba651f447e00"); (0s)
    [5] => select user_id as id, user_password as password from `kevertje_copp1`.cpg_users where user_id=2 (0s)
    [6] => SELECT u.user_id AS id, u.user_name AS username, u.user_password AS password, u.user_group+100 AS group_id FROM `kevertje_copp1`.cpg_users AS u INNER JOIN `kevertje_copp1`.cpg_usergroups AS g ON u.user_group=g.group_id WHERE u.user_id='2' (0s)
    [7] => SELECT user_group_list FROM `kevertje_copp1`.cpg_users AS u WHERE user_id='2' and user_group_list <> ''; (0s)
    [8] => SELECT MAX(group_quota) as disk_max, MIN(group_quota) as disk_min, MAX(can_rate_pictures) as can_rate_pictures, MAX(can_send_ecards) as can_send_ecards, MAX(upload_form_config) as ufc_max, MIN(upload_form_config) as ufc_min, MAX(custom_user_upload) as custom_user_upload, MAX(num_file_upload) as num_file_upload, MAX(num_URI_upload) as num_URI_upload, MAX(can_post_comments) as can_post_comments, MAX(can_upload_pictures) as can_upload_pictures, MAX(can_create_albums) as can_create_albums, MAX(has_admin_access) as has_admin_access, MIN(pub_upl_need_approval) as pub_upl_need_approval, MIN( priv_upl_need_approval) as  priv_upl_need_approval FROM cpg_usergroups WHERE group_id in (1) (0s)
    [9] => SELECT group_name FROM  cpg_usergroups WHERE group_id= 1 (0s)
    [10] => update `kevertje_copp1`.cpg_sessions set time='1183041040' where session_id=md5('1a13237b681ac0e0252c4a4d59b026b9db70db5d85bb4c8a79b1ba651f447e00'); (0s)
    [11] => SELECT user_favpics FROM cpg_favpics WHERE user_id = 2 (0s)
    [12] => DELETE FROM cpg_banned WHERE expiry < '2007-06-28 16:30:40' (0s)
    [13] => SELECT * FROM cpg_banned WHERE (ip_addr='192.16.190.1' OR ip_addr='192.16.190.1' OR user_id=2) AND brute_force=0 (0s)
    [14] => SELECT category FROM cpg_albums WHERE aid='30' (0s)
    [15] => SELECT COUNT(*) FROM cpg_pictures WHERE approved = 'NO' (0s)
)

==========================
GET :
------------------
Array
(
)

==========================
POST :
------------------
Array
(
    [album] => 30
    [MAX_FILE_SIZE] => 1310720
    [title] =>
    [caption] =>
    [keywords] =>
    [event] => picture
)

==========================
VERSION INFO :
------------------
PHP version: 4.4.2 - OK
------------------
mySQL version: 4.1.21-standard
------------------
Coppermine version: 1.4.10(stable)
==========================
Module: GD
------------------
GD Version: bundled (2.0.28 compatible)
FreeType Support: 1
FreeType Linkage: with freetype
T1Lib Support:
GIF Read Support: 1
GIF Create Support: 1
JPG Support: 1
PNG Support: 1
WBMP Support: 1
XBM Support: 1
JIS-mapped Japanese Font Support:

==========================
Module: mysql
------------------
MySQL Supportenabled
Active Persistent Links 0
Active Links 1
Client API version 4.1.21
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /var/lib/mysql/mysql.sock
MYSQL_INCLUDE -I/usr/include/mysql
MYSQL_LIBS -L/usr/lib64 -lmysqlclient 
==========================
Module: zlib
------------------
ZLib Support enabled
Compiled Version 1.2.1.2
Linked Version 1.2.1.2
==========================
Server restrictions (safe mode)?
------------------
Directive | Local Value | Master Value
safe_mode | Off | Off
safe_mode_exec_dir | no value | no value
safe_mode_gid | Off | Off
safe_mode_include_dir | no value | no value
safe_mode_exec_dir | no value | no value
sql.safe_mode | Off | Off
disable_functions | exec, shellexec, passthru, system, escapeshellcmd, escapeshellarg | exec, shellexec, passthru, system, escapeshellcmd, escapeshellarg
file_uploads | On | On
include_path | .:/usr/lib/php:/usr/local/lib/php | .:/usr/lib/php:/usr/local/lib/php
open_basedir | no value | no value
==========================
email
------------------
Directive | Local Value | Master Value
sendmail_from | no value | no value
sendmail_path | /usr/sbin/sendmail -t -i | /usr/sbin/sendmail -t -i
SMTP | localhost | localhost
smtp_port | 25 | 25
==========================
Size and Time
------------------
Directive | Local Value | Master Value
max_execution_time | 30 | 30
max_input_time | 60 | 60
upload_max_filesize | 10M | 10M
post_max_size | 8M | 8M
==========================
Page generated in 0.666 seconds - 16 queries in 0 seconds - Album set : ; Meta set: ;
« Last Edit: June 29, 2007, 07:40:41 am by Hein »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problems uploading files. It did work before.
« Reply #3 on: June 28, 2007, 05:15:52 pm »

Hereby some debugging.
Haven't asked for it. In the upload troubleshooting section I refered to above there's the advice NOT to post debug_output unless requested.

I tried creating an account but can't find out how to create a user which stricht "per album" access only... I'm scared that I give full access to everyone ;)
You're suppossed to create a non-admin user and post the account data. If you don't, we can't help you. You can safely disable that test user once your issues are solved, so there's no reason to be afraid.

Failing to RTFM and start a new posting without proper information (although you agreed otherwise when signing up) is just lazy. Failing to do as suggested even when being told exactly what to do is ignorant. I'm reluctant to look into your issues unless you do your homework first.
Logged

kevertje

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Problems uploading files. It did work before.
« Reply #4 on: June 28, 2007, 06:22:23 pm »

I'm sorry but I read the whole upload manual and even can remember that I changed some files in the past to get things working.
Right now I'm on a different server than before so that change is not needed anymore (I checked it)

I created a user called non-admin with password non-admin
http://www.kevertje.net/pictures/

I'm still scared what people might be able to do with it but I will read this topic later this evening.

thanks for your patience so far and I hope you can help. (I tried changing the coppermine settings to ENGLISH but it seems it keeps getting back to DUTCH again)

Het bestand 'albums/userpics/madrid-001.jpg' kan niet ingevoegd worden in het album.
Means : "the file 'albums/userpics/madrid-001.jpg' can not be inserted in the album"

Niet in staat de verkleinde afbeelding of de afmetingen van de afbeelding aan te passen.
Means : "not able to change the resized picture or not able to resize the picture"

Bestand: /home/kevertje/public_html/pictures/db_input.php - Regel: 402
Means: " file : /home/kevertje/public_html/pictures/db_input.php - line: 402"
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Problems uploading files. It did work before.
« Reply #5 on: June 28, 2007, 07:13:27 pm »

Go to http://www.kevertje.net/pictures/?lang=english to temporarily switch to English, http://www.kevertje.net/pictures/?lang=xxx to go back to your language.

Search the board for the error message "Unable to create thumbnail or reduced size image"

Main reasons for this error:
  • Permissions on file/folder level not set properly
  • Poorly configured safe_mode
  • Wrong "method for resizing images" specified in Coppermine's config
Try the solutions provided in the threads that should show up as search results.

Logged

kevertje

  • Coppermine newbie
  • Offline Offline
  • Posts: 11
Re: Problems uploading files. It did work before.
« Reply #6 on: June 28, 2007, 08:15:04 pm »

Main reasons for this error:
  • Permissions on file/folder level not set properly

Checked, all seems to be in place.

Quote
  • Poorly configured safe_mode
<?php

    define ( 'SILLY_SAFE_MODE' , 1 ) ;

    $CONFIG['dbserver'] = 'localhost' ;
    $CONFIG['dbuser'  ] = 'kevertje_copp1' ;
    $CONFIG['dbpass'  ] = 'ko2rF5tbDl5b' ;
    $CONFIG['dbname'  ] = 'kevertje_copp1'   ;

    $CONFIG['TABLE_PREFIX'] = 'cpg_' ;

?>

Quote
  • Wrong "method for resizing images" specified in Coppermine's config
Try the solutions provided in the threads that should show up as search results.

That's it ! I changed it to GD 2 and now it seems to work.

Can you tell me: is this something my provider could have changed in the meantime ? I'm on a shared hosting server and they use cpanel (which you guys don't like) :-)
DOn't want to fingerpoint but I just wonder why things are broken without me doing something ?

thanks


[/quote]
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Problems uploading files. It did work before.
« Reply #7 on: June 29, 2007, 07:15:22 am »

Probably they have changed I.M 's path !
Logged
‍I don't answer to PM with support question
Please post your issue to related board
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.