Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Search Favorites User Mode  (Read 4545 times)

0 Members and 1 Guest are viewing this topic.

Bri32560

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Search Favorites User Mode
« on: June 27, 2007, 08:29:48 am »

I have recently found that I have a few functions that are not working.

If I do a search the search finds the files I am looking for and displays the thumbnails.  If I click on the thumbnail I get no Image to Display.  Have cleared cookies and cache same problem.

If I am viewing a picture and click on add to favorites I get The selected album/file does not exist !

If I click on user mode I get leaving admin mode then it returns back to where it was, this used to work.  I had never tried the search or the favorites before but have several people who want to use them due to the number of pictures they are looking through.

I am sure this is a simple fix but I have read and searched for days and have not been able to find a fix. 
Any help would be appreciated

Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Favorites User Mode
« Reply #1 on: June 27, 2007, 09:42:50 am »

1) Post a link to your gallery for a start
2) Never leave admin mode unless you know what it was designed for. If you have no clue, read it up in the docs
Logged

Bri32560

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Search Favorites User Mode
« Reply #2 on: June 27, 2007, 03:33:18 pm »

Logged

Bri32560

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Search Favorites User Mode
« Reply #3 on: June 27, 2007, 04:15:07 pm »

I have also turned on debug and noticed I do get a lot of errors.

I just upgraded to 1.4.10 about a week ago.

I also noticed with 1.4.5 an unregistered user could see all thumbnails but had to register to see anything else.  Now an unregistered user can see intermediate pictures as well.  I don't see anyway to change this other than set it so you have to register to see anything.  I don't really want to do it that way liked it where you could view thumbnails but had to register to see intermediate and full size pictures.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Favorites User Mode
« Reply #4 on: June 27, 2007, 05:25:07 pm »

I have also turned on debug and noticed I do get a lot of errors.
Don't enable debug_output if you have no idea what it is and if a supporter hasn't asked for it to be turned on. Leave notices_display turned off at all times - it's a developer-only feature (as suggested in the docs). As the name suggests, it doesn't display errors, but notices, which is an entirely different animal. Developers use it during design and bug-hunting stages. End users like you shouldn't enable it at all. Your report sound a bit like a bad joke where a man sees his doctor and complains "whenever I hit myself on the head, it hurts badly". Doctor's advice of course is: "don't hit yourself on the head in the first place"!

I also noticed with 1.4.5 an unregistered user could see all thumbnails but had to register to see anything else.  Now an unregistered user can see intermediate pictures as well.  I don't see anyway to change this other than set it so you have to register to see anything.  I don't really want to do it that way liked it where you could view thumbnails but had to register to see intermediate and full size pictures.
That's nonsense - this has never been a feature of cpg1.4.5. You must have applied the hack suggested in http://coppermine-gallery.net/demo/cpg14x/docs/faq.htm#viewThumbnailsOnly to your cpg1.4.5 gallery. When upgrading, the hack was of course lost - if you need it, you'll have to re-apply it to the cpg1.4.10 core code again. However, this issue is in no way related to your initial issue; we have a strict "one question per thread" policy that you agreed to respect when signing up. Do so in the future - don't post various issues in one thread. You even reported various issues in your initial posting, which is wrong in the first place.

Both your irrelevant report about notices surprisingly displaying when the corresponding option is enabled in coppermine's config as well as your report about a missing feature that you have hacked into coppermine before makes it more likely in my opinion that regarding this thread's initial issue the error is on your end (PEBCAK issue).

If I do a search the search finds the files I am looking for and displays the thumbnails.
Provide a search term to search for.

If I am viewing a picture and click on add to favorites I get The selected album/file does not exist !
Confirmed. Would have moved this thread to the bugs board for further investigation, as it happens on the demo as well. However, as this thread is too much cluttered already, I won't.

If I click on user mode I get leaving admin mode then it returns back to where it was
As suggested: never leave admin mode if you have no idea what user mode is meant to be used for.

Logged

Bri32560

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Search Favorites User Mode
« Reply #5 on: June 27, 2007, 07:00:29 pm »

Turned off debug as requested

Must have hacked previous version as stated (don't remember doing any hacks to coppermine)

Search Term: Event: Trick Rider or Filename: IMG_2250

Only giving symptoms as I thought they might all be related.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Favorites User Mode
« Reply #6 on: June 27, 2007, 07:24:39 pm »

Can't confirm: when clicking on one of the thumbnails, I get "You need to register to access this page" - it appears that you have re-applied the hack discussed above. Subsequently, if you want supporters to look into your issues, you'll have to provide a non-admin test user account. ::)
Please don't make it so hard to support you. Remember: we don't get paid.
Logged

Bri32560

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Search Favorites User Mode
« Reply #7 on: June 27, 2007, 07:44:37 pm »

sorry I created a test account before I started this topic but forgot to mention it in my post.

username test password test

Not trying to make it hard sorry.  I did re-apply the hack discussed above due the the aggreement we have with the parents of the children in the pictures.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Favorites User Mode
« Reply #8 on: June 28, 2007, 07:52:44 am »

Search works as expected for me. Clear your cookies.
Logged

Bri32560

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Search Favorites User Mode
« Reply #9 on: June 28, 2007, 10:35:13 am »

The problem turned out to be firewall settings in Zone Alarm.
Everything functions normal however I do get The selected album/file does not exist !  when clicking on add to favorites.
Logged
Pages: [1]   Go Up
 

Page created in 0.029 seconds with 19 queries.