Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Search Engine Friendly URLs Broke My Forum!  (Read 5879 times)

0 Members and 1 Guest are viewing this topic.

MatthewSchenker

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Search Engine Friendly URLs Broke My Forum!
« on: June 23, 2007, 03:29:54 pm »

Hello,
This morning, I installed the "Search Engine Friendly URLs v1.0" plugin.
Now, when anyone tries to sign into my forum, this error appears:
Forbidden
You don't have permission to access /CoppermineMain/index.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


How do I recover from this?

Thanks!
« Last Edit: June 25, 2007, 09:47:57 am by GauGau »
Logged

MatthewSchenker

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #1 on: June 23, 2007, 03:55:44 pm »

I just went into my php account and fixed this problem.  Also, I deleted the .htaccess file from the Coppermine folder.  The forum is up again.

Why in the world is this plugin even available from the admin page?

I have a suggestion.  Change the current description for the text of the plugin.  Instead of this:
"Makes SEF URLs for index, thumbnails, and displayimage.php.
Warning: this plugin is still experimental, there are known issues when using it. Test thoroughly and use at your own risk."

Try this:
"Do not install this plugin.  It will make your forum inoperable."
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #2 on: June 25, 2007, 09:46:59 am »

I disagree:
1) Coppermine is a gallery, not a forum. Therefor, a Coppermine plugin could possibly not ruin your forum, but only your gallery
2) Others use the plugin just fine. That's why your reply is just irrelevant.
3) In future versions, the plugin won't be bundled with the coppermine core package, but will be available as a separate download only to avoid newbies ruining their gallery without reading the caveats first.
Logged

MatthewSchenker

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #3 on: June 25, 2007, 02:05:09 pm »

GauGau,
I don't understand what you mean when you say "I disagree."
When I loaded this plugin, my forum would not work.  When I uninstalled it, the forum worked again.  My forum is bridged with Coppermine.  The plugin also broke the gallery.

As for the rest of your responses, I don't quite understand why you need to be so rude.  I read the caveats.  But the caveats say "there are known issues when using it."  But it's more than "known issues."  The plugin will totally break your gallery, as well as any bridged forum.

And I don't get your comment about my "reply" being "irrelevant."  It was my post, so how can my reply be irrelevant?
Logged

Abbas Ali

  • Administrator
  • Coppermine addict
  • *****
  • Country: in
  • Offline Offline
  • Gender: Male
  • Posts: 2165
  • Spread the PHP Web
    • Ranium Systems
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #4 on: June 25, 2007, 02:20:07 pm »

I don't understand what you mean when you say "I disagree."

GauGau (and rest of us) disagrees on your suggestion to change the description of the plugin which is shown on plugin manager page.

Quote
And I don't get your comment about my "reply" being "irrelevant."  It was my post, so how can my reply be irrelevant?

Your post is the first post you made in which you described your issue. Your second post is called a reply in which you made some suggestions. And it was irrelevant since (as GauGau clearly mentions) Others use the plugin just fine.

Hope that answer your questions.
Logged
Chief Geek at Ranium Systems

MatthewSchenker

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 38
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #5 on: June 25, 2007, 02:26:58 pm »

Abbas,
If other people get this plugin to work, then I apologize.  Reading through this forum, however, I haven't found anyone who got it to work.

I understand now.  GauGau didn't mean my reply was irrelevant.  He meant my entire discussion was irrelevant.  Sorry I didn't quite understand just how insulting he was being.
Logged

tfischer

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 75
    • Fischersplace Photo Gallery
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #6 on: July 10, 2007, 09:54:03 pm »

Abbas,
If other people get this plugin to work, then I apologize.  Reading through this forum, however, I haven't found anyone who got it to work.

I have used the SEF plugin for well over a year and have had no major issues with it (I think the only one I've run into is that you can't manually change the order of photos if you use it). 

I think I also had to tweak the .htaccess file a bit to get it to work right, but I don't remember anymore...  But it does indeed work.

-Tim
Logged

GamingLoft

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #7 on: July 20, 2007, 11:28:18 am »

nope, i installed the plugin and im having permission errors, im going to try what Matt said.

i was just about to make my own thread when i stumbled across this.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Search Engine Friendly URLs Broke My Forum!
« Reply #8 on: July 20, 2007, 03:26:42 pm »

You should have started a thread of your own, instead of replying to the flame that Mr. Schenker posted. That's why this thread has been marked as "invalid". Apparently this is not enough - of the myriads of threads that deal with the SEF_URLs plugin, you had to reply to the one that is invalid. To keep this from happening, I'm forced to lock this thread *sigh*.
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 20 queries.