Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1] 2   Go Down

Author Topic: Activated German but Google lists English Titles  (Read 10755 times)

0 Members and 1 Guest are viewing this topic.

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Activated German but Google lists English Titles
« on: June 15, 2007, 07:04:37 pm »

Hi have got a problem with the language setup. In the config I disabled German for the main language and deactivated alle the others. But in google the title is listed in English, how can I fix that?
« Last Edit: July 02, 2007, 07:47:24 am by GauGau »
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #1 on: June 16, 2007, 05:30:06 am »

Could you please post a link to the gallery and the link to the search results showing the listing?
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Activated German but Google lists English Titles
« Reply #2 on: June 25, 2007, 06:58:45 pm »

If you want your gallery to be in German only, delete all files from the lang folder but german.php
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #3 on: June 25, 2007, 07:21:30 pm »

Really delete every language? But I adjusted "no english when german text is somewhere missing" in the config, is that not ok?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #4 on: June 25, 2007, 08:55:42 pm »

Do you have links to the other languages? This happened to me when I was using the flag feature to point to different languages. I switched to the drop down method and now things are fine.
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #5 on: June 25, 2007, 09:12:16 pm »

Because of my problem, I switched all other languages off.
For example look here: http://209.85.135.104/search?q=cache:rSi9ByCtzCIJ:www.bollybilder.de/+bollywood+bilder&hl=de&ct=clnk&cd=32&gl=de&lr=lang_de

Menue is in English, why?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #6 on: June 25, 2007, 10:01:49 pm »

When I view the live version, it shows english to me, too. Make sure that you're setting the language in the admin panel, and not just on the gallery, which only changes it for you.
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #7 on: June 25, 2007, 10:34:08 pm »

Didnt even know there is ja setting for gallery language. I adjusted it in the admin panel but how can you see English in the live version? Do you mean the link www.bollybilder.de? Is it really English? If yes, can you send me please a screen?

So should I just delete all the languages?! If I do that, sure there will be text displayed (German)?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #8 on: June 25, 2007, 10:58:01 pm »

Even after you changed the setting, I still see English. I deleted the domain cookies to make sure. It might also be because I have an English browser... CPG might be auto-detecting.
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #9 on: June 25, 2007, 11:26:03 pm »

Yes this was also my thought. I deleted English files, can you please once again?! ^^
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #10 on: June 25, 2007, 11:40:08 pm »

Now I get a blank white page. :(
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #11 on: June 25, 2007, 11:44:21 pm »

OK thats not good ^^ Correct again?
Logged

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #12 on: June 26, 2007, 01:09:37 am »

It's back up, and still in English.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Activated German but Google lists English Titles
« Reply #13 on: June 26, 2007, 06:28:09 pm »

Yes, the google bot might "speak" English, so he'll "see" your menu items in English. You better read up how languages work in Coppermine: http://documentation.coppermine-gallery.net/languages.htm#how and http://coppermine-gallery.net/demo/cpg14x/custom_language.php
Don't look at pages from the google cache - look at live-pages instead (http://www.google.com/search?q=site%3Abollybilder.de, see attached screenshot, taken from a PC with German OS and German browser preferences).

I'm serious: delete all language files from the lang folder except german.php. In your case, this seems to be the ideal solution.

Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #14 on: June 26, 2007, 07:03:05 pm »

But we already have tested it yesterday. I deleted all files except german and then the user saw blank page!
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Activated German but Google lists English Titles
« Reply #15 on: June 26, 2007, 07:59:57 pm »

Custom language settings get saved in a cookie. If you now delete certain languages and a user has set one of these as a custom language (with the lang selector), cpg still tries (cause of the cookie) to load it and fails.
Clear your cookies or change the cookie name in config (all your users get assigned a new cookie without custom lang settings)

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #16 on: June 26, 2007, 08:16:02 pm »

My project is new and we just talk about the searchengines!
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Activated German but Google lists English Titles
« Reply #17 on: June 27, 2007, 09:02:35 am »

Stramm's suggestion applies anyway: you'll have to delete your local cookie if you have issues with blank pages. Search engine spiders are not impacted by cookies - they don't take them into account. However, all changes you make will of course not have an immediate impact on the database of search engines, but will change only after the search engine spiders have re-visited your site.

Your reply
My project is new and we just talk about the searchengines!
just is irrelevant and confrontational. Just two postings above you complained about the user seeing a blank page, so it was you who started discussing user issues instead of search engine issues. If you don't want our advice, just stop posting here.
« Last Edit: June 27, 2007, 09:12:07 am by GauGau »
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #18 on: June 27, 2007, 01:47:31 pm »

Stay cool GauGaum, with "user" was ment a user here in the forum, which helped me testing! So we just talk about the search engines! Please read corretly and dont shout always  ;D

I will try your option, if there will be problems, I just will restore the files, thx for your help guys!
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #19 on: June 28, 2007, 04:49:52 pm »

One last question. No that I deleted the English file, I get blank emails from the System because of the missing English text. How can I change the language for the email notification?
Logged
Pages: [1] 2   Go Up
 

Page created in 0.022 seconds with 20 queries.