Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 [2]   Go Down

Author Topic: Activated German but Google lists English Titles  (Read 10675 times)

0 Members and 1 Guest are viewing this topic.

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #20 on: June 28, 2007, 06:51:05 pm »

I deleted my cookies for the domain and it shows up as blank. Did you happen to edit either your english.php or german.php file(s)?
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #21 on: June 28, 2007, 06:56:16 pm »

I asked about the email which is blank, not the website. It seems that "not german users" have blank pages, cant do anything about it. I just renamed the coockiename, maybe it works no?
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Activated German but Google lists English Titles
« Reply #22 on: June 29, 2007, 08:50:23 am »

1- set your default language to german
config=>Language & Charset settings=>Language=> german

2-set the Fallback to English to No
config=>Language & Charset settings=>Fallback to English if translated phrase not found?=> No

3- set Display language list to no
config=>Language & Charset settings=>Display language list=> No

4- set Display language flags to no
config=>Language & Charset settings=>Display language flags=> No

5- Delete all language file except german.php
6- rename your cookie name or tell everyone to clear their browsers cookie
Logged
‍I don't answer to PM with support question
Please post your issue to related board

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #23 on: June 29, 2007, 12:32:07 pm »

THX but all that things I already did.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Activated German but Google lists English Titles
« Reply #24 on: June 29, 2007, 03:08:24 pm »

With what result for the (human) client? I changed my browser's default language to english and tried accessing your site, which worked fine. What's your actual issue? As suggested, it will take some time untill the search engine spiders react and your pages will be crwaled in German only.
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #25 on: June 29, 2007, 03:16:07 pm »

Yes I have to wait for the spider. The only thing now is, that some people here tell me that they get a blank page?!
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Activated German but Google lists English Titles
« Reply #26 on: June 29, 2007, 03:53:32 pm »

Count me in , I got blank page too !
with german language it's ok but when I clear my cookie it will display blank page !!!
I think there was a problem with his files (file corruption)
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Activated German but Google lists English Titles
« Reply #27 on: June 29, 2007, 04:04:13 pm »

Can't replicate either. http://www.bollybilder.de/?lang=english works fine - I get the page in german. Even with a PC with English Windows and user preferences set to English I get to see the page just fine.

@Sami: does this still happen for you, or do you now see the page OK even with your cookies deleted?
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #28 on: June 29, 2007, 05:44:09 pm »

I also changed the coockiename, it must go!
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Activated German but Google lists English Titles
« Reply #29 on: June 30, 2007, 12:29:53 am »

No I still get blank page !!!
tried it with:
- IE with ?lang=english and without
- FF with ?lang=english and without
both are blank !
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47844
  • aka "GauGau"
    • gaugau.de
Re: Activated German but Google lists English Titles
« Reply #30 on: June 30, 2007, 12:06:30 pm »

OK, let's do it the brute-force way then: andy, edit include/init.inc.php, find
Code: [Select]
// We load the chosen language file
require "lang/{$CONFIG['lang']}.php";
and replace with
Code: [Select]
// We load the German language file no matter what
require "lang/german.php";
This should force German no matter what.
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #31 on: June 30, 2007, 12:15:49 pm »

Ok I have edited it, is it now ok or still blank?
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Activated German but Google lists English Titles
« Reply #32 on: June 30, 2007, 01:02:35 pm »

[Little bit OT]
There's also the possibility to disable the auto detection... that's the somehow softer method and it would be possible to keep all lang files on the server (users can still use the lang selector -> if admin enables that option)
http://forum.coppermine-gallery.net/index.php?topic=30686.msg142274#msg142274
[/Little bit OT]

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #33 on: June 30, 2007, 03:06:36 pm »

Thx for that option but I dont need any other language, only German.
Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Activated German but Google lists English Titles
« Reply #34 on: July 01, 2007, 06:53:55 am »

Ok now it's working fine :)
Logged
‍I don't answer to PM with support question
Please post your issue to related board

Tranz

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Female
  • Posts: 6149
Re: Activated German but Google lists English Titles
« Reply #35 on: July 01, 2007, 11:14:46 am »

Same here. :)
Logged

andyleery

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 78
Re: Activated German but Google lists English Titles
« Reply #36 on: July 01, 2007, 01:11:31 pm »

Great, finally it works^^, now I just wait for the engines. THX to you all for helping me.
Logged
Pages: 1 [2]   Go Up
 

Page created in 0.021 seconds with 21 queries.