Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Gallery say the selected album does not exist?  (Read 7839 times)

0 Members and 1 Guest are viewing this topic.

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Gallery say the selected album does not exist?
« on: June 03, 2007, 09:29:32 pm »

Hello.

I have the following issue when trying to bridge coppermine and phpbb:

Everything seems ok, but when trying to upĝoad a picture this message appears in Coppermine:
"The selected album/files does not exist!"
But the thing is; the picture actually get uploaded. I wonder how to fix this so that the (incorrect?) message is brought to silence...

Coppermine install: http://www.lhm-kafe.com/citroengalleriet/
Forum install: http://www.lhm-kaffe.com/forum/
Coppermine version: cpg1.4.10
Forum version: phpbb 2.0.22
Test user account: test_coppermine/ passwcopp
BridgeManager settings:
Forum URL:  sorry, not sure what to put in here...(where to take the information from) :-[
Relative path to your BBS's config file:  ../forum/ 
Use post-based groups?:  0
Cookie name/preifx:  phpbb2mysql

Hope for your help, please?
« Last Edit: June 07, 2007, 07:20:32 pm by Nibbler »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Gallery say the selected album does not exist?
« Reply #1 on: June 04, 2007, 09:17:07 am »

Coppermine install: http://www.lhm-kafe.com/citroengalleriet/
Actual gallery link: http://www.lhm-kaffe.com/citroengalleriet/ (mind the missing "f").

Actually, your login doesn't stick, as your use of the leading www subdomain is not consistent. You have to understand that cookies are domain-dependant, and www.lhm-kaffe.com differs from lhm-kaffe.com

Forum URL:  sorry, not sure what to put in here...(where to take the information from) :-[
Well, what's wrong with http://www.lhm-kaffe.com/forum/
Logged

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Gallery say the selected album does not exist?
« Reply #2 on: June 04, 2007, 11:27:51 am »

Thank you for replying.

Very sorry for the missing "f" - totaly my fault not checking my own spelling properly!

Ok, I understand it's important to be consistent regarding "www". My belive, and meaning is to use that everywhere, because I never knew anything else could be correct. There you have an idea about my level.... :(

Really would like not to come up with a follow-up question but I simply see no way around. I hope forum rules allows that. In what setting can tou see that I'm not consistent about "www"? You see, I have tried using it everywhere but I understand I made a mistake somewhere. Is it possible for you (and if so, will you be so kind) to tell me more about that?
Logged

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Gallery say the selected album does not exist?
« Reply #3 on: June 04, 2007, 11:35:20 am »

Sorry to bust in here again instantly, but I could not find a "edit" function. (Might be caused of my trouble with the language.) Please do not take this up as a second question (I know the rules about single questioning), but in case you are not able to tell me where (only that) I am not consistent, do you allow me to copy that line from your answer to bring it to my webhost support and beg them for help? Have to ask you this, because I must have help with this from someone that knows their way around. I surely do not!

Thank you.
Logged

Nibbler

  • Guest
Re: Gallery say the selected album does not exist?
« Reply #4 on: June 04, 2007, 01:41:01 pm »

You have a redirect http://www.lhm-kaffe.com/forum -> http://lhm-kaffe.com/forum/

Either remove that so you can use www.lhm-kaffe.com for both the gallery and the forum or set your forum's cookie domain to .lhm-kaffe.com

Concerning your oringinal issue - i already posted code to correct that so search the board.
Logged

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Gallery say the selected album does not exist?
« Reply #5 on: June 04, 2007, 07:34:35 pm »

Ok, thank you.

I'm in much to deep water for even trying a guess about tat redirect. I have heard about it, might think I know what it is.........that's it. The only thing I can see being a bit strange is the two gif-links at the gallerys top right/left. When using properties they show link without www - but checking the file containing them at the server clearly say www.

Suppose I have no other choise than to cntact webhost support asking for thei advice and help. They have a very, very kind attitude, but of course it's not sure they even have a possibility to figure out this. I suppose it is a user (me) fault here. :(

I must say I'm some confused about what you say regarding my original issue - you have posted solutions before. I thought GauGau actually answered conserning my issue? And you kindly following up above? Anyway, I did a lot of reading (search in forum) before posting here. Some "error"-pages came up, and a lot that I did not find to fit my problem. I'll try again of course, but need to fix this www-problem first thing.

Thank you both of you being patient with me. It's not your fault that I need more help tham you can or wish provide in this forum.   
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Gallery say the selected album does not exist?
« Reply #6 on: June 05, 2007, 08:07:42 am »

Consistent use of the leading subdomain www can be achieved by forcing every http call to either use www at all times or never to use it. The code snippet below (needs to go into a .htaccess file in your webroot) would change all requests to use your domain with the leading www:
Code: [Select]
RewriteEngine on
RewriteCond %{HTTP_HOST} ^www\.lhm-kaffe\.com$ [NC]
RewriteRule ^(.*) http://lhm-kaffe.com/$1 [R,L]
My guess is that you have such a .htaccess file in place, but not inside your webroot.
Logged

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Gallery say the selected album does not exist?
« Reply #7 on: June 05, 2007, 10:55:28 am »

Wow.....thank you a billion times, GauGau. ::) ;D  I will look into this - and give you the result.
Logged

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Gallery say the selected album does not exist?
« Reply #8 on: June 07, 2007, 11:33:41 am »

Ok, here I am again. The code you came up with, GauGau, worked fine. Only it was the opposite way around. ;) It made every page load without the www in the url.
To be sure not doing something wrong I contacted host support, because I have more than this one domain placed there I didn't want do do something that could effect another site. My knowledge.......

Thew support did several things, and no after some time the url comes up with www all over. The .htaccess are placed in the root of the domain. Actually support did it, I just checked it is in place.

The original problem "The selected album/files does not exist!" is still the same. :( I have searched the board but can't find anything relevant to my problem? Quit a few links are "broken", those in function that I see is not something I assosiate with my problem. But I might be wrong, og course.

So (very good) the redirect problem is fixed - "my problem" did not go away.... ??? 
Logged

Citroen

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 25
Re: Gallery say the selected album does not exist?
« Reply #10 on: June 07, 2007, 06:19:26 pm »

That did it. ;D :-* ;D
When I looked at that link now again I must admit that I in fact did see it when searching this board. But in all error and my confusion I thought of this one as an error as well. :-[ :(

I "salut" both of you for taking the time and effort helping me the way you did, not simply shut the door a long time ago. From my side I will do all I can to look for answers before asking next time, but it's a good feeling to know that if a problem becomes too big there are a couple of great people doing suport in this board.

I consider this as solved, thank you very, very much.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 20 queries.