Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: SQL error? Coppermine still blank  (Read 2127 times)

0 Members and 1 Guest are viewing this topic.

mel0

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
SQL error? Coppermine still blank
« on: May 10, 2007, 06:10:39 am »

I just moved to a new host and I got a backup of my SQL dump stuff luckily tonight after reading I needed it, I had already backed up my old Coppermine files so those were already uploaded.
So, I went to "restore the mySQL table by running the queries of the dump files you created in step 2"   as instructed, and it gives me this error:


Error
SQL query:

-- phpMyAdmin SQL Dump
-- version 2.9.0.2
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: May 09, 2007 at 10:43 PM
-- Server version: 4.1.22
-- PHP Version: 4.4.2
--
-- Database: `starry_cm`
--
-- --------------------------------------------------------
--
-- Table structure for table `cpg145_albums`
--
CREATE TABLE `cpg145_albums` (
`aid` int( 11 ) NOT NULL AUTO_INCREMENT ,
`title` varchar( 255 ) NOT NULL default '',
`description` text NOT NULL ,
`visibility` int( 11 ) NOT NULL default '0',
`uploads` enum( 'YES', 'NO' ) NOT NULL default 'NO',
`comments` enum( 'YES', 'NO' ) NOT NULL default 'YES',
`votes` enum( 'YES', 'NO' ) NOT NULL default 'YES',
`pos` int( 11 ) NOT NULL default '0',
`category` int( 11 ) NOT NULL default '0',
`thumb` int( 11 ) NOT NULL default '0',
`keyword` varchar( 50 ) default NULL ,
`alb_password` varchar( 32 ) default NULL ,
`alb_password_hint` text,
PRIMARY KEY ( `aid` ) ,
KEY `alb_category` ( `category` )
) ENGINE = MYISAM DEFAULT CHARSET = latin1 AUTO_INCREMENT =47;

MySQL said: Documentation
#1050 - Table 'cpg145_albums' already exists


And my Coppermine gallery just seems to be blank, http://melodyjustine.com/cm/
Doesnt seem like the dump worked...
Any help would be appreciated. I've been searching/reading for hours. Thanks.
« Last Edit: May 10, 2007, 07:03:19 pm by Nibbler »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: SQL error? Coppermine still blank
« Reply #1 on: May 10, 2007, 08:04:44 am »

If the table already exists you don't need to restore it. The dump you posted above is just the section that creates the empty table, not a dump that actually fills it with data. Is the dump you posted all you have? Then you don't have an actual dump, but only a structure.
There's only limited support for phpMyAdmin and database manipulation here.
Logged

mel0

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: SQL error? Coppermine still blank
« Reply #2 on: May 10, 2007, 06:38:24 pm »

The table wouldn't already exist because I just switched servers...?  I opened the .sql file in Notepad and it's VERY long, so I'm assuming it's the whole thing.. and what I posted above is what it shows me back as an error. Is it possible it is trying to load everything but doesn't because of the above error? 
I just want to get my old settings back without having to re-upload and configure everything again =[  Why is this so difficult to do? The instructions say to "restore the mySQL table by running the queries..."  is there some other way of doing this?
If there is "limited support" here, where should I go?  I doubt my host is going to know what to do about Coppermine.
Logged

mel0

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: SQL error? Coppermine still blank
« Reply #3 on: May 10, 2007, 07:02:36 pm »

Nevermind! I fixed it. Deleted all the tables and re-uploaded and everything works. PHEW!
Logged
Pages: [1]   Go Up
 

Page created in 0.025 seconds with 21 queries.