Advanced search  


cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.

Pages: [1]   Go Down

Author Topic: Upload trouble  (Read 3287 times)

0 Members and 1 Guest are viewing this topic.


  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Upload trouble
« on: June 24, 2007, 06:57:51 pm »

I've been running a Coppermine Gallery with 20 or so users and in excess of 400 images uploaded without a problem. Approx 10 days ago users started experiencing difficulty uploading images. I have read the FAQ and posts on this Forum but have been unable to resolve the issue.

I have followed the instructions to switch on debug mode and when uploading images the following message is generated:

'No file was uploaded !
If you have really selected a file to upload, check that the server allows file uploads...
File: /home/neathphotouk/public_html/gallery/db_input.php - Line: 311'

I checked the data returned by PHPinfo and note that the system build date was given as Jun 15 2007 around the time the upload issue first came to light. I contacted the company hosting the server who assured me that no changes had been made at their end.

I would therefore very appreciate your assistance.

relevant information is as follows

file uploads On
upload_max_filesize 2M
upload_tmp_dir no value
post_max_size 8M
memory_limit 8M
max_input_time- 60 seconds
allow_url_fopen on
safe_mode off

I have created a tmp directory in the cgi-bin and CHMOD 0777

I have created a test account as recommended:

username test
password test

Thanks in anticipation


« Last Edit: June 25, 2007, 08:12:31 am by GauGau »


  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Upload trouble
« Reply #1 on: June 25, 2007, 07:51:02 am »

This is now resolved.


Hein Traag

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: nl
  • Offline Offline
  • Gender: Male
  • Posts: 2166
  • A, B, Cpg
    • Personal website -
Re: Upload trouble
« Reply #2 on: June 25, 2007, 07:55:36 am »

This is now resolved.

Great! Excellent! Super! Awesome! etc.. etc.. Mind explaining how you resolved it  ;) others might benefit from it.



  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Upload trouble
« Reply #3 on: June 25, 2007, 07:47:21 pm »

Well for the record, the problem was solved after the service provider reset permissions on the server and configured in PHP Settings the upload_tmp_dir parameter pointing to a folder called /tmp with permissions set to 777.

I had already contacted the hosting service provider who had previously informed me that no change had been made to the server, but after reading the FAQs and posts on this Forum I was able to write a more informed request to which the service provider promptly responded.

What I have learned:

1. Setting permissions with an FTP client such as FileZilla does not always work despite attributes on folders/files appearing to have the correct permissions set. It is  still sometimes necessary to get the Service provider to reset permissions for you. Even then it can take 12 hours for the changes to take effect.

2l Managing folder permissions on a server is something of a dark art which more knowledgable people on this forum may able shed some light on.

3. I think key to my problem was the inablilty of PHP to be able to write to a temporary directory during the upload process. I believe the location of the tmp directory can be anywhere provided PHP knows where the directory is and is able to write to it  - this is done by setting upload_tmp_dir in the PHP configuration file to point to the tmp folder. Users may be able to alter the PHP Settings and configure upload_tmp_dir themselves through the site control panel or as in my case the Service provider was able to do this in a couple of minutes once you ask the right question.

4. What helped in the end was taking the time to read the information on this Forum to gain a better understanding of PHP in relation to Coppermine and then being in a position to ask the right questions whether that be in this Forum or to the Service provider.

5. In conclusion, I do feel that some of the answers on this Forum still leave the 'question' unanswered even when the problem is 'solved'. So in response to Heine's request for the solution to my upload problem, I hope others with a similar problem will find my explanation of some assistance.



Users may be able to created a /tmp in the root directory in with the correct permissions and it may be possible to point
Pages: [1]   Go Up

Page created in 0.028 seconds with 20 queries.