Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Photos uploaded to Coppermine directory but cannot add to Album(s)  (Read 5428 times)

0 Members and 1 Guest are viewing this topic.

Larry C

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • CHESEBRO' Genealogy

I have previously successfully added many photos and a wmv file but now, after successful ftp adding of new photos to Coppermine Gallery albums directory and setting their attributes to 555, I cannot add from the Coppermine album directory to either a new or existing (with photos) album.  I have tried both very small and very large gif and jpg files without success.  I have tried direct and batch uploading.

Using the "Batch add files" I select the appropriate Gallery directory containing the uploaded photos which they then appear in the next page where I select "OK".

The uploaded photos are listed on the "List of new files" page BUT their thumbnails do not show on the right side of the page - just a blank white graphic with a red "X".  When I select the red "X" a pop displays the photo. 

WhenI select the destination album and then "Insert selected files" the next page shows the same red "X" in the "Result" column which then, if selected, opens a pop-up with "Unable to create thumbnail or reduced size image."

My Gallery is a link in the left hand menu at http://chesebro.net

My email is Larry at Chesebro.net
« Last Edit: May 17, 2007, 12:23:46 pm by GauGau »
Logged

Larry C

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • CHESEBRO' Genealogy
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #1 on: May 11, 2007, 11:00:11 pm »

CORRECTION - attributes are 755  :-[
Logged

Larry C

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • CHESEBRO' Genealogy
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #3 on: May 12, 2007, 02:07:49 am »

I referred to the URL about "uploads" but I don't believe that is my trouble because I can ftp upload the photos - I cannot then add them to an album.  Please let me know if I missed something in the "upload" response.

thanks!
Logged

integam

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #4 on: May 12, 2007, 02:16:50 am »

I had the same problem on two new installs of Coppermine, but I never had it in the older versions.  However, my problem was solved by going to the Config menu... then to the "File and thumbnail advanced settings".  Look to see if "Method for resizing images" is set to Image Magick.  If it is, and you do not have Image Magick installed, that might be your problem.  Either install Image Magick, or change the setting to one of the GD versions (version 2.x worked for me).
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #5 on: May 12, 2007, 09:04:45 am »

Quote
4.11.4 Upload troubleshooting

If you are experiencing issues with coppermine's upload process, temporarily change your coppermine settings as suggested below to get more detailed error messages:

    * Go to your coppermine page and log in as admin
    * Go to the config screen
    * Scroll to the bottom of the page
    * Expand the "Maintenance settings" section by clicking on it
    * Enable debug mode for everyone
    * Leave display of notices switched off
    * Save the new settings by clicking on "Save new configuration"
    * Go to the "groups" panel
    * Set the upload form configuration for all groups to "Single file uploads only" (set File upload boxes to "1", URI upload boxes to "0" and No. of boxes to "fixed")
    * Save your new settings

Then try to upload (using http uploads, even if you experienced troubles using another upload method) - you should get a more detailed error message that tells you what exactly goes wrong with your uploads. If the error message doesn't mean anything to you, search the support board for the error message you get.
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested.

When people have issues with uploading and decide to post their question on the Coppermine support board, they usually are told to read this upload troubleshooting section. Many of them fail to do so properly, which results in frustration both for users as well as supporters. To make this absolutely clear: the above mentioned steps are absolutely mandatory, no matter what skill level you have, no matter what upload method you have troubles with. Failing to do exactly as suggested will result in your request for help being ignored. Yes, this applies to you. We mean it!
Logged

Larry C

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • CHESEBRO' Genealogy
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #6 on: May 12, 2007, 06:28:23 pm »

I, the administrator, have very carefully followed previous support options as follows:

"Single file uploads only" (set File upload boxes to "1", URI upload boxes to "0" and No. of boxes to "fixed")
++++++++++++++++++++++++++
COMPLETED - and is now the existing configuration

search the support board for the error message you get   
++++++++++++++++++++++++++
COMPLETED - 37 messages were found and reviewed. Most, as I remember all, referrred to earlier versions about troubles with ImageMajic, GD2/GD1, and bad jpeg/gif files and none had my debug_output data.  Most of the referrred help items returned 404 pages for additional help so I couldn't get help from them.

I had previously added many photos and clips - about 4 weeks prior to this week - without this trouble.  I had not made any previous Gallery changes prior to the support requested changes above.

The following is the current "error message":

The file 'albums/userpics/larry2yrs.jpg' can't be inserted in the album

Unable to create thumbnail or reduced size image.

File: /home/lanastl/public_html/gallery/db_input.php - Line: 402


The above file is only 13kb which I used the "Upload file" option in User mode as opposed to "Batch add files" in Admin mode to upload to the new Coppermine album mentioned below. I have tried larger files with same problem and with different destination albums

My URL is http://chesebro.net, the Gallery is selected from a menu on the left side of my opening page, "Coppermine" is the login free temporary album for testing.

TIA for your help,

Larry
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #7 on: May 14, 2007, 04:23:59 pm »

Actual gallery URL is http://chesebro.net/gallery/index.php - don't make us navigate your site just to figure out where your gallery actually is located at.
What "method for resizing pics" did you enable in Coppermine's config? Make sure that you actually have the image library available that you claim to have. Check your phpinfo page if you have GD enabled (refer to the FAQ for details).
Logged

Larry C

  • Coppermine newbie
  • Offline Offline
  • Gender: Male
  • Posts: 5
    • CHESEBRO' Genealogy
Re: Photos uploaded to Coppermine directory but cannot add to Album(s)
« Reply #8 on: May 17, 2007, 02:29:17 am »

GD Support was enabled (v2.0.28 compatible) BUT ImageMagik was selected - that was how it was originally configured from the beginning and worked for weeks  :-\

Thanks for your "patient" help    :D
Logged
Pages: [1]   Go Up
 

Page created in 0.024 seconds with 20 queries.