Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: uniq problem with friendly_urls  (Read 6159 times)

0 Members and 1 Guest are viewing this topic.

wipqozn1

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 60
uniq problem with friendly_urls
« on: May 07, 2007, 08:05:07 pm »

I read the forum before, but problem like this didn't come up so far.

I've got enabled mod_rewrite of course. After installing plugin when I click on one of my menu links it give me an error (I mean all of them give me this error):

Quote
The requested URL /my-profile.html was not found on this server.

So it's like this: mod_rewrite works properly (I redirect from www.blablah.com to blablah.com for example) but not in case of this plugin.

Any solution guys?
« Last Edit: May 08, 2007, 09:03:17 am by GauGau »
Logged

Nibbler

  • Guest
Re: uniq problem with friendly_urls
« Reply #1 on: May 07, 2007, 08:24:36 pm »

Which plugin is this?

Are you sure the www redirect actually uses mod_rewrite?
Logged

wipqozn1

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 60
Re: uniq problem with friendly_urls
« Reply #2 on: May 07, 2007, 08:58:05 pm »

This one: http://forum.coppermine-gallery.net/index.php?topic=25215.0

I thought there could be some cpg version differences but didn't find such ones.

Absolutely, I always use .htaccess to redirect from www to non-www. I've got dedicated server so I'm pretty sure what I've enabled :-)

Code: [Select]
RewriteCond %{HTTP_HOST} ^www.asd.com$
RewriteRule ^(.*)$ http://asd.com/$1 [R=301,L]

It works fine.
Logged

Nibbler

  • Guest
Re: uniq problem with friendly_urls
« Reply #3 on: May 07, 2007, 09:14:17 pm »

I don't see any feature in that plugin involving my-profile.html

Did you modify the .htaccess code to match your actual setup?

ie.

Code: [Select]
RewriteBase /votredossier
Edit:

If you are using the second plugin in that thread you'll need to adjust the rewrite rules - they assume the gallery is installed in the web root.
Logged

wipqozn1

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 60
Re: uniq problem with friendly_urls
« Reply #4 on: May 07, 2007, 09:43:36 pm »

My gallery is installed in web root :-)

http://gryz.pl

Now the plugin is enabled and as You can see, it rewrite all addresses to .html extension (sometimes analogue .php page doesn't even exist).  So it (more or less) work, but not properly.

I've attaches 2 files I use (as .txt files).

I've removed one line in htaccess:

Code: [Select]
Options +FollowSymlinks
'cause it gave me an Internal Error (500).
Logged

wipqozn1

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 60
Re: uniq problem with friendly_urls
« Reply #5 on: May 07, 2007, 11:39:34 pm »

One more example.

It shows link like this in cpg menu:

http://gryz.pl/top-rated-cat-0.html

(not found), but in fact it rewrites page to this address:

http://gryz.pl/top-rated-cat-0.php

who work properly (but doesn't appear in menu).
Logged

wipqozn1

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 60
Re: uniq problem with friendly_urls
« Reply #6 on: May 07, 2007, 11:52:45 pm »

Well, I didn't do it before since I thought it'd be to easy...

I've replaced all .html strings in codebase.php with .php

Now everything works fine. Problem solved.
Logged
Pages: [1]   Go Up
 

Page created in 0.018 seconds with 19 queries.