Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: 1 ... 11 12 13 14 [15] 16 17 18 19 ... 33   Go Down

Author Topic: Upload applet (JUpload) : the easiest upload !  (Read 650485 times)

0 Members and 1 Guest are viewing this topic.

erostew

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
Re: Upload applet (JUpload)
« Reply #280 on: November 14, 2007, 10:52:58 am »

I think that I misunderstood what you said earlier, but I have sent you a PM with the login details now.
Thank you for all your help, it's really appreciated!
I found that the jupload config for uploaded photos did not exactly match the coppermine upload policy for uploads so I made a couple of changes to the jupload config. After that I tried an upload and it failed. I tried with a photo that needed resizing and one that didn't.I also tried with metadata set to default and then set to false. No Luck. Normal upload worked correctly. All coppermine files list as having the correct version numbers.

The only thing I found that might indicate a problem: When uploading with the normal CPG upload I could select any album so I uploaded to an album I created with no category. When uploading with JUpload I had only the option to upload to the personal albums category, so I created an album and tried to upload.

All other albums on the site were "no category" albums, but I couldn't select any "no category" album in the JUpload page. Not sure if this is some kind of permissions issue or a limitation in the JUpload plugin.

So unfortunately I couldn't figure out the problem, but I did save a log file so that Etienne may be able to get a clue to the problem. It is attached here with server and username info removed.

Sorry I couldn't help more.

Regards
Logged

evilmaster

  • Coppermine newbie
  • Offline Offline
  • Posts: 5
Re: Upload applet (JUpload)
« Reply #281 on: November 14, 2007, 11:03:19 am »

So unfortunately I couldn't figure out the problem, but I did save a log file so that Etienne may be able to get a clue to the problem. It is attached here with server and username info removed.

Sorry I couldn't help more.

Regards

Thanks for trying though... I guess we'll have to continue using the XP Publishing Wizard for the time being.
Logged

etienne_sf

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Upload applet (JUpload)
« Reply #282 on: November 16, 2007, 02:08:04 pm »

Thanks for trying though... I guess we'll have to continue using the XP Publishing Wizard for the time being.

Hi,

  Sorry for answering only now, and thanks to erostew for the help given. But I'm really busy these days...

FYI: the message 'run().finally' is perfectly normal (means the applet entered an erea where it will free some used memory).

If my first analysis is correct, the INSERT doesn't work. You should have an error in the log. Can you give me the URL and password, by PM. I'll go there.

Etienne
Logged

World-Charmed

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Upload applet (JUpload)
« Reply #283 on: November 16, 2007, 11:58:42 pm »

Hey,
I have problems with JUpload and I don't understand why.

My debug log is too big to post it here so I put it on the end of this thread!

I hope you can help me. Thanks!
Logged

Nibbler

  • Guest
Re: Upload applet (JUpload)
« Reply #284 on: November 17, 2007, 12:13:42 am »

Probably caused by the bridge; vb's session cookie is not being sent to Coppermine by jUpload so it can't recognise you. Try allowing anonymous uploading on the groups page.
Logged

searchforme

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upload applet (JUpload)
« Reply #285 on: November 17, 2007, 05:56:29 am »

latest version dont work for me for uploading.. : Personal Gallery (0) album(s)) ; Select Album ;

no ablums to select. even tho i got 10+ albums to select.

why does it say i have 0 albums etc. version 2.6.1 worked
Logged

etienne_sf

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Upload applet (JUpload)
« Reply #286 on: November 17, 2007, 09:43:52 am »

Hey,
I have problems with JUpload and I don't understand why.

My debug log is too big to post it here so I put it on the end of this thread!

I hope you can help me. Thanks!

I had the same problem, on my demo site. The session is lost by the applet, and Coppermine answers to upload by a page explaining the you're not connected.

Which version of JUpload do you use ?

Two possible reasons:
- If you're using FTP to install the applet, it may be badly installed. Trying binary FTP transfert.
- If not, Do you use a proxy ? Perhaps the applet goes through a proxy, and the navigator not ?

I think you've posted me the URL and a login/password. But I let my laptop at work. Can you post me them by PM ?

Etienne
Etienne
Logged

etienne_sf

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Upload applet (JUpload)
« Reply #287 on: November 17, 2007, 11:34:48 am »

latest version dont work for me for uploading.. : Personal Gallery (0) album(s)) ; Select Album ;

no ablums to select. even tho i got 10+ albums to select.

why does it say i have 0 albums etc. version 2.6.1 worked

Hum,


- Can you upload to these personal albums from standard upload ?
- Are you connected as an admin, or as a registered user ?
- If as an admin: on the group page, are admin allowed to have personal albums ?

Etienne
Logged

phill104

  • Administrator
  • Coppermine addict
  • *****
  • Country: gb
  • Offline Offline
  • Gender: Male
  • Posts: 4858
    • Windsurf.me
Re: Upload applet (JUpload)
« Reply #288 on: November 17, 2007, 05:21:19 pm »

There is a slight problem I noticed with the latest version. If albums have been placed in no category they will not appear as valid locations for upload. Move them into a named category and you can then upload to them.
Logged
It is a mistake to think you can solve any major problems just with potatoes.

Cirno

  • Coppermine newbie
  • Offline Offline
  • Posts: 14
Re: Upload applet (JUpload)
« Reply #289 on: November 18, 2007, 12:00:23 am »

First of all, I have to say thank you for a very good plugin that makes Coppermine a much better product in total.

I really love the jupload plugin, but I am missing one feature that would make it all perfect.

After uploading the files, it takes you to the 'Edit files' section, where you can fill in the Describtion keywords and custom fields, I would love to see a feature that would allow me to type in this information one place, to then have it added to all the pictures i just uploaded. The reason for this is because some of my custom fields are photographer and location, something that in my case is the same for each bulk i upload.

Is there any chance to get such a feature in a future version?

Best regards
Cirno
Logged

World-Charmed

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Upload applet (JUpload)
« Reply #290 on: November 18, 2007, 12:16:16 am »

I had the same problem, on my demo site. The session is lost by the applet, and Coppermine answers to upload by a page explaining the you're not connected.

Which version of JUpload do you use ?

Two possible reasons:
- If you're using FTP to install the applet, it may be badly installed. Trying binary FTP transfert.
- If not, Do you use a proxy ? Perhaps the applet goes through a proxy, and the navigator not ?

I think you've posted me the URL and a login/password. But I let my laptop at work. Can you post me them by PM ?

Etienne
Etienne

Hey,
I uploaded it with a binary FTP transfert but it is the same error too. I don't use a proxy. The applet through a proxy? How should it work? I don't edit the files so when it is not standart it should not be the problem?!

I send you the login/password by PN!

Thanks


World-Charmed
Logged

searchforme

  • Coppermine newbie
  • Offline Offline
  • Posts: 12
Re: Upload applet (JUpload)
« Reply #291 on: November 18, 2007, 04:15:58 am »

Hum,


- Can you upload to these personal albums from standard upload ?
- Are you connected as an admin, or as a registered user ?
- If as an admin: on the group page, are admin allowed to have personal albums ?

Etienne


- Can you upload to these personal albums from standard upload ? Yes.
- Are you connected as an admin, or as a registered user ? Yes.
- If as an admin: on the group page, are admin allowed to have personal albums ? Yes.

as i see what phil104 has just wrote. maybe that has something to do with it?, but i wouldnt want to do that tho.. & right now jupload v2.6.1 , works soo good for me.


There is a slight problem I noticed with the latest version. If albums have been placed in no category they will not appear as valid locations for upload. Move them into a named category and you can then upload to them.
Logged

sanghino

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Upload applet (JUpload)
« Reply #292 on: November 20, 2007, 08:00:45 pm »

hi i have a problem with jupload but i don't know the solution can anyone help me, here there is the log of jupload
Code: [Select]
19:24:01.482 [INFO] Debug level set to 0
19:24:01.486 [INFO] Current debug output file: C:\Users\Riccardo\AppData\Local\Temp\jupload_16145_log.txt
19:24:01.489 [WARN] Invalid int value: true, using default value: 0
19:24:01.789 [WARN] Invalid int value: , using default value: 0
19:24:01.791 [INFO] JUpload plugin for coppermine version 2.6.4
19:24:42.051 [INFO] Debug level set to 100
19:24:42.051 [INFO] Current debug output file: C:\Users\Riccardo\AppData\Local\Temp\jupload_16145_log.txt
19:24:42.055 [DEBUG] =======================================================================
19:24:42.057 [DEBUG] ======= Parameters managed by DefaultUploadPolicy
19:24:42.058 [INFO] JUpload applet, version 3.2.0 [SVN-Rev: 389] (compiled: 11/10/2007 11:57 AM), available at http://jupload.sourceforge.net/
19:24:42.060 [DEBUG] Java version: 1.6.0
19:24:42.060 [DEBUG] Cookie: coppermine_data=YTo0OntzOjI6IklEIjtzOjMyOiI5ZDM2NzQ3OGY2YWQ5NDUxZmJmNjA0ZDU2NjcyMDJlOSI7czoyOiJhbSI7aToxO3M6NDoibGFuZyI7czo3OiJpdGFsaWFuIjtzOjM6ImxpdiI7YTowOnt9fQ%3D%3D; 0844567864b6cb2a1ae024ca0edccea8=7fb27f0f5d66ce78c2929ef0af2d3cff
19:24:42.063 [DEBUG] userAgent: Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
19:24:42.063 [DEBUG] List of all applet parameters:
19:24:42.064 [DEBUG]   language: it
19:24:42.064 [DEBUG]   country:
19:24:42.065 [DEBUG] afterUploadURL: null
19:24:42.065 [DEBUG] allowHttpPersistent: false
19:24:42.066 [DEBUG] allowedFileExtensions: /jpg/jpeg/jpe/gif/png/bmp/jpc/jp2/jpx/jb2/swc/iff/asf/asx/mpg/mpeg/wmv/swf/avi/mov/mp3/midi/mid/wma/wav/ogg/psd/doc/txt/rtf/pdf/xls/pps/ppt/zip/gz/mdb/
19:24:42.066 [DEBUG] debugLevel: 100 (debugfile: C:\Users\Riccardo\AppData\Local\Temp\jupload_16145_log.txt)
19:24:42.067 [DEBUG] fileChooserIconFromFileContent: 0
19:24:42.067 [DEBUG] fileChooserIconSize: 50
19:24:42.068 [DEBUG] filenameEncoding: null
19:24:42.069 [DEBUG] lang: it
19:24:42.069 [DEBUG] maxChunkSize: 1024000
19:24:42.070 [INFO] maxFileSize: 8192000
19:24:42.070 [DEBUG] nbFilesPerRequest: 1
19:24:42.071 [DEBUG] postURL: http://sanghino.freeweb7.com/coppermine/index.php?file=jupload/jupload&action=add_picture
19:24:42.072 [DEBUG] serverProtocol: HTTP/1.1
19:24:42.072 [DEBUG] showLogWindow: false
19:24:42.073 [DEBUG] showStatusbar: true
19:24:42.073 [DEBUG] specificHeaders: null
19:24:42.073 [DEBUG] stringUploadSuccess: ^SUCCESS$
19:24:42.074 [DEBUG] stringUploadError: ^ERROR: (.*)$
19:24:42.075 [DEBUG] urlToSendErrorTo: http://sanghino.freeweb7.com/coppermine/index.php?file=jupload/jupload&action=log_error
19:24:42.075 [DEBUG]
19:24:42.076 [DEBUG] ======= Parameters managed by PictureUploadPolicy
19:24:42.076 [DEBUG] fileChooserImagePreview: true
19:24:42.077 [DEBUG] highQualityPreview : false
19:24:42.077 [DEBUG] pictureCompressionQuality : 0.8
19:24:42.078 [DEBUG] pictureTransmitMetadata : true
19:24:42.078 [DEBUG] maxPicWidth : 2048, maxPicHeight : 2048
19:24:42.078 [DEBUG] realMaxPicWidth : 2048, realMaxPicHeight : 2048
19:24:42.079 [DEBUG] storeBufferedImage : false
19:24:42.079 [DEBUG] targetPictureFormat : null
19:24:42.080 [DEBUG]
19:24:42.080 [DEBUG] ======= Parameters managed by CoppermineUploadPolicy
19:24:42.083 [DEBUG] albumId : 0
19:24:42.084 [DEBUG]
19:24:46.463 [DEBUG] Action : Sfoglia...
19:24:46.505 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Documents\1677_LIBRO CALCIO A 5 E A 7.doc
19:24:46.506 [DEBUG] JUploadFileView.execute: creating the executorService
19:24:46.517 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Documents\Lista DVD.xls
19:24:46.518 [DEBUG] In IconWorker.loadIcon(1677_LIBRO CALCIO A 5 E A 7.doc)
19:24:46.519 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Documents\psw ftp.txt
19:24:46.599 [DEBUG] In IconWorker.loadIcon(Lista DVD.xls)
19:24:46.654 [DEBUG] In IconWorker.loadIcon(psw ftp.txt)
19:24:51.610 [DEBUG] [JUploadFileView] Directory changed
19:24:51.610 [DEBUG] Shutting down all IconWorker running jobs
19:24:51.611 [DEBUG] All IconWorker running jobs are now marked as stopped.
19:24:54.589 [DEBUG] [JUploadFileView] Directory changed
19:24:54.590 [DEBUG] Shutting down all IconWorker running jobs
19:24:54.590 [DEBUG] All IconWorker running jobs are now marked as stopped.
19:24:54.664 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\1170915454_b1478265ff.jpg
19:24:54.664 [DEBUG] In IconWorker.loadIcon(1170915454_b1478265ff.jpg)
19:24:54.665 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\Cattura.JPG
19:24:54.811 [DEBUG] In IconWorker.loadIcon(Cattura.JPG)
19:25:03.118 [DEBUG] [JUploadFileView] Directory changed
19:25:03.119 [DEBUG] Shutting down all IconWorker running jobs
19:25:03.120 [DEBUG] All IconWorker running jobs are now marked as stopped.
19:25:05.371 [DEBUG] [JUploadFileView] Directory changed
19:25:05.371 [DEBUG] Shutting down all IconWorker running jobs
19:25:05.372 [DEBUG] All IconWorker running jobs are now marked as stopped.
19:25:06.436 [DEBUG] [JUploadFileView] Directory changed
19:25:06.439 [DEBUG] Shutting down all IconWorker running jobs
19:25:06.439 [DEBUG] All IconWorker running jobs are now marked as stopped.
19:25:06.455 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2295.JPG
19:25:06.455 [DEBUG] In IconWorker.loadIcon(IMG_2295.JPG)
19:25:06.456 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2296.JPG
19:25:06.456 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2297.JPG
19:25:06.457 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2298.JPG
19:25:06.457 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2299.JPG
19:25:06.458 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2300.JPG
19:25:06.458 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2301.JPG
19:25:06.459 [DEBUG] [JUploadFileView.execute] Adding C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2303.JPG
.....
19:25:07.719 [DEBUG] In IconWorker.loadIcon(IMG_2296.JPG)
19:25:08.163 [DEBUG] LoadImageThread.start (start)
19:25:08.371 [DEBUG] Creation of the DefaultFileData for C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2295.JPG(root: C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON)
19:25:08.388 [DEBUG] Mime types list loaded Ok (/conf/mimetypes.properties)
19:25:08.524 [DEBUG] isPicture=true (IMG_2295.JPG), extension=JPG
19:25:08.548 [DEBUG] Shutting down all IconWorker running jobs
19:25:08.548 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\MVI_2377.AVI
19:25:08.549 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\MVI_2376.AVI
19:25:08.549 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\MVI_2384.AVI...
19:25:08.718 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2315.JPG
19:25:08.718 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2297.JPG
19:25:08.718 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2299.JPG
19:25:08.719 [DEBUG]    Shutting down C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\IMG_2298.JPG
19:25:08.719 [DEBUG] All IconWorker running jobs are now marked as stopped.
19:25:09.017 [DEBUG] LoadImageThread.start (end)
19:25:12.632 [DEBUG] Action : Carica
19:25:15.990 [DEBUG] Action : Rimuovi selezionati
19:25:29.225 [DEBUG] Post URL (modified in CoppermineUploadPolicy) = http://sanghino.freeweb7.com/coppermine/index.php?file=jupload/jupload&action=add_picture&album=2
19:25:40.390 [DEBUG] Action : Carica
19:25:40.401 [DEBUG] Upload done by using the wjhk.jupload2.upload.FileUploadThreadHTTP class
19:25:40.402 [DEBUG] Timer started
19:25:40.429 [DEBUG] PicturePanel.paint(): offscreenImage is null
19:25:41.255 [DEBUG] freeMemory (after hasToTransformPicture) : 57741480
19:25:41.256 [DEBUG] IMG_2295.JPG : hasToTransformPicture = true (rotatedWidth > maxWidth)
19:25:41.261 [WARN] PictureFileData.getTransformedPictureFile(): temp file already exists C:\Users\Riccardo\AppData\Local\Temp\jupload_16146.tmp)
19:25:41.262 [DEBUG] Using temp file C:\Users\Riccardo\AppData\Local\Temp\jupload_16146.tmp for IMG_2295.JPG
19:25:41.263 [DEBUG] freeMemory (after start of getBufferedImage) : 57062824
19:25:41.833 [DEBUG] Resizing picture(using standard quality picture)
19:25:41.840 [DEBUG] bufferedImage.getColorModel(): ColorModel: #pixelBits = 24 numComponents = 3 color space = java.awt.color.ICC_ColorSpace@5bcd91 transparency = 1 has alpha = false isAlphaPre = false
19:25:41.841 [DEBUG] localBufferedImage.getColorModel(): ColorModel: #pixelBits = 24 numComponents = 3 color space = java.awt.color.ICC_ColorSpace@5bcd91 transparency = 1 has alpha = false isAlphaPre = false
19:25:41.921 [DEBUG] freeMemory (after end of getBufferedImage) : 42526936
19:25:41.922 [DEBUG] bufferedImage MinX (BufferedImage@1b1ff47: type = 5 ColorModel: #pixelBits = 24 numComponents = 3 color space = java.awt.color.ICC_ColorSpace@5bcd91 transparency = 1 has alpha = false isAlphaPre = false ByteInterleavedRaster: width = 1536 height = 2048 #numDataElements 3 dataOff[0] = 2): 0
19:25:41.924 [DEBUG] bufferedImage MinY (BufferedImage@1b1ff47: type = 5 ColorModel: #pixelBits = 24 numComponents = 3 color space = java.awt.color.ICC_ColorSpace@5bcd91 transparency = 1 has alpha = false isAlphaPre = false ByteInterleavedRaster: width = 1536 height = 2048 #numDataElements 3 dataOff[0] = 2): 0
19:25:41.924 [DEBUG] bufferedImage Width (BufferedImage@1b1ff47: type = 5 ColorModel: #pixelBits = 24 numComponents = 3 color space = java.awt.color.ICC_ColorSpace@5bcd91 transparency = 1 has alpha = false isAlphaPre = false ByteInterleavedRaster: width = 1536 height = 2048 #numDataElements 3 dataOff[0] = 2): 1536
19:25:41.925 [DEBUG] bufferedImage Height (BufferedImage@1b1ff47: type = 5 ColorModel: #pixelBits = 24 numComponents = 3 color space = java.awt.color.ICC_ColorSpace@5bcd91 transparency = 1 has alpha = false isAlphaPre = false ByteInterleavedRaster: width = 1536 height = 2048 #numDataElements 3 dataOff[0] = 2): 2048
19:25:41.932 [DEBUG] ImageWriter1 (used), CompressionQuality=0.8
19:25:41.932 [INFO] Start of metadata managing, for IMG_2295.JPG
19:25:42.073 [DEBUG] Found one image reader that can read metadata!
19:25:42.427 [DEBUG] freeMemory (after getTransformedPictureFile) : 33771688
19:25:42.427 [DEBUG] transformedPictureFile : jupload_16146.tmp
19:25:42.429 [DEBUG] file 0: content=805189 bytes, getAdditionnalBytesForUpload=829 bytes
19:25:42.429 [DEBUG] chunkHttpParam: jupart=0&jufinal=1
19:25:42.431 [DEBUG] Cookie: coppermine_data=YTo0OntzOjI6IklEIjtzOjMyOiI5ZDM2NzQ3OGY2YWQ5NDUxZmJmNjA0ZDU2NjcyMDJlOSI7czoyOiJhbSI7aToxO3M6NDoibGFuZyI7czo3OiJpdGFsaWFuIjtzOjM6ImxpdiI7YTowOnt9fQ%3D%3D; 0844567864b6cb2a1ae024ca0edccea8=7fb27f0f5d66ce78c2929ef0af2d3cff
19:25:42.432 [DEBUG] User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9
19:25:42.466 [DEBUG] Using non SSL socket, direct connection
19:25:42.470 [DEBUG] === main header (len=1031):
19:25:42.470 [DEBUG] POST /coppermine/index.php?file=jupload/jupload&action=add_picture&album=2 HTTP/1.1\r\n
19:25:42.470 [DEBUG] Host: sanghino.freeweb7.com\r\n
19:25:42.470 [DEBUG] Accept: */*\r\n
19:25:42.470 [DEBUG] Accept-Encoding: identity\r\n
19:25:42.470 [DEBUG] Connection: close\r\n
19:25:42.470 [DEBUG] Content-Type: multipart/form-data; boundary=---------------------------haaf2i953lh\r\n
19:25:42.470 [DEBUG] Content-Length: 806420\r\n
19:25:42.470 [DEBUG] Cookie: coppermine_data=YTo0OntzOjI6IklEIjtzOjMyOiI5ZDM2NzQ3OGY2YWQ5NDUxZmJmNjA0ZDU2NjcyMDJlOSI7czoyOiJhbSI7aToxO3M6NDoibGFuZyI7czo3OiJpdGFsaWFuIjtzOjM6ImxpdiI7YTowOnt9fQ%3D%3D; 0844567864b6cb2a1ae024ca0edccea8=7fb27f0f5d66ce78c2929ef0af2d3cff\r\n
19:25:42.470 [DEBUG] User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; it; rv:1.8.1.9) Gecko/20071025 Firefox/2.0.0.9\r\n
19:25:42.470 [DEBUG] \r\n
19:25:42.470 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.470 [DEBUG] Content-Disposition: form-data; name="file"\r\n
19:25:42.470 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.470 [DEBUG] \r\n
19:25:42.470 [DEBUG] jupload/jupload\r\n
19:25:42.470 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.470 [DEBUG] Content-Disposition: form-data; name="album"\r\n
19:25:42.470 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.470 [DEBUG] \r\n
19:25:42.470 [DEBUG] 2\r\n
19:25:42.470 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.470 [DEBUG] Content-Disposition: form-data; name="action"\r\n
19:25:42.470 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.470 [DEBUG] \r\n
19:25:42.470 [DEBUG] add_picture\r\n
19:25:42.471 [DEBUG] === main header end
19:25:42.472 [DEBUG] --- fileheader start (len=623):
19:25:42.473 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.473 [DEBUG] Content-Disposition: form-data; name="mimetype[]"\r\n
19:25:42.473 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.473 [DEBUG] \r\n
19:25:42.473 [DEBUG] image/jpeg\r\n
19:25:42.473 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.473 [DEBUG] Content-Disposition: form-data; name="pathinfo[]"\r\n
19:25:42.473 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.473 [DEBUG] \r\n
19:25:42.473 [DEBUG] C:\Users\Riccardo\Pictures\2007-11-14 Firenze Novembre 2007\DCIM\100CANON\r\n
19:25:42.473 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.473 [DEBUG] Content-Disposition: form-data; name="relpathinfo[]"\r\n
19:25:42.473 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.473 [DEBUG] \r\n
19:25:42.473 [DEBUG] \r\n
19:25:42.473 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.473 [DEBUG] Content-Disposition: form-data; name="userpicture"; filename="IMG_2295.JPG"\r\n
19:25:42.473 [DEBUG] Content-Type: image/jpeg\r\n
19:25:42.473 [DEBUG] \r\n
19:25:42.473 [DEBUG] --- fileheader end
19:25:42.477 [DEBUG] in UploadFileData.uploadFile (amount:805189, getUploadLength(): 805189)
19:25:42.746 [DEBUG] --- filetail start (len=206):
19:25:42.746 [DEBUG] \r\n
19:25:42.746 [DEBUG] -----------------------------haaf2i953lh\r\n
19:25:42.746 [DEBUG] Content-Disposition: form-data; name="md5sum[]"\r\n
19:25:42.746 [DEBUG] Content-Transfer-Encoding: 8bit\r\n
19:25:42.746 [DEBUG] \r\n
19:25:42.746 [DEBUG] 8f1c0d7a6877156ca4a8d0f741621667\r\n
19:25:42.746 [DEBUG] -----------------------------haaf2i953lh--\r\n
19:25:42.747 [DEBUG] --- filetail end
19:26:31.802 [DEBUG] -------- Response Headers Start --------
19:26:31.803 [DEBUG] HTTP/1.1 200 OK
19:26:31.804 [DEBUG] Date: Tue, 20 Nov 2007 18:25:54 GMT
19:26:31.804 [DEBUG] Server: Apache
19:26:31.805 [DEBUG] X-Powered-By: PHP/5.1.6
19:26:31.806 [DEBUG] Connection: close
19:26:31.806 [DEBUG] Transfer-Encoding: chunked
19:26:31.808 [DEBUG] Content-Type: text/html
19:26:31.808 [DEBUG]
19:26:31.809 [DEBUG] --------- Response Headers End ---------
19:26:31.810 [DEBUG] Chunk: de dec: 222
19:26:31.812 [DEBUG] Chunk: 0 dec: 0
19:26:31.813 [DEBUG] HTTP status: 200 OK
19:26:31.814 [DEBUG] -------- Response Body Start --------
19:26:31.815 [DEBUG] <br />
19:26:31.815 [DEBUG] <b>Fatal error</b>:  Allowed memory size of 16777216 bytes exhausted (tried to allocate 276380 bytes) in <b>/www/freeweb7.com/s/a/n/sanghino/htdocs/coppermine/include/functions.inc.php</b> on line <b>2040</b><br />
19:26:31.815 [DEBUG] --------- Response Body End ---------
19:26:34.535 [ERROR] wjhk.jupload2.exception.JUploadExceptionUploadFailed: wjhk.jupload2.policies.CoppermineUploadPolicy.checkUploadSuccess(): The string "^SUCCESS$" was not found in the response body (wjhk.jupload2.policies.CoppermineUploadPolicy.checkUploadSuccess(): The string "^SUCCESS$" was not found in the response body)
19:26:34.536 wjhk.jupload2.exception.JUploadExceptionUploadFailed: wjhk.jupload2.policies.CoppermineUploadPolicy.checkUploadSuccess(): The string "^SUCCESS$" was not found in the response body
19:26:34.536 at wjhk.jupload2.policies.DefaultUploadPolicy.checkUploadSuccess(DefaultUploadPolicy.java:600)
19:26:34.536 at wjhk.jupload2.upload.DefaultFileUploadThread.doUpload(DefaultFileUploadThread.java:731)
19:26:34.536 at wjhk.jupload2.upload.DefaultFileUploadThread.run(DefaultFileUploadThread.java:486)
19:26:34.536 [DEBUG] FileUploadThread: within run().finally
19:26:34.537 [WARN] Temporary file not deleted
19:26:41.458 [DEBUG] JUploadPanel: after !fileUploadThread.isAlive()
19:26:41.461 [WARN] CoppermineUploadPolicy.afterUpload: No file were uploaded! (0)
, i've also tried to upload manually that image but nothing happens (never a error message and the image isn't uploaded).
I try to set max image size in pixel (in the configuration of coppermine (Max width or height for uploaded pictures (pixels))) to 2048 pixel, 1600 pixel and 1024 pixel and the output of jupload is always the same of above.
i've also see my php settings in phpinfo tools of coppermine admin tool and the upload_max_filesize limit is 2 mb and also the post_max_size is 2mb and the memory limit is 16mb; is the problem related to this settings? thanks in advance!!!
Logged

erostew

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
Re: Upload applet (JUpload)
« Reply #293 on: November 21, 2007, 12:05:06 am »

Quote
Allowed memory size of 16777216 bytes exhausted (tried to allocate 276380 bytes) in /www/freeweb7.com/s/a/n/sanghino/htdocs/coppermine/include/functions.inc.php on line 2040

This isn't a JUpload problem. You posted this in the wrong place.

You don't have enough memory available on the server for the thumb/intermediate pic to be generated after upload.

Your server simply needs more memory allotted to php. Since you are using a free webhost you probably won't be able to use coppermine at all except through ftp, because it's not likely a freehost will allow more memory for you to use. About the only thing you will be able to do is upload thumbs, fullsize and intermediate pics by ftp and use batch add to put them in albums.
Logged

dfmartins

  • Coppermine newbie
  • Offline Offline
  • Posts: 1
Re: Upload applet (JUpload)
« Reply #294 on: November 21, 2007, 04:54:20 am »

ANother member mentioned that did 216 uploads at opnce... just so I know what this plugin can do... how large are the files you used on this upload!? Do you use any setting to make files smaller for the upload or not? I just upgraded the jupload to latest version 2.6.4 and keeds happening the same.

When I upload a large amount of pics (more than 100 pics) around 600kb each, jupload works fine. But if I try 30 or 40 files at 2.5mb each... I start having trouble.

Need to get this thing working 100% for a PhotoLab... But I feel insecure with these kinda problem since I cannot find the source for the issue.

Also, what is the seeting to have the JUPLOAD resize the files before uploading them!? Because my files are resized but they take long time to be uploaded as they were at normal size. It seems that it gets resized after the upload! What are th esetting to make it work right, cuz I tried following the manual... but no success.
« Last Edit: November 21, 2007, 05:04:42 am by dfmartins »
Logged

sanghino

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: Upload applet (JUpload)
« Reply #295 on: November 21, 2007, 09:25:21 am »

thanks for the answer  :)
Logged

etienne_sf

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Upload applet (JUpload)
« Reply #296 on: November 21, 2007, 01:23:52 pm »

After uploading the files, it takes you to the 'Edit files' section, where you can fill in the Describtion keywords and custom fields, I would love to see a feature that would allow me to type in this information one place, to then have it added to all the pictures i just uploaded. The reason for this is because some of my custom fields are photographer and location, something that in my case is the same for each bulk i upload.

Added to my todo list
Logged

etienne_sf

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Upload applet (JUpload)
« Reply #297 on: November 21, 2007, 01:34:27 pm »

ANother member mentioned that did 216 uploads at opnce... just so I know what this plugin can do... how large are the files you used on this upload!? Do you use any setting to make files smaller for the upload or not? I just upgraded the jupload to latest version 2.6.4 and keeds happening the same.

When I upload a large amount of pics (more than 100 pics) around 600kb each, jupload works fine. But if I try 30 or 40 files at 2.5mb each... I start having trouble.

Need to get this thing working 100% for a PhotoLab... But I feel insecure with these kinda problem since I cannot find the source for the issue.

Also, what is the seeting to have the JUPLOAD resize the files before uploading them!? Because my files are resized but they take long time to be uploaded as they were at normal size. It seems that it gets resized after the upload! What are th esetting to make it work right, cuz I tried following the manual... but no success.

What is your problem exactly ?  Your mail is not clear. Here is my understanding, and my answers to these points:

1) Uploading a lot of files works Ok, if they are not too big.

2) Upload a lot of files is KO, if they are too big.
What means KO ?  What happens ?

3) You want to know what's happening in the applet ? Please first read the given doc, including explanation on the plugin configuration page. You should find your answer there.
FYI: resizing can occur at two places:
- In the applet, before upload (see the plugin configuration parameters)
- In the web server, like in standard upload, according to the gallery parameters.

Etienne
Logged

etienne_sf

  • Contributor
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 908
    • Wiki
Re: Upload applet (JUpload)
« Reply #298 on: November 21, 2007, 02:31:13 pm »

Hey,
I have problems with JUpload and I don't understand why.

My debug log is too big to post it here so I put it on the end of this thread!

I hope you can help me. Thanks!


Works the same for me    :-\

After a profound memory analysis ...  : I remember I did something else on my demo site : I removed all existing files in the plugins/jupload directory.

  Can you try this :
- Remove all files and directory behing plugins/jupload
- Re-install the JUpload plugin.

Etienne

 
Logged

erostew

  • Coppermine regular visitor
  • **
  • Offline Offline
  • Posts: 63
Re: Upload applet (JUpload)
« Reply #299 on: November 21, 2007, 06:21:57 pm »

ANother member mentioned that did 216 uploads at opnce... just so I know what this plugin can do... how large are the files you used on this upload!? Do you use any setting to make files smaller for the upload or not? I just upgraded the jupload to latest version 2.6.4 and keeds happening the same.

When I upload a large amount of pics (more than 100 pics) around 600kb each, jupload works fine. But if I try 30 or 40 files at 2.5mb each... I start having trouble.

Need to get this thing working 100% for a PhotoLab... But I feel insecure with these kinda problem since I cannot find the source for the issue.

Also, what is the seeting to have the JUPLOAD resize the files before uploading them!? Because my files are resized but they take long time to be uploaded as they were at normal size. It seems that it gets resized after the upload! What are th esetting to make it work right, cuz I tried following the manual... but no success.

As Etienne mentioned, you need to read the manual for correct settings. It's quite clear what settings to change.

I have used JUpload for uploading over 400 photos at a time, of app. 3.5mb each. They were resized before upload and I had no problems at all. If you are having the pics resized after upload it will be much slower, simply because of the size of the files. It takes longer to upload and the photo gets resized and the thumb and intermediate pics are created before it starts uploading the next photo. And resizing the fullsize pic can also strain the resources on the server quite a lot. Which slows things down even more.
Logged
Pages: 1 ... 11 12 13 14 [15] 16 17 18 19 ... 33   Go Up
 

Page created in 0.028 seconds with 22 queries.