Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Huge Subscribtion Bug?  (Read 3092 times)

0 Members and 1 Guest are viewing this topic.

bitcloud

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 117
Huge Subscribtion Bug?
« on: April 21, 2007, 08:20:34 pm »

Hi Stramm (or anyone else   ;))

I noticed on my installation, (and subsequently tested the same on the clean http://stramm.st.funpic.org test page) an error with Stramm's Subscribtion Mod.

If you have a look at subscribtion_manage.php you'll only see images that you've uploaded yourself. The "Automatically subscribe to pictures you posted" Works perfectly, but the "Automatically subscribe to pictures you commented" just doesn't seem to work. Images you comment on don't appear on the subscribtion_manage page, nor do you receive e-mails for those images. (unless you were the uploader of those images) I thought maybe i'd screwed up my installation somewhere, but this same bug seems to be present on Stramms own installation.

Does anyone how/why/where this is going wrong?
cheers
Lachlan
« Last Edit: April 22, 2007, 11:03:17 am by Stramm »
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Huge Subscribtion Bug?
« Reply #1 on: April 22, 2007, 09:39:50 am »

known and already fixed
http://forum.coppermine-gallery.net/index.php?topic=38314.msg181561#msg181561

A download is on my demo site

bitcloud

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 117
Re: Huge Subscribtion Bug?
« Reply #2 on: April 22, 2007, 10:17:41 am »

Awesome... thats pretty much fixed that one now.. it works perfectly... thanks so much...

To anyone else seeing this bug, the thread stramm points to explains how to resolve this bug:

in db_input.php find
Code: [Select]
if ($auto_subscribe_post['auto_subscribe_comment'])and replace with
Code: [Select]
if ($auto_subscribe_comment['auto_subscribe_comment'])
Logged

bitcloud

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 117
Re: Huge Subscribtion Bug?
« Reply #3 on: April 22, 2007, 10:19:31 am »

incidentally, "subscribtion" should be spelled "subscription"

might be worth looking at that for the next modpack release :)
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.