Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: Is PHP v4.4.6-1 make some issues on ModPack ?  (Read 5824 times)

0 Members and 1 Guest are viewing this topic.

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Is PHP v4.4.6-1 make some issues on ModPack ?
« on: April 02, 2007, 03:15:08 pm »

Hello Stramm,

Just after a PHP upgrade (v4.4.6-1) on my host, a CPG ModPack gallery i'd created since 110 days, send us only a blank page without error message !
It's not a CONFIG.INC.PHP error, because CpmFetch run perfectly with the same ID/Login & Pass...

Nothing work. PHPINFO.PHP do not work at all. ADMIN.PHP idem... I can access only on UPGRADE.PHP script  ???

I'm not the owner of www.haut-les-mains.fr . I only help this paragliding school to be on the web  ;)

URL Gallery : www.haut-les-mains.fr/media/

Many Thank's if some ideas can be posted here.

PYAP

« Last Edit: April 02, 2007, 03:24:04 pm by PYAP »
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Is PHP v4.4.6-1 make some issues on ModPack ?
« Reply #1 on: April 02, 2007, 07:02:13 pm »

I have it running with php 4.4.1 and 4.4.7 ... works perfect. So I don't think the php version is the reason for the blank page.

Make sure you have set errors to display in php.ini and then have a look into the error logs

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Is PHP v4.4.6-1 make some issues on ModPack ?
« Reply #2 on: April 03, 2007, 10:56:48 am »

Stramm,

Quote
have a look into the error logs
Unfortunately, it's impossible to access in PHP.ini and error logs (host by company) ???

I try a full refresh of all Coppermine files, and ModPack too, with no success )-:
It's so strange but no funny at all !
I'm understanding nothing  ???

I do'nt know why CPG's phphinfo.php do not work ?
I'd upload a new file with this command to read mly new config server <?php phpinfo(); ?>

Quote
I have it running with php 4.4.1 and 4.4.7...works perfect.
Then, it's not related to your ModPack  ;)


PYAP
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: Is PHP v4.4.6-1 make some issues on ModPack ?
« Reply #3 on: April 03, 2007, 02:21:19 pm »

easiest thing to try is to replace all modpack files with the orig ones. If you still have issues, then it's definitely not modpack related.

However without being able to check the error logs it's plain guessing where the problem is. So you should contact your (the school's host) and ask them to make the logs accessible

If I'm not wrong, then phphinfo.php includes init.inc.php -> so there may be the culprit. A linebreak or similar just after the ?> ... not overwritten but appended etc. But as said, that's just guessing

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Is PHP v4.4.6-1 make some issues on ModPack ?
« Reply #4 on: April 03, 2007, 03:17:48 pm »

Quote
However without being able to check the error logs it's plain guessing where the problem is.
Yes of course...

Quote
So you should contact your (the school's host) and ask them to make the logs accessible
Done ! I'm waiting for some others infos from the Haut-les-Mains School web's host...

PYAP
Logged

Pascal YAP

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: fr
  • Offline Offline
  • Gender: Male
  • Posts: 13833
  • Hello World :-)
    • CPG 1.5.x ExperiMental website
Re: Is PHP v4.4.6-1 make some issues on ModPack ?
« Reply #5 on: April 05, 2007, 09:44:21 am »

Hello Stramm,

Just to say : Impossible to obtain something from the host company  ???

After a new upload (CPG 1.4.10 + ModPack)
www.haut-les-mains.fr/media/index.php can not load !
But if i add something like that "cat=0", it's OK  ??? www.haut-les-mains.fr/media/index.php?cat=0

Other things, Number of view, Views xxxtimes, and N of comments are not visibles on the front page ! Those infos are simply disapeared !

Understood nothing before ! Understand nothing today !

And finally i do'nt know if it's the right place to post my issue  ;) sorry in this case  ;D

PYAP

Logged

Sami

  • VIP
  • Coppermine addict
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 3686
  • BMossavari
    • My Project
Re: Is PHP v4.4.6-1 make some issues on ModPack ?
« Reply #6 on: April 05, 2007, 10:19:42 am »

It seems that you have setup wrong redirection ,
- check your server redirection setting
- check your gallery homepage on config
Logged
‍I don't answer to PM with support question
Please post your issue to related board
Pages: [1]   Go Up
 

Page created in 0.022 seconds with 20 queries.