Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: User Gallery Visibility Issue  (Read 4383 times)

0 Members and 1 Guest are viewing this topic.

Coldfinger

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
    • http://www.coldfingersolutions.com
User Gallery Visibility Issue
« on: March 04, 2004, 09:45:50 pm »

I've searched the board and FAQ for help with my question already. . .just need a little more help to finish the job.

I've learned through the doc faq that the "user galleries" category is a special category that can't be removed (and only appears if a user has uploaded an album). Well, when I was testing out the board, I created some sample users and did some sample uploads with those users. Consequently, the "User Gallery" became visible.

Now that I'm familiar with how the board operates, I deleted those users. . .but the "User Gallery" still appears on the front page (which I DON'T want). I've made sure to disable all permissions/ability for users to upload, but the front screen still shows it. It even says that there's one album in that category somewhere (when you click on the title "User Gallery", the next screen says the album/picture doesn ot exist). I've gone through and checked to see if anything still existed in that album and. . .nope, it's empty.

So my question is. . .is there a way for me to restore the database or something so it will pick up the fact that there are no albums in here (and thus, the "User Gallery" category can disappear)? Am I going to have to reinstall the software (please say no)? Is there something else I should try?

Thanks team.
Logged
imagine. conceive. embrace.
www.coldfingersolutions.com

Casper

  • VIP
  • Coppermine addict
  • ***
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 5231
User Gallery Visibility Issue
« Reply #1 on: March 04, 2004, 11:26:24 pm »

Hi,

This is a known problem, which usually happens when a user has created an album, but not put any pics in it.  To delete this invisible album, and remove the user galleries category, do the following;

Logon as admin.  Click on any albums 'properties' button.
Now click on the drop down album list(in the top header row), and search for the album you cannot usually see (it will have a members name in brackets at the start).

Now you will see the properties box for this album, which will have for the 'album thumbnail' 'album is empty'.

Now click on the 'album list' in the menu, and you should now have the 'delete/properties/edit pics' album page.

Click on delete, and that should be it.


This hopefully will be sorted for the next version.
Logged
It has been a long time now since I did my little bit here, and have done no coding or any other such stuff since. I'm back to being a noob here

Coldfinger

  • Coppermine newbie
  • Offline Offline
  • Posts: 6
    • http://www.coldfingersolutions.com
User Gallery Visibility Issue
« Reply #2 on: March 04, 2004, 11:57:57 pm »

Great. Thanks Casper. It's gone.
Logged
imagine. conceive. embrace.
www.coldfingersolutions.com
Pages: [1]   Go Up
 

Page created in 0.155 seconds with 20 queries.