Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: extra / in url after bridge  (Read 3910 times)

0 Members and 1 Guest are viewing this topic.

dreams83

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Posts: 54
extra / in url after bridge
« on: March 09, 2007, 08:58:01 pm »

I have  cpg1.4 modpack by Stramm the latest version with the lastest cpg and after bridging it with phpbb 2.0.22 i get an extra / in the url

like after signing in i get the address like:

http://www.ehmongmusic.com//?sid=5c44c266dc023112731d746e974f461d

it works but just doesn't look right. It is suppose to be like that?


Thank You
« Last Edit: March 09, 2007, 11:34:31 pm by Nibbler »
Logged

nickfzx

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 285
Re: extra / in url after bridge
« Reply #1 on: March 09, 2007, 09:05:54 pm »

nice site btw

it doesn't matter that the 2 slashes are there...you could have 6 slashes there and it would still work the same.

Looking at your site I think it is an issue with the login redirect url set by phpbb.

you may notice that the url when you hit login says:
http://www.ehmongmusic.com/forum/login.php?redirect=..//

try altering that.
Logged

Nibbler

  • Guest
Re: extra / in url after bridge
« Reply #2 on: March 09, 2007, 09:17:24 pm »

Assuming this is not a modpack issue, you can remove the extra slash in bridge/phpbb2018.inc.php

Code: [Select]
$redirect = str_repeat('../', $levels) . trim($cpg['path'], '/') . '/';

Change it to

Code: [Select]
$redirect = str_repeat('../', $levels) . trim($cpg['path'], '/');
Logged

dreams83

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Posts: 54
Re: extra / in url after bridge
« Reply #3 on: March 09, 2007, 09:34:59 pm »

thank you

so if its not a problem i will just leave it be :-)
Logged

nickfzx

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 285
Re: extra / in url after bridge
« Reply #4 on: March 09, 2007, 09:37:09 pm »

i am fairly sure if you just opened login.php in your forum folder, located the redirect url and removed one of the slashes at the end it would fix the problem.
Logged

Nibbler

  • Guest
Re: extra / in url after bridge
« Reply #5 on: March 09, 2007, 09:56:58 pm »

No.
Logged

dreams83

  • Contributor
  • Coppermine regular visitor
  • ***
  • Offline Offline
  • Posts: 54
Re: extra / in url after bridge
« Reply #6 on: March 09, 2007, 11:26:04 pm »

replaced the code and it works now.

Thank You
Logged
Pages: [1]   Go Up
 

Page created in 0.017 seconds with 19 queries.