Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: photo_shop 1.3.3 after install all coppermine pages display as blank pages  (Read 8445 times)

0 Members and 1 Guest are viewing this topic.

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I installed this plugin and now all coppermine pages are rendering blank, no errors, just blank.

I have turned on php debugging and tested it with a simple flawed php script and it output an error, so the plugin is not throwing an error.

Coppermine version 1.4.10
Photo_shop plugin version 1.3.3
php version 4.4.0-6.22
Apache version 2.0.54-10.8

I went through and installed all the available modules for php I could think of with no success.

If you could help me out that would be great
« Last Edit: March 03, 2007, 03:56:38 pm by Nibbler »
Logged

Nibbler

  • Guest

Post a link.
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

http://www.victoriaroberts.ca/~baracek/cpg1410/

there's absolutely nothing coming out in the page source, so you're not going to see much.
Logged

Nibbler

  • Guest

It's not absolutely nothing, it's 2 newline characters. Go through the plugin's files and remove the newlines after the closing ?> at the end of each file.
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

Two files had new lines after the closing ?>

photo_shop_cart.php
photo_shop_zip.php

If you go to the above link we still have a blank page
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

Thanks for the quick replies by the way, It's been a couple days of playing trying to get this to work.

If I rename the plugin directory photo_shop to photo_shop.bak the pages start to render again.
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

The Coppermine page is hosted on a linux box by the way, is there any concerns with carriage return / newline conversions in php scripts?
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I also found new lines at the end of the language files

english.php
dutch.php
german.php

Still rendering blank pages though.
Logged

kiig

  • Contributor
  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Gender: Male
  • Posts: 141
    • Igel's Journaler

If you dare :-) PM me with the ftp address and login info, - and I'll take a look and see if I can find someting.

Kim Igel.

can't garantee you anything though, - and maybe someone else (more experienced than me) will come forward and offer a 'review' of the files ?



Logged
Kim Igel
http://igel.it (Personal playground) or http://foto.igel.it (Paypal shop-site)

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

you checked plugins/photo_shop/include/functions.inc.php too

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I looked back and yes I did remove the blank lines from the end of functions.inc.php (thank goodness for auto backups from my text editor)

It is really weird that it's not throwing any errors, and there are lots of reports of people installing it with no problems.

First I tried to install it in 1.4.8 with no luck, so I upgraded to 1.4.10, still same behaviour.  I then created this testbed and applied the mod pack by stramm thinking there might be a depedency, still same behaviour.

I don't have any problems upgrading any of the software on the box if that would be helpfull, can someone with a linux installation using the photo_shop plugin list their installed app versions and I'll try and update to that setup and see what happens.

Apache isn't throwing any errors either, however from my location I don't have access to the apache log, so I'll double check and post the log file if I notice anything.

Thanks for the suggestions.
Logged

Nibbler

  • Guest

Are you using a bridge by any chance? I just installed the plugin on my machine and the shop's tables got created in the wrong database. See if that happened to you.

@Stramm: mysql_query -> cpg_db_query ;)
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

Sorry, I'm not using a bridge, just plain Coppermine 1.4.10, nothing complicated.

I did the install of Coppermine, browsed to plugins, uploaded the 1.3.3 photo_shop plugin, installed it, and when it tried to reload the plugin manager page right after installing photo_shop it came back blank.


Paul
Logged

Nibbler

  • Guest

I don't know if you responded to kiig's offer but I can look into the problem if you happy to permit me access.

For reference my dev machine:
Coppermine version 1.4.10
Photo_shop plugin version 1.3.3
php version 5.1.6
Apache version 2.2.3
FC6 Linux

Works fine.
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I created a test bed for you guys, sent nibbler the login and pass, if he can't figure out the problem, I'll send it on to you Kiig.
Don't want you both changing stuff at the same time.
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I did an update this morning and a few PHP updates came down, the plugin is now working, I'll try and figure out exactly what update made it work.  Thanks for all your help.

Bara Cek
Logged

Bara Cek

  • Coppermine newbie
  • Offline Offline
  • Posts: 12

I'm now running

apache2-mod_php4 4.4.0-6.22
php4 4.4.0-6.22
php4-exif 4.4.0-6.22
php4-fastcgi 4.4.0-6.22
php4-gd 4.4.0-6.22
[
php4-wddx 4.4.0-6.22
[
php4-session 4.4.0-6.22

One of these updates fixed the problem.
Logged

Nibbler

  • Guest

OK, thanks for resolving the thread.
Logged

Stramm

  • Dev Team member
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt

php4-session, however that's quite standard.
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 19 queries.