Advanced search  

News:

cpg1.5.48 Security release - upgrade mandatory!
The Coppermine development team is releasing a security update for Coppermine in order to counter a recently discovered vulnerability. It is important that all users who run version cpg1.5.46 or older update to this latest version as soon as possible.
[more]

Pages: [1]   Go Down

Author Topic: URI and Exif Information  (Read 6175 times)

0 Members and 1 Guest are viewing this topic.

george36

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
URI and Exif Information
« on: February 27, 2007, 09:20:41 pm »

Hello,

I am a newbiee at the coppermine world as I just started and I do face a lil problem which you may help me to solve.

When I upload and photo the EXIF info is displayed correctly.

When I upload a photo using URI the exif info is NOT displayed despite the fact that the EXIF exists in the file.

Any ideas?

Thank you in advance for you help.

George
« Last Edit: March 05, 2007, 05:08:15 pm by GauGau »
Logged

Nibbler

  • Guest
Re: URI and Exif Information
« Reply #1 on: February 27, 2007, 09:26:44 pm »

Can you post the URI?
Logged

george36

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: URI and Exif Information
« Reply #2 on: February 27, 2007, 09:29:31 pm »

Can you post the URI?

Sure I can...
One out of the many I tried.

http://i5.pbase.com/o6/51/498251/1/70973227.RDMloqRF.Team51.jpg

Thank you Nibbler
Logged

Nibbler

  • Guest
Re: URI and Exif Information
« Reply #3 on: February 27, 2007, 09:36:53 pm »

That works as expected on my test gallery. Make sure you have the latest version of Coppermine. Have you applied any EXIF or upload related mods? Can you post a link to your gallery?
Logged

george36

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: URI and Exif Information
« Reply #4 on: February 27, 2007, 09:40:18 pm »

Sure I can..

[removed as requested - Nibbler]

No I did not upload any exif related plugin. Only stramms mod.
« Last Edit: February 28, 2007, 12:13:09 am by Nibbler »
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: URI and Exif Information
« Reply #5 on: February 28, 2007, 04:40:13 pm »

tested your link on my test gallery as well, no problem so far with URI+exif

Code: [Select]
Filename: 70973227_RDMloqRF_Team51.jpg
Album name: Stramm (127.0.0.1[127.0.0.1]) / Pers alb of stramm
File Size: 46 KB
Date added: Feb 28, 2007
Dimensions: 800 x 532 pixels
Displayed: 0 times
Digital Zoom Ratio: 1
Exif Image Height: 532 pixels
Exif Image Width: 800 pixels
Exposure Mode: 0
Exposure Time: 25/1000 sec
Flash: No Flash
Flash Pix Version: version 1
Gain Control: 0
Resolution Unit: Inch
Saturation: 0
Sharpness: 1
Y Resolution: 300
YCbCrPositioning: Center of Pixel Array

older versions of the modpack had issues with exif...

Gephri

  • Coppermine frequent poster
  • ***
  • Offline Offline
  • Posts: 235
Re: URI and Exif Information
« Reply #6 on: March 01, 2007, 09:20:37 am »

Nibbler (or other), I have the same problem - limited EXIF info available for viewing (file name thru URL).
I have installed an "upload related mod" (CPG MassImport)
Not getting all the info-rich stuff (Digital Zoom Ratio..., Exif Image Height..., etc)

Any ideas of how to fix?
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: URI and Exif Information
« Reply #7 on: March 01, 2007, 06:54:56 pm »

please verify if the plugin is the culprit and if so, post your problem in the plugins board

george36

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: URI and Exif Information
« Reply #8 on: March 02, 2007, 01:16:43 am »

tested your link on my test gallery as well, no problem so far with URI+exif
older versions of the modpack had issues with exif...

I did a test two by setting up a test gallery with the mod and it is working perfectly.
However the problem remains on my gallery.

Any idea how to troubleshoot this will be very much appreciated.

Thank you.

George.
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: URI and Exif Information
« Reply #9 on: March 02, 2007, 08:01:21 pm »

CPG + mass importer (+)
CPG + modpack        (+)
but
CPG + modpack + massimporter --> (-)

is that correct??
If so then the mass importer conflicts with the modpack. I haven't had a look at that plugins code. But I can name the problem. If you watermark an image then exif info gets deleted from that image (recompressing). Therefore the modpack reads the exif from the backup image (prefix orig_). If the plugin uses own code to add stuff and doesn't rely on CPG functions that may be the culprit.

george36

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: URI and Exif Information
« Reply #10 on: March 02, 2007, 08:35:27 pm »

Ok I did some trouble shooting just to determine when this occurs.

Actions.

1. Setup a domain installed mod and plugins. Result : Perfect Exif info is ok
2. Deleted all content from the domain including.
3. Re-installed coppermine ONLY and used URI to upload. Result : Exif info not displayed.
4. Re-installed coppermine not on the root but /test directory. Uploaded file with URI. Result : Exif info displayed.

So it is not the mod, nor the plugins but coppermine itself. Why? I do not know.

Anyone willing to help?

Thank you.

PS. I deleted .htacess and some exif info are displayed on my galleries now but not all (uploaded with URI only). If I uploaded the file everything is ok.

George.
Logged

george36

  • Coppermine newbie
  • Offline Offline
  • Posts: 8
Re: URI and Exif Information
« Reply #11 on: March 02, 2007, 08:36:20 pm »

Stramm,

I believe this thread must go back to CPG support, as the mod is ok and not causing issues on this.
Logged

Stramm

  • Moderator
  • Coppermine addict
  • ****
  • Country: 00
  • Offline Offline
  • Gender: Male
  • Posts: 6006
    • Bettis Wollwelt
Re: URI and Exif Information
« Reply #12 on: March 04, 2007, 02:33:00 pm »

I'd say it's better to start a new thread there with all the info and everything you tried in one single post
Pages: [1]   Go Up
 

Page created in 0.027 seconds with 20 queries.