Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Issue with uploaded image - preview not showing up thus image not being uploaded  (Read 4609 times)

0 Members and 1 Guest are viewing this topic.

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

Hello,

I am having an issue getting new images to upload properly. I have provided screen shots to help with my explanation.

Step 1: Upload the image
(http://i177.photobucket.com/albums/w218/mugglenet_help/image1.png)
Step 2: Receive the message that the image has been uploaded successfully
(http://i177.photobucket.com/albums/w218/mugglenet_help/image2.png)
Step 3: Add the image to an album
(http://i177.photobucket.com/albums/w218/mugglenet_help/image3.png)
This is where the error is: The preview image does not show up. I went under element properties with Firefox and retrieved this information. I logged onto the FTP account and went inside the proper folder and the image is there, simply under a different 8 character extraction of an md5 hash. Image is provided below.
(http://i177.photobucket.com/albums/w218/mugglenet_help/image4.png)
Step 4: Add information about the image
(http://i177.photobucket.com/albums/w218/mugglenet_help/image5.png)
Step 5: Image was not placed, and the image was placed?
(http://i177.photobucket.com/albums/w218/mugglenet_help/image6.png)

The image fails to upload any time one attempts to upload it.

What is a resolution to this issue that can be applied soon. Thank You.

Michael
« Last Edit: February 04, 2007, 05:57:16 pm by eruss »
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

I have already researched that page. No information on how to fix the issue is present.

Further assistance?
Logged

Nibbler

  • Guest

Please do as suggested so that we can help you.

Quote
When asking for support on the coppermine forum, post a link to your site and a test user account (the test user mustn't be in the admin group!) with upload privileges, with the above mentioned settings in place - this way, supporters can see the error messages as well. Do not post debug_output unless requested.

When people have issues with uploading and decide to post their question on the Coppermine support board, they usually are told to read this upload troubleshooting section. Many of them fail to do so properly, which results in frustration both for users as well as supporters. To make this absolutely clear: the above mentioned steps are absolutely mandatory, no matter what skill level you have, no matter what upload method you have troubles with. Failing to do exactly as suggested will result in your request for help being ignored. Yes, this applies to you. We mean it!
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

If I had authorization to create a new account I would have done so. I did read the documentation. But since that is out of the question due to security reasons from higher officials of the server, screen caps and text explanations are all I can do for you.

If you need to have the issue explained in more detail, please let me know. But as far as I am concerned, I believe I have the issue pretty clear enough to understand.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

If I had authorization to create a new account I would have done so. I did read the documentation. But since that is out of the question due to security reasons from higher officials of the server, screen caps and text explanations are all I can do for you.
Either get permissions from those authorities or fix the issue for yourself. How could we possibly help if you're not doing as suggested - we're not mind readers. You're suppossed to switch to single file uploads with debug_mode on. This should give you a better error message. The screenshots cleraly show that you have not done as suggested. Do exactly as suggested in the upload troubleshooting section, we haven't provided those steps just for fun. They are the only possible method to find out what is wrong.
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

Notices
/include/picmgmt.inc.php

    * Notice line 205: Undefined index: OS
    * Warning line 225: unlink(./albums/edit/preview_691cb6c4.jpg) [function.unlink]: No such file or directory

/include/functions.inc.php

    * Notice line 2672: Undefined variable: i
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

Okay, so I now have access to give you an account. If you could IM me, I would feel more secure about it. AIM is maapt88.
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

I actually sent you a PM.
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

Even better, I found the solution. The image library wasn't GD 2.X.X - it was ImageMagik and that causes everything not to work.
Logged

eruss

  • Supporter
  • Coppermine frequent poster
  • ****
  • Country: us
  • Offline Offline
  • Gender: Male
  • Posts: 105

Even better, I found the solution. The image library wasn't GD 2.X.X - it was ImageMagik and that causes everything not to work.

If you remove the path for ImageMagick, you will use GD by default.  Or you can find the proper path to ImageMagick.

http://coppermine-gallery.net/demo/cpg14x/docs/faq.htm#WhatIsGD

http://coppermine-gallery.net/demo/cpg14x/docs/faq.htm#whatIsImageMagick
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de

Actually, you have to switch "Method for resizing images" to "GD2" in Coppermine's config. Issue solved?
Logged

michael@mugglenet.com

  • Coppermine newbie
  • Offline Offline
  • Posts: 8

Yes, thank you.
Logged
Pages: [1]   Go Up
 

Page created in 0.023 seconds with 20 queries.