Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Album list not showing in the main page.  (Read 5615 times)

0 Members and 1 Guest are viewing this topic.

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Album list not showing in the main page.
« on: April 06, 2007, 04:05:06 am »

The content of the main page seems to be fine, it says
breadcrumb/catlist/alblist/random,2/lastup,2

When I tried alblist by itself, nothing was showing... any clue?
« Last Edit: April 09, 2007, 09:52:07 am by GauGau »
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Album list not showing in the main page.
« Reply #1 on: April 06, 2007, 12:35:19 pm »

As suggested in the documentation, you need alblist and catlist:
Quote
Unless you really know what you are doing you should always keep catlist and alblist in "the content of the main page", as they make up the core parts of the index page or any gallery site, for that matter.
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Album list not showing in the main page.
« Reply #2 on: April 06, 2007, 04:52:09 pm »

As suggested in the documentation, you need alblist and catlist:

Yeah they are both there right now and it's not showing the album list. What I meant was that I tried alblist by itself to see if it would show because it wasn't showing any albums, and nothing came up.

Right now it has the whole default thing breadcrumb/catlist/alblist/random,2/lastup,2, and everything is showing up fine but the alblist
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Album list not showing in the main page.
« Reply #3 on: April 06, 2007, 10:45:01 pm »

Post a link to your gallery.
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Album list not showing in the main page.
« Reply #5 on: April 07, 2007, 01:51:33 am »

I have no clue =\
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Album list not showing in the main page.
« Reply #6 on: April 07, 2007, 02:08:35 am »

I found out that it shows the albums that are -not- inside categories, like I just did right now.
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Album list not showing in the main page.
« Reply #7 on: April 07, 2007, 11:19:50 am »

It seems that you don't have categories set up. All your albums appear to reside within the root category. Are you 100% sure that you actually have categories?
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Album list not showing in the main page.
« Reply #8 on: April 07, 2007, 06:50:16 pm »

Not right now, I had to delete the categories in order to be able to show all the albums, I am creating now so next time you visit the site you can see no albums show below it (and they should)
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Album list not showing in the main page.
« Reply #9 on: April 08, 2007, 05:06:00 am »

Did you see? I think it's related to the theme because I installed from scratch and as soon as I installed the theme I'm using, the album list stopped showing
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Album list not showing in the main page.
« Reply #10 on: April 08, 2007, 02:31:34 pm »

Works as expected for me: there is a category (being displayed on the gallery's start page) that contains an album

Did you read the announcement thread for the theme "i-feel-dirty" that you are using? There are some settings in the theme that override config setting. If you don't want the theme to override your default settings, remove the corresponding lines in themes/i-feel-dirty/theme.php:
$CONFIG['max_film_strip_items'] = 4; //overrides the number of thumbnails.
$CONFIG['thumbcols'] = 4; //overrides the number of columns for thumbnails.
$CONFIG['main_table_width'] = '100%'; //overrides the Width of the main table (pixels or %).
$CONFIG['picture_table_width'] = '100%'; //overrides the Width of the table for file display (pixels or %).
$CONFIG['album_list_cols'] = 3; // sets "Number of columns for the album list = 3"
$CONFIG['first_level'] = 0; //sets "Show first level album thumbnails in categories = no".
Logged

morgue

  • Coppermine novice
  • *
  • Offline Offline
  • Posts: 28
Re: Album list not showing in the main page.
« Reply #11 on: April 08, 2007, 09:27:19 pm »

Thanks man, I changed this line from
$CONFIG['first_level'] = 0; //sets "Show first level album thumbnails in categories = no".

to
$CONFIG['first_level'] = 1; //sets "Show first level album thumbnails in categories = no".

and it worked fine, it seems to be like it didn't brake anything on the theme, if something happens I'll update this thread for future reference.

:D
Logged

Joachim Müller

  • Dev Team member
  • Coppermine addict
  • ****
  • Offline Offline
  • Gender: Male
  • Posts: 47843
  • aka "GauGau"
    • gaugau.de
Re: Album list not showing in the main page.
« Reply #12 on: April 09, 2007, 09:52:59 am »

You could as well have deleted that line. If you do, the config setting isn't being overridden and the setting from the config is being taken into account.
Logged
Pages: [1]   Go Up
 

Page created in 0.021 seconds with 20 queries.