Advanced search  

News:

CPG Release 1.6.26
Correct PHP8.2 issues with user and language managers.
Additional fixes for PHP 8.2
Correct PHP8 error with SMF 2.0 bridge.
Correct IPTC supplimental category parsing.
Download and info HERE

Pages: [1]   Go Down

Author Topic: Memory usage with Coppermine  (Read 2859 times)

0 Members and 1 Guest are viewing this topic.

baden32

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Memory usage with Coppermine
« on: January 22, 2007, 09:32:06 pm »

I installed Coppermine gallery on my server (hosting done by my provider, virtual server Plesk). Everything is working fine (installation, upload and admin).
My only and BIG problem is the memory usage!
My gallery should send about 12'000 pages/photos per day. It clearly seems that during the day the performance is decreasing very fast and the system statistics show the following:

Memory UsageTotal Used Free Shared Buffer Cached Usage
5.85 GB 5.72 GB 133.71 MB 0 B 1.10 GB 1.62 GB 97.77%     
 
Swap usageTotal Used Free Usage
12.70 GB 9.16 GB 3.53 GB 72.18%

Is that a problem with CPG (memory allocated not released?) or are some minimum system values are recommended (however I would expect 6GB memory are enough ???)?

Thank you in advance for your support.
 
Logged

Nibbler

  • Guest
Re: Memory usage with Coppermine
« Reply #1 on: January 22, 2007, 09:38:21 pm »

All memory used by Coppermine is released automatically when the script ends. You would need to provide more detailed information for me to be able to advise anything.
Logged

baden32

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Memory usage with Coppermine
« Reply #2 on: January 22, 2007, 10:01:31 pm »

Thank you for your feedback. I would also expect that all resources are released, but why the memory usage is so high.
What kind of additional information would you need in order to advise?
Logged

Nibbler

  • Guest
Re: Memory usage with Coppermine
« Reply #3 on: January 22, 2007, 10:18:29 pm »

For a start, what operating system are you using? Determine what is actually using the memory (probably either MySQL or your http server). If you are on a virtual server then the data you posted might well be the memory usage for the entire physical server, not just your site.
Logged

baden32

  • Coppermine newbie
  • Offline Offline
  • Posts: 3
Re: Memory usage with Coppermine
« Reply #4 on: January 22, 2007, 10:40:37 pm »

The basic info I can find is:
CPU GenuineIntel, Intel(R) Xeon(TM) CPU 3.40GHz
Version psa v7.5.4_build75051014.16 os_FedoraCore 2
OS Linux 2.4.20-021stab028.19.777-enterprise

I can ask my Provider tomorrow morning if you need more info.

However I suppose the data I posted are only for my virtual server. If not that means my Provider is hosting website on a server where 99% of the memory is used (a change would be required asap in this case...).
Logged
Pages: [1]   Go Up
 

Page created in 0.015 seconds with 19 queries.